Find the answer to your Linux question:
Results 1 to 9 of 9
Hi I just installed Backtrack 5 to my laptop hdd, and am going through adding some useful apps. I installed Flash by doing the apt-get install flashplugin-nonfree command. It worked, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Posts
    45

    Updated to latest Flash, but its not working?


    Hi

    I just installed Backtrack 5 to my laptop hdd, and am going through adding some useful apps.

    I installed Flash by doing the apt-get install flashplugin-nonfree command.

    It worked, but after a reboot it's no longer working - all Flash sites (youtube, dailymotion) say Flash needs to be installed.

    Apt-get says the newest version is on.

    Using FF11 (latest).

    Help!

  2. #2
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    4,135
    As you may have noticed Flash Player does not work on Backtrack 5, so in order to fix this we first need to remove the current flash player by issuing the following commands:
    Install Flash Player - BackTrack Linux

    I don't run BackTrack but wikis are wonderful when done up right like this one is.
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  3. #3
    Just Joined!
    Join Date
    Feb 2005
    Posts
    45
    Thanks!

    I followed the instructions but I've having some trouble.

    Step 1:
    root@bt:~# apt-get purge flashplugin-nonfree flashplugin-installer gnash gnash-common mozilla-plugin-gnash swfdec-mozilla
    root@bt:~# rm -f /usr/lib/firefox/plugins/*flash*
    root@bt:~# rm -f /usr/lib/firefox-addons/plugins/*flash*
    root@bt:~# rm -f /usr/lib/mozilla/plugins/*flash*
    root@bt:~# rm -f ~/.mozilla/plugins/*flash*so
    root@bt:~# rm -rfd /usr/lib/nspluginwrapper

    This was all fine.

    Step 2:
    Download Flash x64 - fine
    Download Flash Player - link is broken.

    Instead I went to Adobe site and downloaded the latest Flash Player

    root@bt:~# tar xvfz flashplayer10_2_p3_64bit_linux_111710.tar.gz
    root@bt:~# chown root:root libflashplayer.so
    root@bt:~# chmod 644 libflashplayer.so
    root@bt:~# cp -f libflashplayer.so /usr/lib/mozilla/plugins/
    root@bt:~# rm -rf libflashplayer.so
    root@bt:~# ln -s /usr/lib/mozilla/plugins/libflashplayer.so /usr/lib/firefox/plugins/

    All OK

    Now for Flash Player:

    root@bt:~# tar xvfz install_flash_player_10_linux.tar.gz
    root@bt:~# mkdir ~/.mozilla/plugins
    root@bt:~# mv -f libflashplayer.so ~/.mozilla/plugins/
    root@bt:~# ln -s /usr/lib/mozilla/plugins/libflashplayer.so /usr/lib/firefox-addons/plugins/
    root@bt:~# ln -s /usr/lib/mozilla/plugins/libflashplayer.so /usr/lib/xulrunner-addons/plugins/

    There is no such directory as /usr/lib/firefox-addons/plugins

    Instead the directory struture is /usr/lib/firefox/plugins

    So I changed it to this

    Restarted Mozilla, still not working?

  4. #4
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    4,135
    WARNING: BE SURE TO CONFIGURE NOSCRIPT PROPERLY OR YOUR FLASH VIDEOS WILL NOT WORK!
    Last thing on the page in the Wiki. Also. I would have done a

    Code:
    harry@biker:~$ cd /usr/lib
    harry@biker:/usr/lib$ ls /usr/lib
    ao                                          libMateCORBA-imodule-2.so.0
    apt                                         libMateCORBA-imodule-2.so.0.0.0
    arj                                         libmate-desktop-2.so.17
    aspell                                      libmate-desktop-2.so.17.1.4
    atril                                       libmategcr.so.0
    avahi                                       libmategcr.so.0.0.0
    awk                                         libmategp11.so.0
    babl-0.0                                    libmategp11.so.0.0.0
    bonobo                                      libmatekbd.so.4
    caca                                        libmatekbd.so.4.2.0
    caja                                        libmatekbdui.so.4
    checkinstall                                libmatekbdui.so.4.2.0
    compat-ld                                   libmate-keyring.so.1
    conky                                       libmate-keyring.so.1.0.1
    ConsoleKit                                  libmate-media-profiles.la
    coreutils                                   libmate-media-profiles.so
    cups                                        libmate-media-profiles.so.0
    dbus-1.0                                    libmate-media-profiles.so.0.0.0
    dconf                                       libmate-menu.so.2
    dillo                                       libmate-menu.so.2.4.9
    directfb-1.2-9                              libmatenotify.so.1
    dpkg                                        libmatenotify.so.1.2.3
    dri                                         libmate-panel-applet-2.so.1
    eject                                       libmate-panel-applet-2.so.1.0.1
    emacsen-common                              libmate-panel-applet-3.so.1
    enchant                                     libmate-panel-applet-3.so.1.0.1
    eom                                         libmateui-2.so.0
    firefox                                     libmateui-2.so.0.196.4
    flashplugin-nonfree                         libmatevfs-2.so.0
    gcc                                         libmatevfs-2.so.0.196.4
    gcj                                         libmateweather.so.1
    gegl-0.0                                    libmateweather.so.1.6.9
    gettext                                     libmate-window-settings.la
    gimp                                        libmate-window-settings.so
    gio                                         libmate-window-settings.so.1
    girepository-1.0                            libmate-window-settings.so.1.0.0
    glade3                                      libmenu-cache1
    glib-networking                             libmenu-cache.so.1
    gnome-keyring                               libmenu-cache.so.1.0.0
    gnome-settings-daemon-2.0                   libmhash.so.2
    gnome-settings-daemon-3.0                   libmhash.so.2.0.1
    gnome-vfs-2.0                               libmimic.so.0
    gnupg                                       libmimic.so.0.0.1
    gold-ld                                     libmodplug.so.1
    gpm                                         libmodplug.so.1.0.0
    gpointing-device-settings                   libmozjs.so.10d
    GraphicsMagick-1.3.12                       libmozjs.so.8d
    grub                                        libmpeg2convert.so.0
    gtk-2.0                                     libmpeg2convert.so.0.0.0
    gtk-3.0                                     libmpeg2.so.0
    gvfs                                        libmpeg2.so.0.0.0
    gxine                                       libmtp.so.9
    hal                                         libmtp.so.9.0.2
    i386-linux-gnu                              libmusicbrainz.so.4
    i686                                        libmusicbrainz.so.4.0.3
    iceape                                      libmythes-1.2.so.0
    iceweasel                                   libmythes-1.2.so.0.0.0
    ImageMagick-6.6.9                           libneon-gnutls.so.27
    imlib2                                      libneon-gnutls.so.27.2.6
    ispell                                      libnetpbm.so.10
    jitsi                                       libnetpbm.so.10.0
    jvm                                         libnetsnmpagent.so.15
    klibc                                       libnetsnmpagent.so.15.1.2
    lapack                                      libnetsnmphelpers.so.15
    ldscripts                                   libnetsnmphelpers.so.15.1.2
    liba52-0.7.4.so                             libnetsnmpmibs.so.15
    libaa.so.1                                  libnetsnmpmibs.so.15.1.2
    libaa.so.1.0.4                              libnetsnmp.so.15
    libao.a                                     libnetsnmp.so.15.1.2
    libao.so                                    libnetsnmptrapd.so.15
    libao.so.4                                  libnetsnmptrapd.so.15.1.2
    libao.so.4.0.0                              libnfnetlink.so.0
    libapt-inst.so.1.2                          libnfnetlink.so.0.2.0
    libapt-inst.so.1.2.0                        libnl-cli.so.3
    libapt-pkg.so.4.10                          libnl-cli.so.3.0.0
    libapt-pkg.so.4.10.1                        libnl-genl.so.3
    libart_lgpl_2.so.2                          libnl-genl.so.3.0.0
    libart_lgpl_2.so.2.3.21                     libnl-nf.so.3
    libaspell.so.15                             libnl-nf.so.3.0.0
    libaspell.so.15.2.0                         libnl-route.so.3
    libasprintf.a                               libnl-route.so.3.0.0
    libasprintf.so                              libnl.so.3
    libasprintf.so.0                            libnl.so.3.0.0
    libasprintf.so.0.0.0                        libntfs-3g.so.80
    libatkmm-1.6.so.1                           libntfs-3g.so.80.0.0
    libatkmm-1.6.so.1.1.0                       libntfs.so.10
    libatrildocument.so.3                       libntfs.so.10.0.0
    libatrildocument.so.3.0.0                   libofa.so.0
    libatrilview.so.3                           libofa.so.0.0.0
    libatrilview.so.3.0.0                       libogg.so.0
    libaudiofile.so.0                           libogg.so.0.7.1
    libaudiofile.so.0.0.2                       libopcodes-2.22-system.so
    libavcodec.so.52                            libopenjpeg-2.1.3.0.so
    libavcodec.so.52.123.0                      libopenjpeg.so.2
    libavutil.so.50                             libopenobex.so.1
    libavutil.so.50.43.0                        libopenobex.so.1.5.0
    libbabl-0.0.so.0                            libopenraw.so.1
    libbabl-0.0.so.0.22.0                       libopenraw.so.1.5.2
    libbfd-2.22-system.so                       libopenspc.so.0
    libbind9.so.60                              libopenspc.so.0.0.3
    libbind9.so.60.0.4                          libORBit-2.so.0
    libbind9.so.80                              libORBit-2.so.0.1.0
    libbind9.so.80.0.3                          libORBitCosNaming-2.so.0
    libblas                                     libORBitCosNaming-2.so.0.1.0
    libblas.so.3gf                              libORBit-imodule-2.so.0
    libboolstuff-0.1.so.0                       libORBit-imodule-2.so.0.0.0
    libboolstuff-0.1.so.0.0.0                   liborc-0.4.so.0
    libboost_date_time.so.1.48.0                liborc-0.4.so.0.16.0
    libboost_filesystem.so.1.46.1               liborc-test-0.4.so.0
    libboost_filesystem.so.1.48.0               liborc-test-0.4.so.0.16.0
    libboost_iostreams.so.1.46.1                libpangomm-1.4.so.1
    libboost_iostreams.so.1.48.0                libpangomm-1.4.so.1.0.30
    libboost_program_options.so.1.46.1          libpaper.so.1
    libboost_program_options.so.1.48.0          libpaper.so.1.1.2
    libboost_system.so.1.46.1                   libpcsclite.so.1
    libboost_system.so.1.48.0                   libpcsclite.so.1.0.0
    libbs2b.so.0                                libperl.so.5.14
    libbs2b.so.0.0.0                            libperl.so.5.14.2
    libburn.so.4                                libpiano.so.0
    libburn.so.4.73.0                           libpiano.so.0.0.0
    libcaca.so.0                                libplist.so.1
    libcaca++.so.0                              libplist.so.1.1.8
    libcaca.so.0.99.17                          libpolkit-gtk-mate-1.so.0
    libcaca++.so.0.99.17                        libpolkit-gtk-mate-1.so.0.0.0
    libcairomm-1.0.so.1                         libpoppler-glib.so.6
    libcairomm-1.0.so.1.4.0                     libpoppler-glib.so.6.0.0
    libcaja-extension.so.1                      libpoppler.so.13
    libcaja-extension.so.1.2.0                  libpoppler.so.13.0.0
    libcanberra-0.28                            libprojectM.so.2
    libcanberra-gtk3.so.0                       libprojectM.so.2.0.1
    libcanberra-gtk3.so.0.1.8                   libproxy
    libcanberra-gtk.so.0                        libproxy.so.0
    libcanberra-gtk.so.0.1.8                    libproxy.so.0.0.0
    libcanberra.so.0                            libpspell.so.15
    libcanberra.so.0.2.5                        libpspell.so.15.2.0
    libcap-ng.so.0                              libpulsecore-1.1.so
    libcap-ng.so.0.0.0                          libpyglib-2.0-python2.6.so.0
    libcdaudio.so.1                             libpyglib-2.0-python2.6.so.0.0.0
    libcdaudio.so.1.0.0                         libpyglib-2.0-python2.7.so.0
    libcdda_interface.so.0                      libpyglib-2.0-python2.7.so.0.0.0
    libcdda_interface.so.0.10.2                 libpyglib-gi-2.0-python2.6.so
    libcdda_paranoia.so.0                       libpyglib-gi-2.0-python2.6.so.0
    libcdda_paranoia.so.0.10.2                  libpyglib-gi-2.0-python2.6.so.0.0.0
    libcddb.so.2                                libpyglib-gi-2.0-python2.7.so
    libcddb.so.2.2.3                            libpyglib-gi-2.0-python2.7.so.0
    libcdio_cdda.so.0                           libpyglib-gi-2.0-python2.7.so.0.0.0
    libcdio_cdda.so.0.0.5                       libpython2.7.so.1
    libcdio_paranoia.so.0                       libpython2.7.so.1.0
    libcdio_paranoia.so.0.0.3                   libqmmp.so.0
    libcdio.so.10                               libqmmp.so.0.5.4
    libcdio.so.10.0.0                           libqmmpui.so.0
    libcelt0.so.0                               libqmmpui.so.0.5.4
    libcelt0.so.0.0.0                           libQtCLucene.so.4
    libCHART-1.6.so.0                           libQtCLucene.so.4.7
    libCHART-1.6.so.0.0.44                      libQtCLucene.so.4.7.4
    libchromeXvMCPro.so                         libQtCore.so.4
    libchromeXvMCPro.so.1                       libQtCore.so.4.7
    libchromeXvMCPro.so.1.0.0                   libQtCore.so.4.7.4
    libchromeXvMC.so                            libQtDBus.so.4
    libchromeXvMC.so.1                          libQtDBus.so.4.7
    libchromeXvMC.so.1.0.0                      libQtDBus.so.4.7.4
    libcolamd.so.2.7.1                          libQtDesignerComponents.so.4
    libcpufreq.so.0                             libQtDesignerComponents.so.4.7
    libcpufreq.so.0.0.0                         libQtDesignerComponents.so.4.7.4
    libcucul.so.0                               libQtDesigner.so.4
    libcucul++.so.0                             libQtDesigner.so.4.7
    libcucul.so.0.99.17                         libQtDesigner.so.4.7.4
    libcucul++.so.0.99.17                       libQtGui.so.4
    libdaemon.so.0                              libQtGui.so.4.7
    libdaemon.so.0.5.0                          libQtGui.so.4.7.4
    libdca.so.0                                 libQtNetwork.so.4
    libdca.so.0.0.0                             libQtNetwork.so.4.7
    libdialog.a                                 libQtNetwork.so.4.7.4
    libdirect-1.2.so.9                          libQtOpenGL.so.4
    libdirect-1.2.so.9.0.1                      libQtOpenGL.so.4.7
    libdirectfb-1.2.so.9                        libQtOpenGL.so.4.7.4
    libdirectfb-1.2.so.9.0.1                    libQtScript.so.4
    libdjvulibre.so.21                          libQtScript.so.4.7
    libdjvulibre.so.21.3.0                      libQtScript.so.4.7.4
    libdns.so.69                                libQtSvg.so.4
    libdns.so.69.1.2                            libQtSvg.so.4.7
    libdns.so.81                                libQtSvg.so.4.7.4
    libdns.so.81.3.1                            libQtXml.so.4
    libdvbpsi.so.7                              libQtXml.so.4.7
    libdvbpsi.so.7.0.0                          libQtXml.so.4.7.4
    libdvdnavmini.so.4                          libquicktime1
    libdvdnavmini.so.4.2.0                      libquicktime.so.1
    libdvdnav.so.4                              libquicktime.so.1.0.0
    libdvdnav.so.4.2.0                          libquvi.so.0
    libdvdread.so.4                             libquvi.so.0.4.0
    libdvdread.so.4.2.0                         libraptor2.so.0
    libelf-0.152.so                             libraptor2.so.0.0.0
    libelf.so.0                                 librarian.so.0
    libelf.so.0.8.13                            librarian.so.0.0.0
    libelf.so.1                                 librasqal.so.3
    libenca.so.0                                librasqal.so.3.0.0
    libenca.so.0.5.1                            librdf.so.0
    libenchant.so.1                             librdf.so.0.0.0
    libenchant.so.1.6.0                         libreoffice
    libept.so.1                                 libresid-builder.so.0
    libept.so.1.0.5                             libresid-builder.so.0.0.1
    libevent-2.0.so.5                           librpmbuild.so.2
    libevent-2.0.so.5.1.5                       librpmbuild.so.2.0.1
    libexif-gtk.so.5                            librpmio.so.2
    libexif-gtk.so.5.0.0                        librpmio.so.2.0.1
    libexiv2.so.9                               librpmsign.so.0
    libexiv2.so.9.0.0                           librpmsign.so.0.0.1
    libexslt.so.0                               librpm.so.2
    libexslt.so.0.8.15                          librpm.so.2.0.2
    libfaac.so.0                                libschroedinger-1.0.so.0
    libfaac.so.0.0.0                            libschroedinger-1.0.so.0.11.0
    libfaad.a                                   libsemanage.so.1
    libfaad.so                                  libsgutils2.so.2
    libfaad.so.2                                libsgutils2.so.2.0.0
    libfaad.so.2.0.0                            libsidplay2.so.1
    libfam.so.0                                 libsidplay2.so.1.0.1
    libfam.so.0.0.0                             libsidplay.so.1
    libffmpegthumbnailer.so.4                   libsidplay.so.1.0.3
    libffmpegthumbnailer.so.4.0.7               libsigc-2.0.so.0
    libfftw3f.so.3                              libsigc-2.0.so.0.0.0
    libfftw3f.so.3.3.0                          libsigsegv.so.2
    libfftw3f_threads.so.3                      libsigsegv.so.2.0.2
    libfftw3f_threads.so.3.3.0                  libslp.so.1
    libfftw3l.so.3                              libslp.so.1.0.1
    libfftw3l.so.3.3.0                          libslv2.so.9
    libfftw3l_threads.so.3                      libslv2.so.9.2.0
    libfftw3l_threads.so.3.3.0                  libsnmp.so.15
    libfftw3.so.3                               libsnmp.so.15.1.2
    libfftw3.so.3.3.0                           libsoup-2.4.so.1
    libfftw3_threads.so.3                       libsoup-2.4.so.1.4.0
    libfftw3_threads.so.3.3.0                   libsoup-gnome-2.4.so.1
    libflite_cmulex.so.1                        libsoup-gnome-2.4.so.1.4.0
    libflite_cmulex.so.1.4                      libsox.so.1
    libflite_cmu_time_awb.so.1                  libsox.so.1.0.0
    libflite_cmu_time_awb.so.1.4                libspandsp.so.2
    libflite_cmu_us_awb.so.1                    libspandsp.so.2.0.0
    libflite_cmu_us_awb.so.1.4                  libspectre.so.1
    libflite_cmu_us_kal16.so.1                  libspectre.so.1.1.6
    libflite_cmu_us_kal16.so.1.4                libspeexdsp.so.1
    libflite_cmu_us_kal.so.1                    libspeexdsp.so.1.5.0
    libflite_cmu_us_kal.so.1.4                  libspeex.so.1
    libflite_cmu_us_rms.so.1                    libspeex.so.1.5.0
    libflite_cmu_us_rms.so.1.4                  libsqlite3.so.0
    libflite_cmu_us_slt.so.1                    libsqlite3.so.0.8.6
    libflite_cmu_us_slt.so.1.4                  libssh2.so.1
    libflite.so.1                               libssh2.so.1.0.1
    libflite.so.1.4                             libstartup-notification-1.so.0
    libflite_usenglish.so.1                     libstartup-notification-1.so.0.0.0
    libflite_usenglish.so.1.4                   libstlport_gcc.so.4.6
    libfontenc.so.1                             libswscale.so.0
    libfontenc.so.1.0.0                         libswscale.so.0.14.1
    libFOX-1.6.so.0                             libt1.so.5
    libFOX-1.6.so.0.0.44                        libt1.so.5.1.2
    libFS.so.6                                  libt1x.so.5
    libFS.so.6.0.0                              libt1x.so.5.1.2
    libftgl.so.2                                libtar.so.0
    libftgl.so.2.1.3                            libtar.so.0.0.0
    libfusion-1.2.so.9                          libtextcat.so.0
    libfusion-1.2.so.9.0.1                      libtextcat.so.0.0.0
    libgck-1.so.0                               libtheoradec.so.1
    libgck-1.so.0.0.0                           libtheoradec.so.1.1.4
    libgcr-3.so.1                               libtheoraenc.so.1
    libgcr-3.so.1.0.0                           libtheoraenc.so.1.1.2
    libgdkmm-2.4.so.1                           libtheora.so.0
    libgdkmm-2.4.so.1.1.0                       libtheora.so.0.3.10
    libgd.so.2                                  libthreadutil.so.2
    libgd.so.2.0.0                              libthreadutil.so.2.2.3
    libgdu.so.0                                 libts-0.0.so.0
    libgdu.so.0.0.0                             libts-0.0.so.0.1.1
    libgegl-0.0.so.0                            libtwolame.so.0
    libgegl-0.0.so.0.22.0                       libtwolame.so.0.0.0
    libgeoclue.so.0                             libungif.so.4
    libgeoclue.so.0.0.0                         libungif.so.4.1
    libGeoIP.so.1                               libungif.so.4.1.6
    libGeoIP.so.1.4.8                           libuniconf.so.4.6
    libGeoIPUpdate.so.0                         libunique-1.0.so.0
    libGeoIPUpdate.so.0.0.0                     libunique-1.0.so.0.100.6
    libgettextlib-0.18.1.so                     libuniquewm-1.2.so.9
    libgettextlib.so                            libuniquewm-1.2.so.9.0.1
    libgettextpo.a                              libuno_cppuhelpergcc3.so.3
    libgettextpo.so                             libuno_cppu.so.3
    libgettextpo.so.0                           libuno_purpenvhelpergcc3.so.3
    libgettextpo.so.0.5.1                       libuno_salhelpergcc3.so.3
    libgettextsrc-0.18.1.so                     libuno_sal.so.3
    libgettextsrc.so                            libupnp.so.3
    libgif.so.4                                 libupnp.so.3.0.5
    libgif.so.4.1                               libupower-glib.so.1
    libgif.so.4.1.6                             libupower-glib.so.1.0.1
    libgimp-2.0.so.0                            libusbmuxd.so.1
    libgimp-2.0.so.0.600.12                     libusbmuxd.so.1.0.7
    libgimpbase-2.0.so.0                        libustr-1.0.so.1
    libgimpbase-2.0.so.0.600.12                 libustr-1.0.so.1.0.4
    libgimpcolor-2.0.so.0                       libva.so.1
    libgimpcolor-2.0.so.0.600.12                libva.so.1.0.14
    libgimpconfig-2.0.so.0                      libva-x11.so.1
    libgimpconfig-2.0.so.0.600.12               libva-x11.so.1.0.14
    libgimpmath-2.0.so.0                        libvcdinfo.so.0
    libgimpmath-2.0.so.0.600.12                 libvcdinfo.so.0.2.0
    libgimpmodule-2.0.so.0                      libvga.a
    libgimpmodule-2.0.so.0.600.12               libvgagl.a
    libgimpthumb-2.0.so.0                       libvgagl.so
    libgimpthumb-2.0.so.0.600.12                libvgagl.so.1
    libgimpui-2.0.so.0                          libvgagl.so.1.4.3
    libgimpui-2.0.so.0.600.12                   libvga.so
    libgimpwidgets-2.0.so.0                     libvga.so.1
    libgimpwidgets-2.0.so.0.600.12              libvga.so.1.4.3
    libgiomm-2.4.so.1                           libvlccore.so.5
    libgiomm-2.4.so.1.3.0                       libvlccore.so.5.0.0
    libgirepository-1.0.so.1                    libvlc.so.5
    libgirepository-1.0.so.1.0.0                libvlc.so.5.3.0
    libgksu                                     libvorbisenc.so.2
    libgksu2.so.0                               libvorbisenc.so.2.0.8
    libgksu2.so.0.0.2                           libvorbisfile.so.3
    libglade                                    libvorbisfile.so.3.3.4
    libglade-2.0.so.0                           libvorbis.so.0
    libglade-2.0.so.0.0.7                       libvorbis.so.0.4.5
    libgladeui-1.so.9                           libvpx.so.0
    libgladeui-1.so.9.0.3                       libvpx.so.0.9
    libglibmm-2.4.so.1                          libvpx.so.0.9.7
    libglibmm-2.4.so.1.3.0                      libvte-2.90-9
    libglibmm_generate_extra_defs-2.4.so.1      libvte2_90.so.9
    libglibmm_generate_extra_defs-2.4.so.1.3.0  libvte2_90.so.9.3000.1
    libgme.so.0                                 libvte9
    libgme.so.0.5.3                             libvte.so.9
    libgnomevfs-2.so.0                          libvte.so.9.2800.2
    libgnomevfs-2.so.0.2400.4                   libwebkitgtk-1.0.so.0
    libgpds.so.0                                libwebkitgtk-1.0.so.0.11.2
    libgpds.so.0.1.0                            libwebkitgtk-3.0.so.0
    libGraphicsMagick.so.3                      libwebkitgtk-3.0.so.0.11.2
    libGraphicsMagick.so.3.6.0                  libwmii_hack.so
    libGraphicsMagickWand.so.2                  libwnck-1.so.22
    libGraphicsMagickWand.so.2.2.0              libwnck-1.so.22.3.31
    libgraphite2.so.2.0.0                       libwpd-0.9.so.9
    libgsm.so.1                                 libwpd-0.9.so.9.0.4
    libgsm.so.1.0.12                            libwpd-stream-0.9.so.9
    libgs.so.9                                  libwpd-stream-0.9.so.9.0.4
    libgs.so.9.05                               libwpg-0.2.so.2
    libgtkimageview.so.0                        libwpg-0.2.so.2.0.1
    libgtkimageview.so.0.0.0                    libwps-0.2.so.2
    libgtkmm-2.4.so.1                           libwps-0.2.so.2.0.4
    libgtkmm-2.4.so.1.1.0                       libwvbase.so.4.6
    libgtksourceview-2.0.so.0                   libwvdbus.so.4.6
    libgtksourceview-2.0.so.0.0.0               libwvstreams.so.4.6
    libgtop-2.0.so.7                            libwvutils.so.4.6
    libgtop-2.0.so.7.2.0                        libx264.so.112
    libHalf.so.6                                libx264.so.118
    libHalf.so.6.0.0                            libxapian.so.22
    libhal.so.1                                 libxapian.so.22.4.2
    libhal.so.1.0.0                             libXaw3d.so.6
    libhal-storage.so.1                         libXaw3d.so.6.1
    libhal-storage.so.1.0.0                     libxcb-keysyms.so.1
    libhardsid-builder.so.0                     libxcb-keysyms.so.1.0.0
    libhardsid-builder.so.0.0.1                 libxfce4kbd-private-2.so.0
    libhd.so.16                                 libxfce4kbd-private-2.so.0.0.0
    libhd.so.16.0                               libxfce4ui-1.so.0
    libhpip.so.0                                libxfce4ui-1.so.0.0.0
    libhpip.so.0.0.1                            libxfce4util.so.4
    libhpmud.so.0                               libxfce4util.so.4.1.1
    libhpmud.so.0.0.6                           libxfconf-0.so.2
    libhyphen.so.0                              libxfconf-0.so.2.0.0
    libhyphen.so.0.2.1                          libXfont.so.1
    libI810XvMC.so.1                            libXfont.so.1.4.1
    libI810XvMC.so.1.0.0                        libxine.so.1
    libicudata.so.48                            libxine.so.1.30.1
    libicudata.so.48.1.1                        libxine.so.2
    libicui18n.so.48                            libxine.so.2.1.0
    libicui18n.so.48.1.1                        libxkbfile.so.1
    libicuio.so.48                              libxkbfile.so.1.0.2
    libicuio.so.48.1.1                          libxklavier.so.16
    libicule.so.48                              libxklavier.so.16.2.0
    libicule.so.48.1.1                          libxml2.so.2
    libiculx.so.48                              libxml2.so.2.7.8
    libiculx.so.48.1.1                          libxmmsclient.so.6
    libicutest.so.48                            libxmmsclient.so.6.0.0
    libicutest.so.48.1.1                        libXRes.so.1
    libicutu.so.48                              libXRes.so.1.0.0
    libicutu.so.48.1.1                          libxslt.so.1
    libicuuc.so.48                              libxslt.so.1.1.26
    libicuuc.so.48.1.1                          libXvMC.so.1
    libid3tag.so.0                              libXvMC.so.1.0.0
    libid3tag.so.0.3.0                          libXvMCW.so.1
    libIDL-2.so.0                               libXvMCW.so.1.0.0
    libIDL-2.so.0.0.0                           libXxf86dga.so.1
    libiec61883.so.0                            libXxf86dga.so.1.0.0
    libiec61883.so.0.1.1                        libzbar.so.0
    libIex.so.6                                 libzbar.so.0.2.0
    libIex.so.6.0.0                             linux-boot-probes
    libijs-0.35.so                              linux-kbuild-2.6.36
    libIlmImf.so.6                              linux-kbuild-2.6.38
    libIlmImf.so.6.0.0                          locale
    libIlmThread.so.6                           lp_solve
    libIlmThread.so.6.0.0                       lxpanel
    libImath.so.6                               man-db
    libImath.so.6.0.0                           mate-applets
    libImlib2.so.1                              matecomponent
    libImlib2.so.1.4.4                          matecomponent-2.0
    libimobiledevice.so.2                       MateConf
    libimobiledevice.so.2.0.1                   matecorba-2.0
    libIntelXvMC.so.1                           mate-document-viewer
    libIntelXvMC.so.1.0.0                       mate-file-archiver
    libisccc.so.60                              mate-keyring
    libisccc.so.60.0.0                          mate-panel
    libisccc.so.80                              mate-power-manager
    libisccc.so.80.0.0                          mate-screensaver
    libisccfg.so.62                             mate-screensaver-dialog
    libisccfg.so.62.0.0                         mate-screensaver-gl-helper
    libisccfg.so.82                             mate-settings-daemon-1.2.0
    libisccfg.so.82.0.0                         mate-vfs
    libisc.so.62                                mate-vfs-2.0
    libisc.so.62.1.1                            mc
    libisc.so.83                                memtest86+
    libisc.so.83.0.1                            midbrowser
    libiso9660.so.7                             mime
    libiso9660.so.7.0.0                         mozilla
    libisofs.so.6                               mozilla-firefox
    libisofs.so.6.56.0                          nmap
    libixml.so.2                                notification-daemon
    libixml.so.2.0.4                            odbc
    libjacknet.so.0                             openssh
    libjacknet.so.0.1.0                         orbit-2.0
    libjack.so.0                                os-prober
    libjack.so.0.1.0                            os-probes
    libjavascriptcoregtk-1.0.so.0               p7zip
    libjavascriptcoregtk-1.0.so.0.11.2          pcmciautils
    libjavascriptcoregtk-3.0.so.0               perl
    libjavascriptcoregtk-3.0.so.0.11.2          perl5
    libjbig2dec.so.0                            pkgconfig
    libjbig2dec.so.0.0.0                        pluma
    libjpeg.so.62                               pm-utils
    libjpeg.so.62.0.0                           policykit-1
    libjson.so.0                                policykit-1-gnome
    libjson.so.0.0.1                            polkit-mate
    libjte.so.1                                 pppd
    libjte.so.1.0.0                             ppr
    libkate.so.1                                preloadable_libintl.so
    libkate.so.1.3.0                            psutils
    libkpathsea.so.5                            pt_chown
    libkpathsea.so.5.0.0                        pulse-1.0
    liblapack.so.3gf                            pymodules
    liblcms2.so.2                               pyshared
    liblcms2.so.2.0.2                           python2.6
    liblcms.so.1                                python2.7
    liblcms.so.1.0.19                           python3
    liblirc_client.la                           qmmp
    liblirc_client.so.0                         qt4
    liblirc_client.so.0.2.1                     rpm
    liblqr-1.so.0                               rpm-plugins
    liblqr-1.so.0.3.1                           rsyslog
    liblucene2-java                             rtkit
    liblwres.so.60                              sasl2
    liblwres.so.60.0.1                          security
    liblwres.so.80                              sox
    liblwres.so.80.0.1                          sse2
    libmad.a                                    ssh
    libmad.la                                   ssl
    libmad.so                                   sudo
    libmad.so.0                                 syslinux
    libmad.so.0.2.1                             tc
    libMagickCore.so.4                          thunar-archive-plugin
    libMagickCore.so.4.0.1                      ts0
    libMagickWand.so.4                          udisks
    libMagickWand.so.4.0.1                      upower
    libmarco-private.so.0                       ure
    libmarco-private.so.0.0.0                   urxvt
    libmate-2.so.0                              uswsusp
    libmate-2.so.0.200.0                        valgrind
    libmatecanvas-2.so.0                        vlc
    libmatecanvas-2.so.0.198.2                  webkitgtk-1.0-0
    libmatecomponent-2.so.0                     webkitgtk-3.0-0
    libmatecomponent-2.so.0.0.0                 win32
    libmatecomponent-activation.so.4            window-manager-settings
    libmatecomponent-activation.so.4.0.0        X11
    libmatecomponentui-2.so.0                   x86_64-linux-gnu
    libmatecomponentui-2.so.0.0.0               xfce4
    libmateconf-2.so.4                          xine
    libmateconf-2.so.4.1.5                      xine-plugin
    libMateCORBA-2.so.0                         xorg
    libMateCORBA-2.so.0.1.0                     xscreensaver
    libMateCORBACosNaming-2.so.0                xulrunner
    libMateCORBACosNaming-2.so.0.1.0            xulrunner-addons
    To see first in Backtrack (which I don't run) to see if

    There is no such directory as /usr/lib/firefox-addons/plugins

    Instead the directory struture is /usr/lib/firefox/plugins
    File structures are different from Distro to Distro on how folders are placed and plugins are placed for flash and java. Example: This is where my plugins are for AntiX.

    Code:
    harry@biker:/usr/lib$ cd /usr/lib/mozilla/plugins
    harry@biker:/usr/lib/mozilla/plugins$ ls
    flash-mozilla.so  libjavaplugin.so  xineplugin.so
    gxineplugin.so    libvlcplugin.so
    harry@biker:/usr/lib/mozilla/plugins$
    The locate command is also useful when looking for folders also

    Code:
    harry@biker:/usr/lib/mozilla/plugins$ locate /usr/lib/firefox
    /usr/lib/firefox
    /usr/lib/firefox/plugins
    /usr/lib/firefox/plugins/libjavaplugin.so
    as you can see. In AntiX I have no /usr/lib/firefox-addons/plugins/ folder also. So my best guess is No Script which seems to be incorporated into Firefox on Back Track is what is keeping flash from working.

    Testing the link in the wiki

    You have version 11,1,102,55 installed
    Is what Adobe tells me my version of Flash and is working.
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  5. #5
    Just Joined!
    Join Date
    Feb 2005
    Posts
    45
    I'm confused!

    I have already uninstalled NoScript so i dont think its that.

  6. #6
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    4,135
    I'm confused!
    I usually go to the source when I get confused.

    http://www.backtrack-linux.org/forums/forum.php
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  7. #7
    Just Joined!
    Join Date
    Feb 2005
    Posts
    45
    And its fixed!

    Someone had a link to v10, which worked like a charm

  8. #8
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    4,135
    Include a link address< (you have enough posts to do so), to the thread that supplied your

    And its fixed!

    Someone had a link to v10, which worked like a charm
    and what you did exactly to fix your issue. It will help others . Then mark thread as solved (thread tools on top of first post) so it shows on the net.

    Glad you got it going.
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  9. #9
    Just Joined!
    Join Date
    Feb 2005
    Posts
    45
    Sure thing.

    The link is kindly hosted by another backtracker.

    wget samiux.volospin.com/flash/install_flash_player_10_linux.tar.gz
    tar xvfz install_flash_player_10_linux.tar.gz
    mkdir ~/.mozilla/plugins
    mv -f libflashplayer.so ~/.mozilla/plugins/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •