Find the answer to your Linux question:
Results 1 to 4 of 4
Linux Mint 12 64 Bit. I downloaded the device drivers for this, installed ndiswrapper in linux mint and installed them. The hardware is listed on the device list. It says ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2005
    Posts
    13

    Dell Inspiron 1520 wireless card: 1390 mini pci card wifi.


    Linux Mint 12 64 Bit.


    I downloaded the device drivers for this, installed ndiswrapper in linux mint and installed them.

    The hardware is listed on the device list. It says "hardware present: yes"

    Aviable networks is blank, it doesn't look like it is searching for any.

    I believe the radio is on, I manually slid the wi-fi toggle to on and reset and no difference.

    It says there is a wired network that works when plugged in,
    It says there is wireless, but the firmware is not installed.
    I install the Broadcom STA driver from the additional hardware icon thing, and after restart no sign of wireless is present at all.

    It woks in Windows 7.

    What now? Thanks.

  2. #2
    Linux Guru jmadero's Avatar
    Join Date
    Jul 2007
    Location
    California
    Posts
    1,998
    So just to clarify, you installed the .exe dirver through ndiswrapper and then installed the STA driver through the Ubuntu driver software? If this is the case you're going to have problems as you essentially have two drivers installed. Furthermore, ndiswrapper should be a last option always. Forcing windows drivers (exe files) into Linux isn't a good plan if there are options to avoid doing so.

    This being said, if you did this I would first recommend doing the following:

    remove ndiswrapper (terminal, sudo apt-get purge ndiswrapper)
    remove the sta driver (you can do so in synaptic or through terminal, just not positive what driver you have installed)

    Reboot

    sudo apt-get clean (just for good measure)

    Reboot

    reinstall the STA driver using Ubuntu's driver manager software

    Reboot


    OR METHOD 2

    A quick google search resulted in:

    do the whole remove all drivers things (STA and NDISWRAPPER reboot) then

    sudo apt-get install b43-fwcutter

    reboot, good to go
    Bodhi 1.3 & Bodhi 1.4 using E17
    Dell Studio 17, Intel Graphics card, 4 gigs of RAM, E17

    "The beauty in life can only be found by moving past the materialism which defines human nature and into the higher realm of thought and knowledge"

  3. #3
    Just Joined!
    Join Date
    Jan 2009
    Posts
    50
    ndiswrapper + NetworkManager Tutorial

    This is intended for Ubuntu, but it might work for other distro's I am not sure. In place of sudo if you dont have it. use su.

    update with: sudo update-manager -d
    install ndiswrapper. Find the native windows drivers for your wireless card. in my case i had to use netgears wn311t. When they were extracted i would get netmw14x.inf (the driver).
    find out what the device number is (forget what its called exatly) but it will be ####:#### (it will have letters) so do a "lspci -nn" minus the quotes.
    it will show a list of stuff with network devices and such, Find your wireless adaptor and on the line with it it will have something like:
    00:04.0 Ethernet controller [0200]: Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet [1039:0900] (rev 91)

    Im not booted into linux so im ssh'd into my shell. but your wireless card will show something like that. note down the numbers nad letters inside the [####:####]

    "sudo ndiswrapper -i driver.inf" (/etc/ndiswrapper will create a folder named "netmw14x" inside it. make sure you are in the directory with the driver file. and dont forget the .inf part).

    "sudo ndiswrapper -a 11ab:2a08 netmw14x" (lspci -nn will show device ids. with different versions of ndiswrapper it might be -d. but do sudo ndiswrapper -a or -d depending on your version. "ndiswrapper -a ####:#### driver" notice the driver on this one doesnt have the .inf part )

    "sudo ndiswrapper -l" will now say the device is present and it can be configured normally.

    after that you'll want to edit your network manager so you can use it with the wireless adaptor. so do

    sudo gedit /etc/NetworkManager/nm-system-settings.conf
    under [ifupdown], change managed=true

    after youll want to add your alias with ndiswrapper so

    "sudo ndiswrapper -m"

    next youll want to make the module dependencies (its like a makefile) so do:

    "sudo depmod -a"

    and then youll want to load the modules so it will work:

    "sudo modprobe ndiswrapper"

    and then

    "sudo ifup wlan0"


    an overview of commands

    1. sudo apt-get install ndiswrapper-common
    2. sudo ndiswrapper -i driver.inf
    3. lspci -nn (note down the device id)
    4. sudo ndiswrapper -a ####:#### driver
    5. sudo ndiswrapper -m
    6. sudo gedit /etc/NetworkManager/nm-system-settings.conf (change managed to true)
    7. sudo depmod -a
    8. sudo modprobe ndiswrapper
    9. sudo ifup wlan0

    and your wireless should show up in the network manager

    [edit] atleast thats all waht worked for me. i tried for months to get wireless to work and it wouldnt. the only thing i didnt do was change the managed to true which made it work. an easier way to install the driver though is using ndisgtk so you dont have to go through all the hassle of running commands. as it says ndisgtk gimp toolkit so its for x instead of a command line.


    TRY SEARCHING THE FORUMS BEFORE POSTING

  4. #4
    Linux Newbie
    Join Date
    Apr 2005
    Location
    Clinton Township, MI
    Posts
    104
    Quote Originally Posted by jmadero View Post
    So just to clarify, you installed the .exe dirver through ndiswrapper and then installed the STA driver through the Ubuntu driver software? If this is the case you're going to have problems as you essentially have two drivers installed. Furthermore, ndiswrapper should be a last option always. Forcing windows drivers (exe files) into Linux isn't a good plan if there are options to avoid doing so.

    This being said, if you did this I would first recommend doing the following:

    remove ndiswrapper (terminal, sudo apt-get purge ndiswrapper)
    remove the sta driver (you can do so in synaptic or through terminal, just not positive what driver you have installed)

    Reboot

    sudo apt-get clean (just for good measure)

    Reboot

    reinstall the STA driver using Ubuntu's driver manager software

    Reboot


    OR METHOD 2

    A quick google search resulted in:

    do the whole remove all drivers things (STA and NDISWRAPPER reboot) then

    sudo apt-get install b43-fwcutter

    reboot, good to go
    I tend to agree with your approach, except for one thing: these days, the firmware-b43-installer is preferable to using b43-fwcutter by itself. The firmware-b43-installer does, in fact, grab the b43-fwcutter package. What happens, in effect, when you use firmware-b43-installer is that it will download the b43 firmware from the Broadcom site, then it will install it for you.

    If you still run into problems, then check the Debian site: bcm43xx - Debian Wiki
    If, in fact, this is b43 firmware, the site above will guide you through the complete process, and it will also provide trouble-shooting, in case the problems persist.

    The Debian User Forums have another topic that may be germane and provide additional information: Debian User Forums • View topic - Help for wifi B43 Diver install

    Based on what I've read. I have reason to believe that the Dell 1390 mini pci card wifi uses the Broadcom 4312 firmware, and therefore, the b43 driver is the one that ought to work. Let us know if that's the case.
    Brian Masinick
    masinick AT yahoo DOT com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •