Find the answer to your Linux question:
Results 1 to 10 of 10
Running 12.04, fully up to date. Everything will be fine on login, but upon heavy FF or Chrome usage (15-20 tabs) the whole system gets bogged down. Now one might ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie Syndacate's Avatar
    Join Date
    May 2012
    Location
    Hell..no literally, this state is hell..
    Posts
    192

    System Lag (12.04) - Can't find cause


    Running 12.04, fully up to date.

    Everything will be fine on login, but upon heavy FF or Chrome usage (15-20 tabs) the whole system gets bogged down.

    Now one might say "close some tabs" - but this minuscule number of tabs shouldn't be an issue. According to the system monitor, FF is using around 400-500MB. That may be a lot if I'm on a netbook, but I'm not.

    I realize I don't have the fastest processor (I7 Nahalem 920 at 3.4Ghz), but I feel it should be fast enough. As for memory, the same goes. At 12GB of DDR3 at 1600Mhz, I don't feel this should be an issue.

    According to both top and the system monitor my CPU usage is basically 0%, mem usage is at about 2GB total.

    Though when I do stuff (ie. as windows minimize/open back up, double clicking icons, etc.), I see re-drawing problems sometimes, like the window as it's moving out of the dock "stepping" as its being drawn, ghosting. I never got a lot of use out of 11.10 but I know it didn't exist in 11.04 with regular unity. I was using the same exact HW configured the same exact way. Both times using the Nvidia proprietary drivers (currently on 295.49).

    I've searched high and low but I can't find any answers to this issue. Even though I found a slew of Unity bugs, but none of the fixes seemed to apply. Any help is appreciated :-\.

    EDIT:
    If I close FF or Chrome (whatever has many tabs open), this all goes away. It's like its a resource problem but with 20 static webpages (most of these are code docs, maybe 1 or 2 flash (youtube) or JS pages) this shouldn't be happening. Not really anything else is open besides that. Skype, pidgin, transmission, and qbittorrent in the background, typically gedit and a terminal also in the foreground.

    EDIT 2:
    Forgot to mention graphics. This seems like it could be a display card issue but I doubt it. It's an EVGA card with a Nvidia 280GTX w/ 1GB memory. It's good enough to play Crisis decently, I feel it should be enough to move some windows around. It's not like I have tons of effects on (basically whatever is default). I've also tried disabling the sync to vblank with no change for better or for worse.

  2. #2
    Linux Newbie hagfish52's Avatar
    Join Date
    Dec 2011
    Location
    Asheville, NC
    Posts
    225
    With that many tabs open you are using a lot of memory. 2 GB is a lot. Normal usage is around 150 MB with Firefox. You might even be getting into a regime where FF is using the swap partition. You're just asking the browsers to do something they can't do. I think your first answer is the best one; don't open so many tabs.
    Last edited by hagfish52; 07-29-2012 at 11:26 PM.

  3. #3
    Linux Newbie Syndacate's Avatar
    Join Date
    May 2012
    Location
    Hell..no literally, this state is hell..
    Posts
    192
    Quote Originally Posted by hagfish52 View Post
    With that many tabs open you are using a lot of memory. 2 GB is a lot. Normal usage is around 150 MB with Firefox. You're just asking the browsers to do something they can't do. I think your first answer is the best one; don't open so many tabs.
    I could see if Firefox itself was laggy, but it's not. Not even slightly. Once the window is open all the tabs switch just fine, new tabs load just fine, it opens/closes tabs just fine.

    2GB isn't a lot out of 12, that's 17% (of total memory, without paging) and Firefox is only using 2%-6% of total memory. Remember, the 2GB is total usage, the FF usage is like 300-500MB.

    The Unity UI is laggy, even when I open/close windows they 'step'/'ghost'. I know this isn't a problem with FF because I've done this before with Unity in 11.04 and I had 0 issues like this, my browsing habbits haven't changed.

    Even if an app is using a large amount of memory, this should in no way affect how the UI moves windows about the desktop. Unity has plenty of free memory if it needed to use some more. When I close windows they disappear slower than normal, when I open minimized things they they're a bit sluggish to come to the forefront.

    The fact that it's a UI problem is further backed by me opening other programs which aren't even slightly lagging on opening time, they open just fine, but then their windows get iffy when I minimize/open/close/etc. (try to get work done).

    If I take a single window and shake it around it draws fine... If I minimize a single widow and open it many times, it draws fine..but when you start mixing it and moving windows around a lot the UI gets laggy.

    Also, my processor usage is next to null. I believe this to be a problem with graphics, but I'm not sure why it's in affect when it is. I hope that I'm not asking too much out of the browser because FF (same versions) handle my browsing just fine in Windows or OS X. So unless XUL was implemented very poorly on Linux (which I doubt), it's most likely a UI thing.

    This is a confusing problem to say the least :-\. I'm wondering if it has anything to do with 3D effects of Unity.

  4. #4
    Linux Engineer MASONTX's Avatar
    Join Date
    May 2010
    Location
    Mason Texas
    Posts
    934
    Shot in the dark here. Try opening the case and checking all memory connections, leave case open to check if it is a heat issue. Finally, check to see if all drivers are the right drivers for your equipment, and are current, or if the problem only just started after an update, roll back to a previous driver. To check unity, try disabling it and see if performance improves.
    Registered Linux user #526930

  5. #5
    Linux Newbie Syndacate's Avatar
    Join Date
    May 2012
    Location
    Hell..no literally, this state is hell..
    Posts
    192
    Quote Originally Posted by MASONTX View Post
    Shot in the dark here. Try opening the case and checking all memory connections, leave case open to check if it is a heat issue. Finally, check to see if all drivers are the right drivers for your equipment, and are current, or if the problem only just started after an update, roll back to a previous driver. To check unity, try disabling it and see if performance improves.
    This might sound fan-boyish, but the Antec 1200 flows about as much air as it's going to get. It's not a heat issue.

    The drivers, as mentioned earlier, are the 295.49 Nvidia drivers, they are the correct drivers, to the best of my knowledge, for the GTX285.

    I installed KDE and am using this with the same exact Firefox session, none of the issues reported with Unity persist. It's most definitely a Unity issue, though I'm not sure with what. I didn't think I'd get answers, there seems to be a lot of lag issues (at least bug reports for them) for Unity as of late and recently late. Not entirely sure how to describe my personal one except "it bothers the piss out of me" - hard to describe, haha. Though I believe that it's definitely related to moving or minimizing windows which are consuming a good amount of memory, though under the circumstances of my system, I don't believe 500MB should be an issue. Can't really say much else beyond that :-\.

  6. #6
    rrl
    rrl is offline
    Just Joined!
    Join Date
    May 2011
    Location
    NJ
    Posts
    64
    There are 3 places to access the sync to v-blank.

    - In compiz display settings
    - In NVidia XVideo settings
    - In NVidia OpenGLX settings

    Did you disable the compiz, and opengl v-blank settings? If not, that might help.

    You say in the OP this happens with FF open with around 20 tabs, but doesn't when you close FF. In your response to hagfish, you say it's not FF causing this because FF doesn't suffer from the performance issues. Can you run another program that will use approx the same amount of resources FF will with 20 tabs open and see if the problem returns?

  7. #7
    rrl
    rrl is offline
    Just Joined!
    Join Date
    May 2011
    Location
    NJ
    Posts
    64
    Do you know the upper limit of tabs you can have open before you start noticing the sluggishness? 20 tabs might not be seem like alot relative to your total amount of system memory, but relative to a actual usefulness, I'd say it's getting up there. Do you find a need to have that many tabs open consistently?

    You also say you have qbittorrent running sometimes in the background? Are you downloading torrents when this happens as well?

  8. #8
    Linux Engineer
    Join Date
    Apr 2012
    Location
    Virginia, USA
    Posts
    896
    Sounds like your system is out of video memory.

    The first thing I would try is another distro. Unless you have a specific need, no real general reason to use Ubugtu.

  9. #9
    rrl
    rrl is offline
    Just Joined!
    Join Date
    May 2011
    Location
    NJ
    Posts
    64
    The latest drivers I found for your card is http://www.nvidia.com/object/linux-d...71-driver.html Have you tried this one?

    If you want or need to be running Unity in 3D, you might need the older driver as I believe there is a bug in the newest driver. I am running an NVIDIA 9600 GT card and can't get Unity to run in 3D with any driver.
    Last edited by rrl; 08-08-2012 at 01:02 AM. Reason: fixing link

  10. #10
    Linux Newbie Syndacate's Avatar
    Join Date
    May 2012
    Location
    Hell..no literally, this state is hell..
    Posts
    192
    I doubt it is out of video memory unless an application is terribly written for the GPU, with 1GB of memory.

    Other programs with generally the same amount of memory usage DO weigh down Unity as much as Firefox does.

    These problems do NOT persist in KDE, meaning it's not a core problem. They also did NOT exist in 11.04 with Unity and did NOT exist in Gnome or Mate.

    Another distro, not using Unity, I would make a very educated guess that it would fix this problem, seeing as KDE in an Ubuntu install works fine. The reason I stick to Ubuntu is mostly because:
    1. The amount of stuff done for you (no setup required)
    2. The huge amounts of stuff in the repository makes most things a mouse-click away....though I might go to Arch after this 'bump' as between official an AUR their repos are quite large.
    3. Lots of support for when **** happens

    I tried rolling back the driver version with no success.

    I kind of gave up on this issue. It's something with Unity handling large blobs of memory, not sure why, as a developer it's truly confusing to me, but I guess I don't know enough about the Unity environment or how deep it goes to really understand a possible backing for this. Given that I need to get stuff done I've just been using KDE4 and I've had no problems. This is quite sad because I feel Unity is FAR superior to Gnome3 but this lag issue is screwing with my work-flow and I'm not appreciating it. So...continuing with KDE4 I guess....KDE4 has finally gotten rock stable, IMO, compared to how it was up to KDE4.5 or so, lmao.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •