Find the answer to your Linux question:
Page 3 of 3 FirstFirst 1 2 3
Results 21 to 23 of 23
Originally Posted by devils casper Post the contents of /etc/default/grub folder too. $ ls -al /etc/default/grub Code: -rw-r--r-- 1 root root 1252 Oct 1 11:00 /etc/default/grub $ cat /etc/default/grub Code: ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #21
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,814

    Quote Originally Posted by devils casper View Post
    Post the contents of /etc/default/grub folder too.
    $ ls -al /etc/default/grub
    Code:
    -rw-r--r-- 1 root root 1252 Oct  1 11:00 /etc/default/grub
    $ cat /etc/default/grub
    Code:
    # If you change this file, run 'update-grub' afterwards to update
    # /boot/grub/grub.cfg.
    # For full documentation of the options in this file, see:
    #   info -f grub -n 'Simple configuration'
    
    GRUB_DEFAULT=0
    GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT=10
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.audio=1"
    GRUB_CMDLINE_LINUX=""
    
    # Uncomment to enable BadRAM filtering, modify to suit your needs
    # This works with Linux (no patch required) and with any kernel that obtains
    # the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
    #GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"
    
    # Uncomment to disable graphical terminal (grub-pc only)
    #GRUB_TERMINAL=console
    
    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    #GRUB_GFXMODE=640x480
    
    # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
    #GRUB_DISABLE_LINUX_UUID=true
    
    # Uncomment to disable generation of recovery mode menu entries
    #GRUB_DISABLE_RECOVERY="true"
    
    # Uncomment to get a beep at grub start
    #GRUB_INIT_TUNE="480 440 1"
    You GRUB Menu has a lot of entries. Do you want to keep that all or remove a few? Do you want to keep/require memtest entries too? I would suggest you to remove unused, older Ubuntu kernels too.
    No. I don't need those unused/obsolete entries. Please advise which of them are essential. Then I would remove others. Before taking action I would create a backup of grub.cfg just in case.

    Thanks

    satimis

  2. #22
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    First of all, uninstall all earlier kernel versions through Synaptic or apt-get. In Synaptic, search linux-header and linux-image. Keep latest version and uninstall all others.
    You can remove memtest entry by resetting its execution bit.
    Code:
    sudo chmod -x /etc/grub.d/20_memtest86+
    Execute 'sudo update-grub' command again to generate new grub.cfg file.

    Add Fedora's entry in newly generate grub.cfg file. Add it after "### BEGIN /etc/grub.d/10_linux ###" line in grub.cfg file. Fedora will be default OS in GRUB Menu. I have checked your default file. Hidden status in not set and GRUB menu should appear by default.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #23
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,814
    Performed following steps;

    $ sudo apt-get remove linux-image-3.2.0-29-generic
    $ sudo apt-get remove linux-headers-3.2.0-29-generic
    $ sudo apt-get remove linux-image-3.2.0-23-generic
    $ sudo apt-get remove linux-headers-3.2.0-23-generic
    $ sudo chmod -x /etc/grub.d/20_memtest86+

    $ sudo update-grub
    Code:
    Generating grub.cfg ...
    Found linux image: /boot/vmlinuz-3.2.0-31-generic
    Found initrd image: /boot/initrd.img-3.2.0-31-generic
    done
    Added following lines to /boot/grub/grub.cfg as advised
    Code:
    menuentry 'Fedora (3.5.4-1.fc17.x86_64)' --class fedora --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-753d40c0-9f28-4011-a8c6-7b6da842e0ad' {
    	load_video
    	set gfxpayload=keep
    	insmod gzio
    	insmod part_msdos
    	insmod ext2
    	set root='hd0,msdos3'
    	if [ x$feature_platform_search_hint = xy ]; then
    	  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos3 --hint-efi=hd0,msdos3 --hint-baremetal=ahci0,msdos3 --hint='hd0,msdos3'  4e11a723-32c9-42eb-b549-3ded0494c281
    	else
    	  search --no-floppy --fs-uuid --set=root 4e11a723-32c9-42eb-b549-3ded0494c281
    	fi
    	echo 'Loading Fedora (3.5.4-1.fc17.x86_64)'
    	linux	/vmlinuz-3.5.4-1.fc17.x86_64 root=/dev/mapper/vg-lv_root ro rd.md=0 rd.dm=0  KEYTABLE=us SYSFONT=True rd.lvm.lv=vg/lv_root rd.luks=0 rd.lvm.lv=vg/lv_swap LANG=en_US.UTF-8 rhgb radeon.audio=1 quiet
    	echo 'Loading initial ramdisk ...'
    	initrd /initramfs-3.5.4-1.fc17.x86_64.img
    }
    $ cat /boot/grub/grub.cfg
    Code:
    #
    # DO NOT EDIT THIS FILE
    #
    # It is automatically generated by grub-mkconfig using templates
    # from /etc/grub.d and settings from /etc/default/grub
    #
    
    ### BEGIN /etc/grub.d/00_header ###
    if [ -s $prefix/grubenv ]; then
      set have_grubenv=true
      load_env
    fi
    set default="0"
    if [ "${prev_saved_entry}" ]; then
      set saved_entry="${prev_saved_entry}"
      save_env saved_entry
      set prev_saved_entry=
      save_env prev_saved_entry
      set boot_once=true
    fi
    
    function savedefault {
      if [ -z "${boot_once}" ]; then
        saved_entry="${chosen}"
        save_env saved_entry
      fi
    }
    
    function recordfail {
      set recordfail=1
      if [ -n "${have_grubenv}" ]; then if [ -z "${boot_once}" ]; then save_env recordfail; fi; fi
    }
    
    function load_video {
      insmod vbe
      insmod vga
      insmod video_bochs
      insmod video_cirrus
    }
    
    insmod part_msdos
    insmod ext2
    set root='(hd0,msdos1)'
    search --no-floppy --fs-uuid --set=root 361a5563-f447-42ea-b5ef-c3be733df368
    if loadfont /usr/share/grub/unicode.pf2 ; then
      set gfxmode=auto
      load_video
      insmod gfxterm
      insmod part_msdos
      insmod ext2
      set root='(hd0,msdos1)'
      search --no-floppy --fs-uuid --set=root 361a5563-f447-42ea-b5ef-c3be733df368
      set locale_dir=($root)/boot/grub/locale
      set lang=en_HK
      insmod gettext
    fi
    terminal_output gfxterm
    if [ "${recordfail}" = 1 ]; then
      set timeout=-1
    else
      set timeout=10
    fi
    ### END /etc/grub.d/00_header ###
    
    ### BEGIN /etc/grub.d/05_debian_theme ###
    menuentry 'Fedora (3.5.4-1.fc17.x86_64)' --class fedora --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-753d40c0-9f28-4011-a8c6-7b6da842e0ad' {
    	load_video
    	set gfxpayload=keep
    	insmod gzio
    	insmod part_msdos
    	insmod ext2
    	set root='hd0,msdos3'
    	if [ x$feature_platform_search_hint = xy ]; then
    	  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos3 --hint-efi=hd0,msdos3 --hint-baremetal=ahci0,msdos3 --hint='hd0,msdos3'  4e11a723-32c9-42eb-b549-3ded0494c281
    	else
    	  search --no-floppy --fs-uuid --set=root 4e11a723-32c9-42eb-b549-3ded0494c281
    	fi
    	echo 'Loading Fedora (3.5.4-1.fc17.x86_64)'
    	linux	/vmlinuz-3.5.4-1.fc17.x86_64 root=/dev/mapper/vg-lv_root ro rd.md=0 rd.dm=0  KEYTABLE=us SYSFONT=True rd.lvm.lv=vg/lv_root rd.luks=0 rd.lvm.lv=vg/lv_swap LANG=en_US.UTF-8 rhgb radeon.audio=1 quiet
    	echo 'Loading initial ramdisk ...'
    	initrd /initramfs-3.5.4-1.fc17.x86_64.img
    }
    set menu_color_normal=white/black
    set menu_color_highlight=black/light-gray
    if background_color 44,0,30; then
      clear
    fi
    ### END /etc/grub.d/05_debian_theme ###
    
    ### BEGIN /etc/grub.d/10_linux ###
    function gfxmode {
    	set gfxpayload="${1}"
    	if [ "${1}" = "keep" ]; then
    		set vt_handoff=vt.handoff=7
    	else
    		set vt_handoff=
    	fi
    }
    if [ "${recordfail}" != 1 ]; then
      if [ -e ${prefix}/gfxblacklist.txt ]; then
        if hwmatch ${prefix}/gfxblacklist.txt 3; then
          if [ ${match} = 0 ]; then
            set linux_gfx_mode=keep
          else
            set linux_gfx_mode=text
          fi
        else
          set linux_gfx_mode=text
        fi
      else
        set linux_gfx_mode=keep
      fi
    else
      set linux_gfx_mode=text
    fi
    export linux_gfx_mode
    if [ "${linux_gfx_mode}" != "text" ]; then load_video; fi
    menuentry 'Ubuntu, with Linux 3.2.0-31-generic' --class ubuntu --class gnu-linux --class gnu --class os {
    	recordfail
    	gfxmode $linux_gfx_mode
    	insmod gzio
    	insmod part_msdos
    	insmod ext2
    	set root='(hd0,msdos1)'
    	search --no-floppy --fs-uuid --set=root 361a5563-f447-42ea-b5ef-c3be733df368
    	linux	/boot/vmlinuz-3.2.0-31-generic root=UUID=361a5563-f447-42ea-b5ef-c3be733df368 ro   quiet splash radeon.audio=1 $vt_handoff
    	initrd	/boot/initrd.img-3.2.0-31-generic
    }
    menuentry 'Ubuntu, with Linux 3.2.0-31-generic (recovery mode)' --class ubuntu --class gnu-linux --class gnu --class os {
    	recordfail
    	insmod gzio
    	insmod part_msdos
    	insmod ext2
    	set root='(hd0,msdos1)'
    	search --no-floppy --fs-uuid --set=root 361a5563-f447-42ea-b5ef-c3be733df368
    	echo	'Loading Linux 3.2.0-31-generic ...'
    	linux	/boot/vmlinuz-3.2.0-31-generic root=UUID=361a5563-f447-42ea-b5ef-c3be733df368 ro recovery nomodeset 
    	echo	'Loading initial ramdisk ...'
    	initrd	/boot/initrd.img-3.2.0-31-generic
    }
    ### END /etc/grub.d/10_linux ###
    
    ### BEGIN /etc/grub.d/20_linux_xen ###
    ### END /etc/grub.d/20_linux_xen ###
    
    ### BEGIN /etc/grub.d/30_os-prober ###
    if [ "x${timeout}" != "x-1" ]; then
      if keystatus; then
        if keystatus --shift; then
          set timeout=-1
        else
          set timeout=0
        fi
      else
        if sleep --interruptible 3 ; then
          set timeout=0
        fi
      fi
    fi
    ### END /etc/grub.d/30_os-prober ###
    
    ### BEGIN /etc/grub.d/40_custom ###
    # This file provides an easy way to add custom menu entries.  Simply type the
    # menu entries you want to add after this comment.  Be careful not to change
    # the 'exec tail' line above.
    ### END /etc/grub.d/40_custom ###
    
    ### BEGIN /etc/grub.d/41_custom ###
    if [ -f  $prefix/custom.cfg ]; then
      source $prefix/custom.cfg;
    fi
    ### END /etc/grub.d/41_custom ###
    Rebooted PC


    Fedora started as default but GRUB didn't start. I have to press left-shift to start it.

    How to fix it?

    Also how to add Fedora recovery mode?

    Thanks

    B.R.
    satimis
    Last edited by satimis; 10-03-2012 at 03:38 PM. Reason: to correct typing mistake

  4. $spacer_open
    $spacer_close
Page 3 of 3 FirstFirst 1 2 3

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •