Find the answer to your Linux question:
Results 1 to 10 of 10
I have been on Ubuntu 12.04 since May 2012. Yesterday Update manager showed up with updates for installation. As usual I clicked on update button for some 60 odd updates. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2008
    Posts
    8

    Software Update Issues


    I have been on Ubuntu 12.04 since May 2012. Yesterday Update manager showed up with updates for installation. As usual I clicked on update button for some 60 odd updates. Every time I tried to install the updates, I get the following messages. First I tried through update manager. Then through comd line & finally through package manager. The errors I get are

    installArchives() failed: perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
    LANGUAGE = (unset),
    LC_ALL = (unset),
    LANG = "en_IN.ISO8859-1"
    are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    locale: Cannot set LC_CTYPE to default locale: No such file or directory
    locale: Cannot set LC_MESSAGES to default locale: No such file or directory
    locale: Cannot set LC_ALL to default locale: No such file or directory

    Extracting templates from packages: 53%%
    Extracting templates from packages: 100%%
    Preconfiguring packages ...
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
    LANGUAGE = (unset),
    LC_ALL = (unset),
    LANG = "en_IN.ISO8859-1"
    are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    locale: Cannot set LC_CTYPE to default locale: No such file or directory
    locale: Cannot set LC_MESSAGES to default locale: No such file or directory
    locale: Cannot set LC_ALL to default locale: No such file or directory

    Extracting templates from packages: 53%%
    Extracting templates from packages: 100%%
    Preconfiguring packages ...
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
    LANGUAGE = (unset),
    LC_ALL = (unset),
    LANG = "en_IN.ISO8859-1"
    are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    locale: Cannot set LC_CTYPE to default locale: No such file or directory
    locale: Cannot set LC_MESSAGES to default locale: No such file or directory
    locale: Cannot set LC_ALL to default locale: No such file or directory

    Extracting templates from packages: 53%%
    Extracting templates from packages: 100%%
    Preconfiguring packages ...
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
    LANGUAGE = (unset),
    LC_ALL = (unset),
    LANG = "en_IN.ISO8859-1"
    are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    locale: Cannot set LC_CTYPE to default locale: No such file or directory
    locale: Cannot set LC_MESSAGES to default locale: No such file or directory
    locale: Cannot set LC_ALL to default locale: No such file or directory

    Extracting templates from packages: 53%%
    Extracting templates from packages: 100%%
    Preconfiguring packages ...
    (Reading database ...
    (Reading database ... 5%%
    (Reading database ... 10%%
    (Reading database ... 15%%
    (Reading database ... 20%%
    (Reading database ... 25%%
    (Reading database ... 30%%
    (Reading database ... 35%%
    (Reading database ... 40%%
    (Reading database ... 45%%
    (Reading database ... 50%%
    (Reading database ... 55%%
    (Reading database ... 60%%dpkg: unrecoverable fatal error, aborting:
    files list file for package `libatspi2.0-0' contains empty filename



    Extracting templates from packages: 100%
    Preconfiguring packages ...
    (Reading database ... 60%dpkg: unrecoverable fatal error, aborting:
    files list file for package `libatspi2.0-0' contains empty filename
    E: Sub-process /usr/bin/dpkg returned an error code (2)
    A package failed to install. Trying to recover:



    W: GPG error: [packages.medibuntu]Medibuntu -- Medibuntu packages precise In Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 2EBC26B60C5A2783
    W: GPG error: [ppa.launchpad]Index of precise Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 88DB8FC6C190F85D

    Will be gratefull for step by step HELP. I started on computers with windows, switched to Linux some 3 years ago. Do not wish to go back. Have NO CLUE about UNIX and no knowledge of any kind of programming.
    Thanks in advance.

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Try this
    Code:
    sudo dpkg-reconfigure -a
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Oct 2008
    Posts
    8

    software update issues

    Quote Originally Posted by devils casper View Post
    Try this
    Code:
    sudo dpkg-reconfigure -a
    "Thanks Devil's Casper - for such a prompt reply. Ran the command in the Terminal. Provided the password. Cursor jumped to next row. Blinked for about 10 secs & stayed steady for ever & ever. No further murmur from the computer"

  4. $spacer_open
    $spacer_close
  5. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Press Ctrl+C to stop dpkg command execution.
    files list file for package `libatspi2.0-0' contains empty filename
    libatspi2.0-0 library is creating problem. Try to remove it.
    Code:
    sudo apt-get remove --purge libatspi2.0-0
    sudo apt-get clean all
    sudo apt-get update
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  6. #5
    Just Joined!
    Join Date
    Oct 2008
    Posts
    8

    software update issues

    Quote Originally Posted by devils casper View Post
    Press Ctrl+C to stop dpkg command execution.

    libatspi2.0-0 library is creating problem. Try to remove it.
    Code:
    sudo apt-get remove --purge libatspi2.0-0
    sudo apt-get clean all
    sudo apt-get update
    "Thanks indeed for all the help
    DID WHAT YOU SUGGESTED
    What I got was
    chandru4895@chandru4895-desktop:~$ sudo apt-get remove --purge libatspi2.0-0
    [sudo] password for chandru4895:
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following packages were automatically installed and are no longer required:
    graphicsmagick linux-headers-3.2.0-25 linux-headers-3.2.0-25-generic-pae
    Use 'apt-get autoremove' to remove them.
    The following packages will be REMOVED:
    at-spi2-core* gir1.2-atspi-2.0* gnome-orca* libatk-adaptor*
    libatk-adaptor-schemas* libatspi2.0-0* python-pyatspi2* ubuntu-desktop*
    0 upgraded, 0 newly installed, 8 to remove and 66 not upgraded.
    After this operation, 7,843 kB disk space will be freed.
    Do you want to continue [Y/n]? y
    (Reading database ... 60%dpkg: unrecoverable fatal error, aborting:
    files list file for package `libatspi2.0-0' contains empty filename
    E: Sub-process /usr/bin/dpkg returned an error code (2)
    chandru4895@chandru4895-desktop:~$ sudo apt-get clean all
    chandru4895@chandru4895-desktop:~$ sudo apt-get update
    (NOW FOLLOWS A HUGE LIST OF URLs THAT I CANNOT INCLUDE IN THE REPLY)
    Fetched 888 kB in 18s (48.3 kB/s)
    W: GPG error: launchpad.net precise Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 88DB8FC6C190F85D
    W: GPG error: packages.medibuntu.org precise InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 2EBC26B60C5A2783
    E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
    chandru4895 chandru4895-desktop:~$ sudo dpkg --configure -a
    chandru4895 chandru4895-desktop:~$
    I also ran sudo dpkg --configure -a with no further response. Hope you continue to help sir."

  7. #6
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Did you try sudo apt-get update command again? Does it through any error now?
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  8. #7
    Just Joined!
    Join Date
    Oct 2008
    Posts
    8
    "Ran sudo apt-get updateagain. I am back with the massive list ending with

    Fetched 7,412 B in 22s (329 B/s)
    W: GPG error: ppa.launchpad.net precise Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 88DB8FC6C190F85D
    W: GPG error: packages.medibuntu.org precise InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 2EBC26B60C5A2783
    E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
    chandru4895@chandru4895-desktop:~$

  9. #8
    Just Joined!
    Join Date
    Oct 2008
    Posts
    8

    software update issues

    Quote Originally Posted by 48chandru95 View Post
    "Ran sudo apt-get updateagain. I am back with the massive list ending with

    Fetched 7,412 B in 22s (329 B/s)
    W: GPG error: ppa.launchpad.net precise Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 88DB8FC6C190F85D
    W: GPG error: packages.medibuntu.org precise InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 2EBC26B60C5A2783
    E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
    chandru4895@chandru4895-desktop:~$
    "Hello Devils Casper. Ran apt-get update with result shown just above. Then got to Update Manager & tried update. System went into partial upgrade and a series of errors came up with bug reports being automatically generated in Launch Pad. Did not understand any of it & just followed messages as they came along. I am back to square 1 & at a loss as to what to do next."

  10. #9
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Something is wrong with Package Manager. May be other Users have reported it as a bug at Launchpad. I will check there and let you know.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  11. #10
    Just Joined!
    Join Date
    Oct 2008
    Posts
    8

    software update issues

    Quote Originally Posted by devils casper View Post
    Something is wrong with Package Manager. May be other Users have reported it as a bug at Launchpad. I will check there and let you know.
    "Thankyou sir. Will wait for your reply"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •