Find the answer to your Linux question:
Results 1 to 5 of 5
Trying to get the network connection establised on the virtual machine. the virtual machine I'm using is vmware-player. The physical system's operating system is Ubuntu as well. I set on ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2007
    Posts
    20

    Question can't get network to work on virtual machine


    Trying to get the network connection establised on the virtual machine.



    the virtual machine I'm using is vmware-player.

    The physical system's operating system is Ubuntu as well.


    I set on the virtual machine: Bridged: Connected directly to the physical network
    tick on Replicate physical network connection state.

    The reason is I chose this is that I want to have a different IP address on this. I want it to get it from my dhcp server as if it was a system by it's on.


    Problem is that I keep getting this error and can't seem to get it connected: "could not connect Ethernet0 to virtual network "/dev/vmnet0"


    Would really appreciate any help on this.

    cheers

  2. #2
    Just Joined!
    Join Date
    Sep 2007
    Location
    Silver Spring, MD
    Posts
    95

    Question and answers

    Since you are running Vmware Workstation or Vmware ESXi server.

    What version are you running?

    One thing, are you running vmware tools, that will help as well.

    The other thing you could do would be to verify the network type is is a vmxnet2 or vmxnet3 (Enhanced).

    You may want to change the type of network adapter that is running on the machine.

    You can do it using vmware vsphere by right clicking on the vm, select settings click on network and change the adapter type, the machine has to be turned off.

    However, there is another way to do it, you have to be running vmware powershell to run this command and you have the right permissions

    Code:
    get-vm <vmname> | get-networkadapter | set-networkadapter -type vmxnet3 -confirm:$false
    Remember there are different types of network adapters [vmxnet,vmxnet2,vmxnet3,e1000]

    It just depends on the type of adapter that is supported by the OS.

    Todd

  3. #3
    Just Joined!
    Join Date
    Jun 2007
    Posts
    20
    Thanks for the reply Todd, very much appreciated.

    I'm runnning VMware Player 5.0.0 build-812388.

    The operating system set on the virtual machine is ubuntu 12.04 server edition 64 bit


    Physical server is also ubuntu 12.04 server edition 64 bit.

    For some odd reason, now it works, after I restarted the server.

    After I changed the file /etc/network/interfaces from

    Code:
    auto lo
    iface lo inet loopback
    to
    Code:
     auto eth0
    iface eth0 inet dhcp
    then restarted the service
    Code:
    /etc/init.d/networking restart
    I got a dhcp from the dhcp server now to

    eth0.

    My other question which of this will I know which it uses,
    is it vmnet1 or vmnet8?



    Physical machine:

    Code:
    vmnet1    Link encap:Ethernet  HWaddr 00:50:56:c0:00:01
              inet addr:172.16.29.1  Bcast:172.16.29.255  Mask:255.255.255.0
              inet6 addr: fe80::250:56ff:fec0:1/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:121 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
    
    vmnet8    Link encap:Ethernet  HWaddr 00:50:56:c0:00:08
              inet addr:192.168.14.1  Bcast:192.168.14.255  Mask:255.255.255.0
              inet6 addr: fe80::250:56ff:fec0:8/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:121 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)






    Quote Originally Posted by tdsan View Post
    Since you are running Vmware Workstation or Vmware ESXi server.

    What version are you running?

    One thing, are you running vmware tools, that will help as well.

    The other thing you could do would be to verify the network type is is a vmxnet2 or vmxnet3 (Enhanced).

    You may want to change the type of network adapter that is running on the machine.

    You can do it using vmware vsphere by right clicking on the vm, select settings click on network and change the adapter type, the machine has to be turned off.

    However, there is another way to do it, you have to be running vmware powershell to run this command and you have the right permissions

    Code:
    get-vm <vmname> | get-networkadapter | set-networkadapter -type vmxnet3 -confirm:$false
    Remember there are different types of network adapters [vmxnet,vmxnet2,vmxnet3,e1000]

    It just depends on the type of adapter that is supported by the OS.

    Todd

  4. #4
    Just Joined!
    Join Date
    Sep 2007
    Location
    Silver Spring, MD
    Posts
    95

    Configuration challenges

    LOL,

    You may want to change the /etc/network/interfaces lo item, just add back your lo section to the beginning of the document and move down the ethernet settings that you just added. The (lo) pertains to your loopback adapter. Honest mistake.

    Just hit the enter key a few times or set it up like this.

    Code:
    auto lo
    iface lo inet loopback
    
    auto eth0
    iface eth0 inet dhcp
    Restart the network adapters

    Code:
    /etc/init.d/networking restart
    Then you should be good to go. The loopback adapters allows you to check the status of your system by pinging the loopback and you can use this for testing purposes as well.

    You are on the right track.

    As far as your vmware network settings goes, go into edit | vmware network editor.

    There is a section that says VMNet Information, it usually says Auto, there is a drop down where you can tell it which adapter to use. Also, the vmxnet0 should say bridged or auto bridging (that is the one sending the traffic back and forth, the vmxnet8 says Nat, that is the one that is used to control the network adapter's natted traffic, but they both work together, that is why you see traffic matching the other (they are virtual nics that vmware uses, nothing too much to worry about there).

    But it also depends on how you set it up your network as well, as far as the virtual nics, most of the time allow the system to choose which adapter to chose from.

    Todd

  5. #5
    Just Joined!
    Join Date
    Jun 2007
    Posts
    20
    LOL, my bad, I already done this,
    meant that I changed it from

    Code:
    auto lo
    iface lo inet loopback
    to

    Code:
    auto lo
    iface lo inet loopback
    
    auto eth0
    iface eth0 inet dhcp
    Yeah, loopback, home, localhost is very handy way of checking,
    127.0.0.1.


    Didn't manage to see the virtual adapter choice option on vmware player, on the advance options, there is no option to choose the adapter, can't seem to find that, but it's no problem for now.



    Thanks a bunch Todd, very much appreciated your help on this.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •