Find the answer to your Linux question:
Results 1 to 4 of 4
Hello. For the beginning sorry but my english is bad.. I tried to find an answer for my problem,but can't see it (or am blind). I downloaded Ubuntu 12.10, installation ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2012
    Posts
    2

    Question Question - Problem with mouse


    Hello.

    For the beginning sorry but my english is bad..
    I tried to find an answer for my problem,but can't see it (or am blind).

    I downloaded Ubuntu 12.10, installation was successful and when i boot up everything is ok, but..
    When i see my desktop, click on firefox (for example). Program is running, but here my problem start's... when i click second time anywhere my mouse not responding (can only move the cursor no buttons working). Now i can only use my keyboard (Tab for change box + arrows, ALT+F4 for quit current window). Even right mouse button not working.

    This problem is on all distribution (i tried) : Mint 11 and 13 , Ubuntu 12.10 and 12.04 , Mandriva 2009 one ... all checked on 32 bit and 64bit. With 4 different mouse's.
    Pc specification :

    AMD Phenom II 64bit
    4 GB RAM
    Graphic : Gainward GeForce 550Ti
    Motherboard: AsRock series N68-XXX
    Mouse: Saitek R.A.T 5
    Keyboard: Tracer Lucid TRK-212

    Please help or tip what may be wrong

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Hi and Welcome !

    Have you checked Hardware Drivers option in Menu? Does it suggest any proprietary driver installation?
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Oct 2012
    Posts
    2
    Mint 13 and Mint 11 want update only graphics drivers. Ubuntu says "all drivers updated"

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Oct 2012
    Posts
    1
    The problem is your Saitek R.A.T. 5 mouse. Unfortunately the R.A.T. series of mice confuse the input for the X server because of the mode buttons. This is usually solved by editing the xorg.conf and setting the button mapping for your mouse.

    Unfortunately, the new version of Ubuntu Quantal Quetzal (12.10) has introduced some strange new kind of xorg.conf including the manner in which to change settings for mouse input. Until someone figures out how to do this, RAT 3 and RAT 5 and RAT 7 mice will not work in Ubuntu. You're better off installing 12.04

    I have also tried using xinput and various button mapping programs to change the mouse settings, unfortunately everything seems to be broken in 12.10 - not to go off on a tangent, but I can't even click on "use proprietary video driver" anymore for my nVidia card because it breaks the X server and switches to an unusable resolution. 12.10 is a horrible mess, frankly after about 10 years, I'm thinking of switching back to Vanilla Debian or something else, Ubuntu has really gone down hill the past 2 years, real shame. Currently all of my production and live servers now run 12.04 LTS and its going to stay that way unless they really change this hot mess. Really sad. Even sadder that with possibly the worst release ever, now is when they start asking for handouts. Real classy Ubuntu.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •