Find the answer to your Linux question:
Results 1 to 2 of 2
My parents have a hard drive that my brother gave them for use with a Popcorn Hour machine. After I plugged it into my computer (Windows OS) I found that ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2012
    Posts
    1

    Cannot Mount File


    My parents have a hard drive that my brother gave them for use with a Popcorn Hour machine. After I plugged it into my computer (Windows OS) I found that I could not open the hard drive and was asked to reformat the hard drive - which I did not do. I tried putting it back in the Popcorn machine and it worked, but after I plugged it into my computer again, it did not work.

    I found out from my brother afterwards, that this hard drive is formated for Linux, so I downloaded Ubuntu and plugged it in. It detects the hard drive but when I try to open it up, it says it is unable to mount it. I have another hard drive with media data on it, formatted in the same way, and when i plug it into my laptop or the Popcorn Hour machine, both open up so I'm thinking I did something to this particular drive.

    I don't know a lot about Linux, so please help me, and please, explain it to me like I'm a 2 year old.

    The harddrive is a WD 2 TB.

    Also, if it matters, the first time I plugged it to a computer, I plugged it through the SATA cords inside of a desktop computer. The second time I plugged it in, I used a SATA to USB cord and plugged it into my laptop.

  2. #2
    Linux Enthusiast
    Join Date
    Jan 2005
    Location
    Saint Paul, MN
    Posts
    648
    Linux supports multiple "filesystem" (the basic layout on the disk that provides support for directories (Windowing environments usually refer to these as "folders") and files). The support for a "filesystem" can be build into the linux kernel or it can be built as insertable/removable module of the kernel (known as a Module). If he kernel does not support (or the module for the filesystem is not loaded) it can mount the partition (or whole drive when not partitioned). So to tell you what you need to do depends on the filesystem that is used on the Popcorn Hour machine. A quick Google of the 'Popcorn Hour machine' says that it is using the Ext3 filesystem (at least in the UK model) which should be supported by your Ununtu system. So if I were you I would attempt to see how the drive is partitioned. (I do stuff from the command line as user root in the following (so you will need to precede them with "sudo"). Also the number of physical drives internal and connected to the computer (or the device name of the drive)

    If you have "blockdev" (determined by the command: which blockdev):
    blockdev --report
    This shows all the "block devices" that are active on the machine. Drives are a "block device" (input/output are performed via blocks rather than by characters). You might see something like:
    RO RA SSZ BSZ StartSec Size Device
    rw 256 512 4096 0 1000204886016 /dev/sda
    rw 256 512 4096 2048 1023410176 /dev/sda1
    rw 256 512 4096 2000896 30975979520 /dev/sda2
    rw 256 512 4096 62500864 968203698176 /dev/sda3
    rw 256 512 4096 0 1000204886016 /dev/sdb
    rw 256 512 1024 63 1000202241024 /dev/sdb1
    rw 256 512 4096 0 1000204886016 /dev/sdc
    rw 256 512 4096 2048 1072693248 /dev/sdc1
    rw 256 512 4096 2097152 33554432 /dev/sdc2
    rw 256 512 4096 2162688 33554432000 /dev/sdc3
    rw 256 512 4096 67698688 965542412288 /dev/sdc4
    Using this information (before and after plugging in the drive, you can figure out the drive device (in the above the drives are
    • /dev/sda
    • /dev/sdb
    • /dev/sdc

    Since my notebook has two internal drives and "dev/sda" and "/dev/sdb" were reported before plugging in the external drive, I know that the external is "dev/sdc".

    If you have "parted" (determined by the command: which parted):
    parted /dev/sdc print
    This shows the partitions (which are also show in the "blockdev" command above).
    Model: WDC WD10 JPVT-00A1YT0 (scsi)
    Disk /dev/sdc: 1000GB
    Sector size (logical/physical): 512B/512B
    Partition Table: gpt
    Disk Flags:

    Number Start End Size File system Name Flags
    1 1049kB 1074MB 1073MB ext2 boot
    2 1074MB 1107MB 33.6MB bios_grub
    3 1107MB 34.7GB 33.6GB linux-swap(v1)
    4 34.7GB 1000GB 966GB
    To attempt to mount the desired partition (in the example above it would be "/dev/sda4") so the command would be:
    Code:
    mkdir  -p  /mnt/popcorn
    mount  -t  ext3  -o  ro  /dev/sdc4 /mnt/popcorn
    For read-only (use rw for read-write)

    If it mounts the data is with the directory "/mnt/popcorn"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •