Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
Hello all, I have a desktop system (P4 - 3.0 GHz.) which runs Lubuntu 12.04. Whenever i'm watching a movie on youtube, the screensaver turns my screen blank. How do ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! nomko's Avatar
    Join Date
    Dec 2010
    Location
    /home/nomko
    Posts
    7

    Question Turn off screensaver


    Hello all,

    I have a desktop system (P4 - 3.0 GHz.) which runs Lubuntu 12.04. Whenever i'm watching a movie on youtube, the screensaver turns my screen blank. How do i switch off the screenssaver completely? Is it a sort of a deamon which can be disabled or removed?

    Any help will be very much appreciated!

  2. #2
    Just Joined! ShadowCat8's Avatar
    Join Date
    Sep 2005
    Location
    San Gabriel Valley, CA
    Posts
    10
    Well,

    To start with, do you know which screensaver app you are running? gnome-screensaver, kscreensaver or xscreensaver?

    Any way you slice it, there should be a way to control it under Preferences -> ScreenSaver, but how to configure it will likely depend on which one you are running.

    HTH. Let us know.

  3. #3
    Linux Newbie reginaldperrin's Avatar
    Join Date
    Oct 2010
    Location
    Christchurch, New Zealand
    Posts
    122
    There are potential issues with Nvidia drivers in 12.10. It can be "cured" by switching your graphics driver to the Nouveau free and open source one.
    I had the same screen blanking issues, and switching fixed it immediately. I had tried all the settings I could find, but none worked. It didnt want to behave itself.
    HAving said switch, you might find some minor text-display glitches, but you'll have to decide what is worse - having to keep moving the mouse every ten mintues when wayching movies, or a few lines where the text seems a little scrambled until it's redrawn.

  4. #4
    Linux Newbie
    Join Date
    Jun 2004
    Location
    Halesowen, West Midlands, UK
    Posts
    107
    Quote Originally Posted by reginaldperrin View Post
    There are potential issues with Nvidia drivers in 12.10. It can be "cured" by switching your graphics driver to the Nouveau free and open source one.
    I had the same screen blanking issues, and switching fixed it immediately. I had tried all the settings I could find, but none worked. It didnt want to behave itself.
    HAving said switch, you might find some minor text-display glitches, but you'll have to decide what is worse - having to keep moving the mouse every ten mintues when wayching movies, or a few lines where the text seems a little scrambled until it's redrawn.
    I have been running kernels 3.7-rc2 and now 3.7-rc3 with the NVidia kernel module 310.14 with no issues.
    root@sdrbox:~# uname -r
    3.7.0-rc3+
    root@sdrbox:~# cat /proc/driver/nvidia/version
    NVRM version: NVIDIA UNIX x86_64 Kernel Module 310.14 Tue Oct 9 11:52:41 PDT 2012
    GCC version: gcc version 4.7.2 (Ubuntu/Linaro 4.7.2-2ubuntu1)
    root@sdrbox:~# cat /etc/lsb-release
    DISTRIB_ID=Ubuntu
    DISTRIB_RELEASE=12.10
    DISTRIB_CODENAME=quantal
    DISTRIB_DESCRIPTION="Ubuntu 12.10"

  5. #5
    Just Joined! fenario's Avatar
    Join Date
    Mar 2009
    Location
    Rylstone NSW Australia
    Posts
    36

    startup

    Quote Originally Posted by nomko View Post
    Hello all,

    I have a desktop system (P4 - 3.0 GHz.) which runs Lubuntu 12.04. Whenever i'm watching a movie on youtube, the screensaver turns my screen blank. How do i switch off the screenssaver completely? Is it a sort of a deamon which can be disabled or removed?

    Any help will be very much appreciated!
    Hi

    In Preferences > Startup Applications > you can disable screensaver by unchecking it there.

    Hope that works for you.

    fen

  6. #6
    Just Joined! fenario's Avatar
    Join Date
    Mar 2009
    Location
    Rylstone NSW Australia
    Posts
    36
    And if you cannot see that in startup type or copy and paste this in a terminal:
    sudo sed -i 's/NoDisplay=true/NoDisplay=false/g' /etc/xdg/autostart/*.desktop

  7. #7
    Just Joined! nomko's Avatar
    Join Date
    Dec 2010
    Location
    /home/nomko
    Posts
    7
    Quote Originally Posted by reginaldperrin View Post
    There are potential issues with Nvidia drivers in 12.10.
    If you have read my post more carefully, then you could read that i'm using Lubuntu 12.04.

  8. #8
    Just Joined! nomko's Avatar
    Join Date
    Dec 2010
    Location
    /home/nomko
    Posts
    7
    Quote Originally Posted by fenario View Post
    In Preferences > Startup Applications > you can disable screensaver by unchecking it there.
    Hi fenario,

    Done that, it didn listed there.
    Last edited by nomko; 11-09-2012 at 05:47 PM.

  9. #9
    Just Joined! nomko's Avatar
    Join Date
    Dec 2010
    Location
    /home/nomko
    Posts
    7
    Quote Originally Posted by fenario View Post
    And if you cannot see that in startup type or copy and paste this in a terminal:
    sudo sed -i 's/NoDisplay=true/NoDisplay=false/g' /etc/xdg/autostart/*.desktop
    Haven't tried this command. I'll try this out and let you know if this helped.

  10. #10
    Just Joined!
    Join Date
    Feb 2007
    Posts
    21
    Quote Originally Posted by nomko View Post
    Hello all,

    I have a desktop system (P4 - 3.0 GHz.) which runs Lubuntu 12.04. Whenever i'm watching a movie on youtube, the screensaver turns my screen blank. How do i switch off the screenssaver completely? Is it a sort of a deamon which can be disabled or removed?

    Any help will be very much appreciated!
    Might be worth trying:

    xset -dpms

    to disable the X server energy saver

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •