Find the answer to your Linux question:
Results 1 to 5 of 5
Hi, whenever I try to install a program I always face with dependency issues ( like : dependent on package xxx but xxx is not installed ), and installations are ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2012
    Posts
    3

    dependency issues


    Hi,

    whenever I try to install a program I always face with dependency issues ( like : dependent on package xxx but xxx is not installed ), and installations are not done ( aborted ), what should I do ? I tried to install dependent packages but they were also dependent to other packages and so on, it seemed endless operation for just one simple installation.

    I installed lxde but it has few programs and graphical packages I tried to install synaptic package installer to analyze the package issues in system but installation failed like others due to dependency issues

    I also used ubuntu software center to install my desired programs but software center says that I have broken packages to fix and asks me to fix them and I tried to make the system fix the packages but it fails and gives error message I attached the message at the end of my writing

    I am using dpkg ( for .deb ) or ( udate, upgrade ) apt-get install commands to install programs from terminal

    I am beginner for linux/ubuntu o.s so I appreciate if you can help me fix this issue

    version : 12.04
    desktop : lxde
    I am using remote server ( connection via vnc viewer )

    installArchives() failed: perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
    LANGUAGE = (unset),
    LC_ALL = (unset),
    LANG = "None.None"
    are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    locale: Cannot set LC_CTYPE to default locale: No such file or directory
    locale: Cannot set LC_MESSAGES to default locale: No such file or directory
    locale: Cannot set LC_ALL to default locale: No such file or directory
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
    LANGUAGE = (unset),
    LC_ALL = (unset),
    LANG = "None.None"
    are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    locale: Cannot set LC_CTYPE to default locale: No such file or directory
    locale: Cannot set LC_MESSAGES to default locale: No such file or directory
    locale: Cannot set LC_ALL to default locale: No such file or directory
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
    LANGUAGE = (unset),
    LC_ALL = (unset),
    LANG = "None.None"
    are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    locale: Cannot set LC_CTYPE to default locale: No such file or directory
    locale: Cannot set LC_MESSAGES to default locale: No such file or directory
    locale: Cannot set LC_ALL to default locale: No such file or directory
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
    LANGUAGE = (unset),
    LC_ALL = (unset),
    LANG = "None.None"
    are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    locale: Cannot set LC_CTYPE to default locale: No such file or directory
    locale: Cannot set LC_MESSAGES to default locale: No such file or directory
    locale: Cannot set LC_ALL to default locale: No such file or directory
    Setting up linux-image-3.2.0-33-generic-pae (3.2.0-33.52) ...
    Running depmod.
    update-initramfs: deferring update (hook will be called later)
    The link /initrd.img is a dangling linkto /boot/initrd.img-3.2.0-33-generic-pae
    Examining /etc/kernel/postinst.d.
    run-parts: executing /etc/kernel/postinst.d/dkms 3.2.0-33-generic-pae /boot/vmlinuz-3.2.0-33-generic-pae
    run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.2.0-33-generic-pae /boot/vmlinuz-3.2.0-33-generic-pae
    update-initramfs: Generating /boot/initrd.img-3.2.0-33-generic-pae
    E: /usr/share/initramfs-tools/hooks/fixrtc failed with return 1.
    update-initramfs: failed for /boot/initrd.img-3.2.0-33-generic-pae with 1.
    run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
    Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-3.2.0-33-generic-pae.postinst line 1010.
    dpkg: error processing linux-image-3.2.0-33-generic-pae (--configure):
    subprocess installed post-installation script returned error exit status 2
    No apport report written because MaxReports is reached already
    dpkg: dependency problems prevent configuration of linux-image-generic-pae:
    linux-image-generic-pae depends on linux-image-3.2.0-33-generic-pae; however:
    Package linux-image-3.2.0-33-generic-pae is not configured yet.
    dpkg: error processing linux-image-generic-pae (--configure):
    dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of linux-image:
    linux-image depends on linux-image-generic-pae (= 3.2.0.33.36); however:
    Package linux-image-generic-pae is not configured yet.
    dpkg: error processing linux-image (--configure):
    dependency problems - leaving unconfigured
    No apport report written because MaxReports is reached already
    No apport report written because MaxReports is reached already
    dpkg: dependency problems prevent configuration of mencoder:
    mencoder depends on libavcodec52 (>= 4:0.5.1-1) | libavcodec-extra-52 (>= 4:0.5.1-1); however:
    Package libavcodec52 is not installed.
    Package libavcodec-extra-52 is not installed.
    mencoder depends on libavformat52 (>= 4:0.5.1-1) | libavformat-extra-52 (>= 4:0.5.1-1); however:
    Package libavformat52 is not installed.
    Package libavformat-extra-52 is not installed.
    mencoder depends on libavutil49 (>= 4:0.5.1-1) | libavutil-extra-49 (>= 4:0.5.1-1); however:
    Package libavutil49 is not installed.
    Package libavutil-extra-49 is not installed.
    mencoder depends on libfaac0 (>= 1.26); however:
    Package libfaac0 is not installed.
    mencoder depends on libjpeg62; however:
    Package libjpeg62 is not installed.
    mencoder depends on libmpcdec3; however:
    Package libmpcdec3 is not installed.
    mencoder depends on libpostproc51 (>= 4:0.5.1-1) | libpostproc-extra-51 (>= 4:0.5.1-1); however:
    Package libpostproc51 is not installed.
    PNo apport report written because MaxReports is reached already
    ackage libpostproc-extra-51 is not installed.
    mencoder depends on libswscale0 (>= 4:0.5.1-1) | libswscale-extra-0 (>= 4:0.5.1-1); however:
    Package libswscale0 is not installed.
    Package libswscale-extra-0 is not installed.
    mencoder depends on libx264-85; however:
    Package libx264-85 is not installed.
    dpkg: error processing mencoder (--configure):
    dependency problems - leaving unconfigured
    Errors were encountered while processing:
    linux-image-3.2.0-33-generic-pae
    linux-image-generic-pae
    linux-image
    mencoder
    Setting up linux-image-3.2.0-33-generic-pae (3.2.0-33.52) ...
    Running depmod.
    update-initramfs: deferring update (hook will be called later)
    The link /initrd.img is a dangling linkto /boot/initrd.img-3.2.0-33-generic-pae
    Examining /etc/kernel/postinst.d.
    run-parts: executing /etc/kernel/postinst.d/dkms 3.2.0-33-generic-pae /boot/vmlinuz-3.2.0-33-generic-pae
    run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.2.0-33-generic-pae /boot/vmlinuz-3.2.0-33-generic-pae
    update-initramfs: Generating /boot/initrd.img-3.2.0-33-generic-pae
    E: /usr/share/initramfs-tools/hooks/fixrtc failed with return 1.
    update-initramfs: failed for /boot/initrd.img-3.2.0-33-generic-pae with 1.
    run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
    Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-3.2.0-33-generic-pae.postinst line 1010.
    dpkg: error processing linux-image-3.2.0-33-generic-pae (--configure):
    subprocess installed post-installation script returned error exit status 2
    dpkg: dependency problems prevent configuration of mencoder:
    mencoder depends on libavcodec52 (>= 4:0.5.1-1) | libavcodec-extra-52 (>= 4:0.5.1-1); however:
    Package libavcodec52 is not installed.
    Package libavcodec-extra-52 is not installed.
    mencoder depends on libavformat52 (>= 4:0.5.1-1) | libavformat-extra-52 (>= 4:0.5.1-1); however:
    Package libavformat52 is not installed.
    Package libavformat-extra-52 is not installed.
    mencoder depends on libavutil49 (>= 4:0.5.1-1) | libavutil-extra-49 (>= 4:0.5.1-1); however:
    Package libavutil49 is not installed.
    Package libavutil-extra-49 is not installed.
    mencoder depends on libfaac0 (>= 1.26); however:
    Package libfaac0 is not installed.
    mencoder depends on libjpeg62; however:
    Package libjpeg62 is not installed.
    mencoder depends on libmpcdec3; however:
    Package libmpcdec3 is not installed.
    mencoder depends on libpostproc51 (>= 4:0.5.1-1) | libpostproc-extra-51 (>= 4:0.5.1-1); however:
    Package libpostproc51 is not installed.
    Package libpostproc-extra-51 is not installed.
    mencoder depends on libswscale0 (>= 4:0.5.1-1) | libswscale-extra-0 (>= 4:0.5.1-1); however:
    Package libswscale0 is not installed.
    Package libswscale-extra-0 is not installed.
    mencoder depends on libx264-85; however:
    Package libx264-85 is not installed.
    dpkg: error processing mencoder (--configure):
    dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of linux-image-generic-pae:
    linux-image-generic-pae depends on linux-image-3.2.0-33-generic-pae; however:
    Package linux-image-3.2.0-33-generic-pae is not configured yet.
    dpkg: error processing linux-image-generic-pae (--configure):
    dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of linux-image:
    linux-image depends on linux-image-generic-pae (= 3.2.0.33.36); however:
    Package linux-image-generic-pae is not configured yet.
    dpkg: error processing linux-image (--configure):
    dependency problems - leaving unconfigured

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    apt-get sort out dependency issues itself and it looks like something is wrong sources.list file or slow/dead internet connection.
    Execute this
    Code:
    sudo apt-get clean all
    sudo dpkg --configure -a
    sudo apt-get update
    In case it doesn't solve problem, post the contents of /etc/apt/sources.list file here.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Nov 2012
    Posts
    3
    Quote Originally Posted by devils casper View Post
    apt-get sort out dependency issues itself and it looks like something is wrong sources.list file or slow/dead internet connection.
    Execute this
    Code:
    sudo apt-get clean all
    sudo dpkg --configure -a
    sudo apt-get update
    In case it doesn't solve problem, post the contents of /etc/apt/sources.list file here.
    thanks for your fast reply

    I executed the commands that you gave and problem still exists

    here is my sources.list content

    deb archive.ubuntu.com/ubuntu precise main restricted universe
    deb archive.ubuntu.com/ubuntu precise-updates main restricted universe
    deb security.ubuntu.com/ubuntu precise-security main restricted universe$
    deb archive.canonical.com/ubuntu precise partner

    deb download.virtualbox.org/virtualbox/debian precise contrib

  4. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    There is a $ sign at the end of third line. Is it a typo?
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  5. #5
    Just Joined!
    Join Date
    Nov 2012
    Posts
    3
    I copied and posted this from terminal screen from terminal yes there is $ sign but when I opened in desktop there is no $ sign, this is a vps server so I will probably reinstall the system from control panel, and I will setup gnome desktop

    if my problems will still exist after that I will write them here again

    thanks for your attention and help

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •