Find the answer to your Linux question:
Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 25
YOu wouldn't happen to have gnome-tweak-tool installed, would you? If not: $ sudo apt-get install gnome-tweak-tool let me know the result....
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Aug 2012
    Posts
    14

    YOu wouldn't happen to have gnome-tweak-tool installed, would you? If not:
    $ sudo apt-get install gnome-tweak-tool

    let me know the result.

  2. #12
    Just Joined!
    Join Date
    Mar 2012
    Posts
    19
    Quote Originally Posted by AGrant View Post
    YOu wouldn't happen to have gnome-tweak-tool installed, would you? If not:
    $ sudo apt-get install gnome-tweak-tool

    let me know the result.
    Always did. I was poking around that today...

  3. #13
    Just Joined!
    Join Date
    Aug 2012
    Posts
    14
    Okay, quick testing, whilst avoiding the boss, reveals that you may have removed a couple of files used by the window manager. To get them back, try using the CompizConfig Settings Manager (CCSM). (Just like you pondered earlier).before you go into CCSM, in a terminal type:

    $ sudo unity --reset

    you should get a message telling you reset is deprecated, but don't worry too much about that. For whatever reason it does have an effect.

    after this, go to CCSM and look for the "Effects" in the left bar. It's about half way down the bar.

    int he main task area, there should be three options : Animations, Fading Windows, Window Decoration; make sure they are all checked. Then click the text "Window Decoration". this should take you to a new window, make sure that "Enable Window Decoration" on the left of the box is checked and you have:
    "/usr/bin/gtk-window-decorator" (without the quotes) in the command box. (Top of the right hand task area)

    Also make sure that Decoration windows is set to "any" and Shadow windows is "any" as well.

    Now go to, General Compiz Options. Key bindings.

    In here, you should see a series of labels, have a look and see if these options have an instruction set next to them:
    Close Window <alt><f4>
    Minimize Window <control><primary><alt>KP0
    Maximize Window <control><primary><super>Up
    Unmaximize Window <control><primary><super>down
    Show Desktop <control><primary><super>d

    If they don't click on the button and set it to the defaults, I've popped them next to the label text. the <...> bit.

    do all of this and close CCSM

    now go to the terminal and type:

    sudo stop lightdm

    restart your computer.
    You should be presented with the usual login screen, select unity and lightdm and the proper buttons should magically appear. I hope!

  4. $spacer_open
    $spacer_close
  5. #14
    Just Joined!
    Join Date
    Mar 2012
    Posts
    19
    Did everything you said. Once any app is maximized, then those buttons are gone and I am stuck with the global menu in the upper left hand corner.

    You are persistent.

    I do auto-login. Not sure if that means anything.

  6. #15
    Just Joined!
    Join Date
    Mar 2012
    Posts
    19
    Quote Originally Posted by AGrant View Post
    Now go to, General Compiz Options. Key bindings.

    In here, you should see a series of labels, have a look and see if these options have an instruction set next to them:
    Close Window <alt><f4>
    Minimize Window <control><primary><alt>KP0
    Maximize Window <control><primary><super>Up
    Unmaximize Window <control><primary><super>down
    Show Desktop <control><primary><super>d
    By the way, there is a Minimize Windows with a mouse symbol next to it that is disabled.

  7. #16
    Just Joined!
    Join Date
    Aug 2012
    Posts
    14
    Just out of curiosity, run in a terminal,

    $ wmctrl -m

    If you don't have this installed, $ sudo apt-get install wmctrl

    If there is no window manager displayed, it should be the first piece of data shown, you will probably need to reinstall the window manager.
    To reinstall compiz do:

    $ sudo apt-get install unity-2d
    then same instruction for:

    ubuntu-desktop
    ubuntu-desktop-2d
    compizconfig-settings-manager
    xserver-xgl
    emerald
    conpize-fusion-plugins-extra
    git compiz-plugins-extra
    compix-plugins-extra
    unity

    the order is important.

    This should take you back to the default desktop. Make sure you back up your /home directory[ies]! It usually works, but occasionally will delete things in /home. Still trying to figure out why.

    Oh, and make sure the disabled extensions in firefox are enabled.

    Once you get this back, you should be able to get what you want, if you do it step by step. Each step, restart/logout[in] and test. then if something doesn't work you can just undo it. (if you uninstall anything use the apt-get remove command rather than autoremove) once you have tested everything and it's all to your liking, you can use apt-get autoremove to get rid of the vestiges of what ever remains.

    I always find it handy to write down everything i do in a little notebook or on a piece of paper. Yup, the paperless office requires more paper!

    Let me know how you get on. This one has got stuck in the curiosity department of the brain cell.

    I'm taking my wife to dinner now. So, will not be able to get to a computer for a fair few hours.

    Night!

  8. #17
    Just Joined!
    Join Date
    Mar 2012
    Posts
    19
    Sorry for the long delay. You really know your stuff. I did this $ wmctrl -m and it was not installed, so it is now installed. I am backing up my files but am hesitant to continue. Your instructions reference Unity 2D. I thought Unity 2D was removed from 12.10.

  9. #18
    Just Joined!
    Join Date
    Aug 2012
    Posts
    14
    You are quite right, unity-2d is not included in Ubuntu12.10, however, when you run $ sudo apt-get install unity-2d the system should run through as if it is installing. I've just tested it on three ubuntu computers and it goes through the motions. This step seems to be important for the rest of the installs. Why, I don't know.
    Did you run $ wmctrl -m? and if so, did it give you any output? if it did, can you post the output? We're just interested in the first two which should show you which window manager you are running: for example on the computer I am currently using it shows:

    Name: KWin
    Class: kwin

    on the computer I am accessing it shows:

    Name: Compiz
    Class: N/A

    and on the server it just states:
    Cannot open window manager

    If you have a problem, you should get an error message. Should. But this is Linux and what should happen doesn't always! Oh the joys of Linux computing!

  10. #19
    Just Joined!
    Join Date
    Mar 2012
    Posts
    19
    I get the following when I run wmctrl -m:

    Name: Compiz
    Class: N/A
    PID: N/A
    Window manager's "showing the desktop" mode: OFF

  11. #20
    Just Joined!
    Join Date
    Mar 2012
    Posts
    19
    Well I followed your instructions and unfortunately I still have the same problem when any window is maximized. Also, the following with an asterisk were 'Unable to be found"

    sudo apt-get install unity-2d
    then same instruction for:

    ubuntu-desktop
    *ubuntu-desktop-2d
    *compizconfig-settings-manager
    *xserver-xgl
    *emerald
    *conpize-fusion-plugins-extra
    git compiz-plugins-extra
    compix-plugins-extra
    *unity

Page 2 of 3 FirstFirst 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •