Find the answer to your Linux question:
Page 3 of 3 FirstFirst 1 2 3
Results 21 to 25 of 25
I did end up with a quite a few extra options in Compiz. I have no idea what any of them mean, but I got 'em!...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #21
    Just Joined!
    Join Date
    Mar 2012
    Posts
    19

    I did end up with a quite a few extra options in Compiz. I have no idea what any of them mean, but I got 'em!

  2. #22
    Just Joined!
    Join Date
    Aug 2012
    Posts
    14
    Am out in the "field" for a fair few hours, so haven't any access to my desk. Will respond as soon as I can. But you should be able to do what you want to do, as wmctrl shows you have a window manager present and that it's functioning. Have a peer round compizconfig see if you can do what you want to do. Has Firefox got the Ubuntu extensions? If not, try installing them, including the unity extension. Make sure they are enabled.
    I will endeavor to get back to you later this evening. Sorry about this, but the regular chap got himself arrested. (When a cop tells you to do something, might be a good idea to do it. Not argue the case and try and kick the copper...)

  3. #23
    Just Joined!
    Join Date
    Aug 2012
    Posts
    14
    If anyone else wants to help, please do! Thanks.

  4. $spacer_open
    $spacer_close
  5. #24
    Just Joined!
    Join Date
    Mar 2012
    Posts
    19
    Much obliged for all your help. Firefox has the Global Menu extensions disabled as I do not want it. Enabling it makes no difference - I get the same thing (no buttons on maximized Firefox). For what its worth, this is the first time I have done an upgrade. KDE Plasma was a flawless upgrade. Gnome shell needed a few tweaks but works perfectly. Its just Unity that is a mess.

    As for Compiz, I have no idea what the extra plugins mean.

  6. #25
    Just Joined!
    Join Date
    Aug 2012
    Posts
    14
    Okay dokey, sorry for the delay in getting back to you.
    It appears the answer is simpler than first thought. I've just done this on about 8 computers running Unity, Ubuntu 12.10, and each works with no problems at all.
    What you need to do is:

    in a terminal type:

    $ sudo apt-get remove indicator-appmenu
    press enter and pop in your password (the usual stuff)

    that's it!

    this should put all the menu's and buttons in the application.

    In Firefox you need to disable (not remove):

    Global Menu Bar Integration
    Ubuntu Firefox Modifications
    Unity Desktop Integration

    Removing them screws the whole thing up, but disabling seems to work a treat.

    Let me know how you get on.

    Cheers!
    Last edited by AGrant; 11-30-2012 at 05:04 PM. Reason: typo's...

Page 3 of 3 FirstFirst 1 2 3

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •