Find the answer to your Linux question:
Results 1 to 5 of 5
Hi Experts, when I execute "date" command , it gives me the right date. But If I create a file and do "ls -lart" it appears that it has been ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2013
    Posts
    2

    wrong date while creating files


    Hi Experts,
    when I execute "date" command , it gives me the right date.
    But If I create a file and do "ls -lart" it appears that it has been created 6 Feb 2009 !!???
    Anyone has any clue

  2. #2
    Trusted Penguin Irithori's Avatar
    Join Date
    May 2009
    Location
    Munich
    Posts
    3,390
    Hi and welcome

    could you please execute these commands and paste the result?
    Code:
    date
    touch foo
    ls -la foo
    You must always face the curtain with a bow.

  3. #3
    Just Joined!
    Join Date
    Jan 2013
    Posts
    2
    Hi Irithori,
    === root@eqm01s0fp2 ANCB ~ # date
    Thu Jan 3 14:06:32 CET 2013
    === root@eqm01s0fp2 ANCB ~ # touch test
    === root@eqm01s0fp2 ANCB ~ # ls -lart test
    -rw-r--r-- 1 root root 0 Feb 6 2009 test
    === root@eqm01s0fp2 ANCB ~ #

  4. #4
    Trusted Penguin Irithori's Avatar
    Join Date
    May 2009
    Location
    Munich
    Posts
    3,390
    hmm, it is root´s $HOME, so the chance, that it might be a non-posix filesystem is slim.
    Anyway, please post the output of these in CODE tags:
    Code:
    mount
    dmesg
    Are you maybe using a networked filesystem like nfs, ocfs, etc?
    You must always face the curtain with a bow.

  5. #5
    Just Joined!
    Join Date
    Dec 2012
    Location
    Utah
    Posts
    25
    Is it possible that atime and/or diratime was disabled? I always disable it to speed up my hard drive.
    cat /etc/fstab

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •