Find the answer to your Linux question:
Results 1 to 3 of 3
I have been running a Linux Mint VM for some months now, where I do my Ruby and Ruby-related development. Earlier today I installed the F5 VPN plugin and used ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2013
    Posts
    3

    My linux VM lost internet after disconnecting my F5 VPN session


    I have been running a Linux Mint VM for some months now, where I do my Ruby and Ruby-related development.

    Earlier today I installed the F5 VPN plugin and used my linux VM to connect to my company's network. This worked just fine, and I could do anything I normally do, plus connect to our company servers and databases.

    The problem started when I disconnected from VPN later today. Once I did that, I can still reach my router, but can no longer get to the internet.

    Pinging mit.edu or google.com simply fails.

    Here is my ifconfig info:

    eth0 Link encap:Ethernet HWaddr 00:0c:29:cb:78:00
    inet addr:192.168.0.25 Bcast:192.168.0.255 Mask:255.255.255.0
    inet6 addr: fe80::20c:29ff:fecb:7800/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:401 errors:0 dropped:0 overruns:0 frame:0
    TX packets:329 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:50042 (50.0 KB) TX bytes:33110 (33.1 KB)

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

    Please note that this is a wired connection. I am currently running the VM in bridged mode, but have also tried swapping back and forth to NAT mode (where it shares the same IP as the host computer), with no luck.

    Nor has doing simple things like ifconfig eth0 down (and then up) helped.

  2. #2
    Just Joined!
    Join Date
    Jan 2013
    Posts
    3
    I have narrowed the problem. I am able to ping external entities if I use their IP address (ex. 74.125.225.195, which corresponds to google.com).

    This points to some kind of problem with dns.

  3. #3
    Just Joined!
    Join Date
    Jan 2013
    Posts
    3
    This may have been a foolish thing, but...it seems to have worked.

    I backed up my /etc/resolv.conf and then deleted it.
    I then ran: sudo /etc/init.d/networking restart

    I can now access internet entities by their hostname, not just IP.

    I notice that the resolv.conf was not recreated or anything, by the system, so I'm not sure how necessary it is, or whether I should put it back (in a modified form perhaps?).

    I believe the VPN software messed with the file, leading to my issues when VPN disconnected.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •