Find the answer to your Linux question:
Results 1 to 10 of 10
Today when I booted up my machine this screen appeared. I don't even know what screen that is so I can't even google it. This may not be the right ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! Mo3u8se's Avatar
    Join Date
    Jan 2013
    Posts
    18

    What is this?


    Today when I booted up my machine this screen appeared.
    I don't even know what screen that is so I can't even google it. This may not be the right section but zorin is based off of Ubuntu. Any help would be appreciated.

    Specs(based off the top of my head)
    AmdA8 Quadcore 2.4Ghz
    8gigs RAM
    Graphics: Gt520 Nvidia 2gb
    Attached Images Attached Images

  2. #2
    Linux User
    Join Date
    Dec 2007
    Location
    Idaho USA
    Posts
    362
    do you have linux 'Zorin OS 6' installed ? google it

  3. #3
    Just Joined! Mo3u8se's Avatar
    Join Date
    Jan 2013
    Posts
    18
    Of course I do. What should I google? I don't even know what the screen I'm in is called.

  4. #4
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023
    Hello and Welcome!
    Looks like a console login screen. You should be able to login with your username and password, then use startx to get a GUI.
    Did you happen to run a system update during your previous login?
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

  5. #5
    Just Joined! Mo3u8se's Avatar
    Join Date
    Jan 2013
    Posts
    18
    No I didn't. Didn't install a driver or anything. I can login with my username and password but then it looks like I'm in terminal. I'll try that command and see where I get. Thanks.

  6. #6
    Just Joined! Mo3u8se's Avatar
    Join Date
    Jan 2013
    Posts
    18
    I did start startx and I found out that there was an error with my graphics card drivers and the kernels. Atleast I know what to google. Thank you.

  7. #7
    Linux Engineer
    Join Date
    Apr 2012
    Location
    Virginia, USA
    Posts
    889
    You're at a terminal login screen. GUI did not start for one reason or another, if it is even installed. Have you tried simply rebooting?

    You can log in with your regular username and password, then try
    sudo startx

    Also, have you recently made any changes to your system?

    EDIT: I guess I didn't read through all the replies before I replied.

  8. #8
    Just Joined! Mo3u8se's Avatar
    Join Date
    Jan 2013
    Posts
    18
    Thanks to everyone who posted. I have messed around with my graphics card kernel and driver and I've got it working. Thanks

  9. #9
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023
    Glad you got it sorted.
    Just for anyone that might have a similar issue, what did you have to do to get it working again?

    BTW, feel free to mark the thread as [SOLVED] using the Thread Tools button at the top of your first post.
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

  10. #10
    Just Joined! Mo3u8se's Avatar
    Join Date
    Jan 2013
    Posts
    18
    Because I don't have enough posts to post the link. Here's what I did.
    You will need to boot into recovery mode, then issue apt-get remove --purge nvidia-current on the root terminal, followed by apt-get install nvidia-current - to rebuild the nvidia driver for the new kernel. I had this problem as well when I upgraded.

    Please do not install the drivers from nVidia's website btw! You could cause serious trouble if you then try to install the recommended driver later without cleanly removing the previous one.

    Edit: You will need to run these commands from a terminal. I cannot guarantee a perfect result, since I am going based on what I've found via the internet and from memory.

    The problem you are getting is caused by having differing user mode components and kernel modules. To fix it, the nvidia kernel module has to be rebuilt. This is supposed to happen on reboot, but it often does not.

    First you need to install the linux kernel headers:

    sudo apt-get install linux-headers-generic

    Then you will need to run dkms to remove the old nvidia kernel module:

    sudo dkms remove nvidia

    Then run:

    sudo apt-get install nvidia-current
    this should make it install correctly, so all you need to do is run sudo nvidia-xconfig and reboot.
    If you still get an error about the module version, run: sudo dkms build nvidia

    This should solve the problem.

    Sorry if things are a little confusing, I tried to put back together the process I had to use to the best of my memory ! If you run into problems don't hesitate to let me know (and if anyone spots any problems with the instructions please let me know ASAP)!!!!
    Update:

    I found another possible cause. Nouveau might not have been blacklisted, and nvidia-current may not have placed itself in the .conf file that is used to choose your display driver. Here is how to fix it:
    NB:

    Before you continue, ensure that you have the nvidia-current driver from the repositories. Downloading the driver from nvidia's website can cause problems later, as it does not use the debian package format and leaves things behind that can conflict with later installations. So make sure you clear any traces of it first, and then install the standard driver from the Ubuntu repos. If you do not, you will get a driver mismatch, and this fix will be pointless.

    If you are stuck on the console, log in and install the nouveau X.org driver: sudo apt-get install xorg-xserver-video-nouveau
    Restart your computer (you will have working graphics, yay! But this is temporary).
    Open gedit as root: gksu gedit.
    From gedit open /etc/modprobe.d/blacklist.conf.
    Add this line at the bottom: blacklist nouveau.
    Save the file, and open /etc/modprobe.d/nvidia-graphics-drivers.conf.
    Add these lines:

    blacklist nouveau
    blacklist lbm-nouveau
    blacklist nvidia-173
    blacklist nvidia-96
    alias nvidia nvidia-current

    Now save this file, and close gedit.
    Run:
    sudo nvidia-xconfig,
    and then:
    sudo apt-get remove xserver-xorg-video-nouveau,
    followed by:
    sudo shutdown -r now.
    When your system restarts, you should have working nvidia drivers.

    By the way, this problem of not blacklisting nouveau seems to exist in the newer drivers (nvidia-current), so I would suggest after fixing the problem, that you wait for an update on this bug (I am going to report the bug soon).

    Alternate solution: If you did install the NVIDIA drivers from their web site, then you must boot into a text terminal, (hold at boot to see grub menu and select 'recovery' mode of the kernel version that last worked with the NVIDIA drivers, and select the command line as root option)

    Then run the original NVIDIA install shell script you ran to install the NVIDIA drivers from their website. e.g. sudo ./NVIDIA-Linux-x86-290.10.run --uninstall. (Your version may differ.)

    You won't need to run the "sudo dkms remove nvidia" command, as this doesn't apply for your case.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •