Find the answer to your Linux question:
Results 1 to 7 of 7
Sup everyone Ive run into a strange issue on a machine running 12.04 LTS. I think it started after running chown to modify permissions on what I thought was one ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2013
    Posts
    5

    System permissions problem?


    Sup everyone

    Ive run into a strange issue on a machine running 12.04 LTS.

    I think it started after running chown to modify permissions on what I thought was one directory, a subdir of Downloads folder.

    Now, when the machine boots, the GUI session fails to load. I can log in to virtual terminals (TTYS) with my user account and thats about it.

    The machine runs some services which dont start up when it boots. Both network interfaces in the machine do not get configured by DHCP on boot up so it cant communicate on network at all. Machine says it cant even open a ICMP socket to localhost when try to ping loopback. 'Operation not permitted' is what is says....sounds like permission problem.

    When you try to do anything root, 'it says must be setuid root'.

    The other strange thing is I can hear the CPU fan working indicating something processor intensive is going on.

    Boot into a recovery CD? Any thoughts?

  2. #2
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,102
    I don't really see how changing permissions on a sub-directory of your Downloads directory would cause the problems you have posted. It will be difficult for anyone to suggest a way for you to undo whateveer it is you did when you don't know what it is that you did. If the GUI fails to load, have you tried typing: startx at a terminal prompt?

  3. #3
    Just Joined!
    Join Date
    Jan 2013
    Posts
    5
    strange, after a window comes up with 'failed to load session: ubuntu' I click enter and then a window comes up that says 'The system is running in low graphics mode'...click enter again, a window comes up 'What would you like to do' ....run in low graphics mode one session, reconfigure graphics, troubleshoot, exit to console...at this point there is no response to my keyboard or mouse so I cannot choose an option

    as you can see in my original reply, this is more than a graphics issue

    let me know if you have any other suggestions, its lookin like i might need to reinstall OS...

  4. #4
    Linux Newbie mactruck's Avatar
    Join Date
    Apr 2012
    Location
    City of Salt
    Posts
    185
    wait dont do that, Is your card AMD? I had this same issue last week when I went from 12.04 to 12.10. 12.10 does not support some older AMD cards by default. let me find the link I used and it worked great.

  5. #5
    Linux Newbie mactruck's Avatar
    Join Date
    Apr 2012
    Location
    City of Salt
    Posts
    185
    Try this.

    Code:
    sudo add-apt-repository ppa:makson96/fglrx 
    sudo apt-get update 
    sudo apt-get upgrade 
    sudo apt-get install fglrx-legacy

  6. #6
    Just Joined!
    Join Date
    Jan 2013
    Posts
    5
    nah I'm using onboard video intelchip

  7. #7
    Just Joined!
    Join Date
    Jan 2013
    Posts
    5
    thanks but if you read my original respose, my network interfaces do not get configd by dhcp so I have no network...also I cannot sudo anything

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •