Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
Hello, I am Deepika, I am new to this forum, About 2 hrs. ago I faced a major problem : after login, only the terminal was appearing and no desktop. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2013
    Posts
    6

    ubuntu 10.04, only terminal display & no desktop


    Hello, I am Deepika, I am new to this forum, About 2 hrs. ago I faced a major problem : after login, only the terminal was appearing and no desktop. This problem occurred after following the 3 commands to sync iphone to the rhythmbox :

    sudo add-apt-repository ppa:pmcenery/ppa
    sudo apt-get update
    sudo apt-get dist-upgrade

    After doing the above I restarted & then only terminal was appearing and no desktop. I have uninstalled libimobiledevice package but still no change. If anyone has any solutions to this problem please let me know. Thanks.
    Last edited by jayd512; 01-25-2013 at 01:46 AM. Reason: un-parse smiley

  2. #2
    Just Joined! Mo3u8se's Avatar
    Join Date
    Jan 2013
    Posts
    18
    I had something like this happen to me. Let me find my thread about it.
    Edit: Because I need 2 more posts until I can post a link. Just click my name. Go to view forum posts and look at the very first post I posted.
    Edit 2: Just type startx and see what happens.

  3. #3
    Just Joined!
    Join Date
    Jan 2013
    Posts
    6
    Hi, i typed startx ans i get the following message : X: user not authorized to run the x server, aborting.

    Also I did the following for abt 2 hrs. :

    I removed the ppamcenery from /etc/apt/sources.list.d/ and also removed the ppa gpg key using : sudo apt-key del id. Now to some extent I am sure that I have removed the ppa repository.

    After that I did the following
    sudo apt-get update but it says it fails to fetch few files. e.g : could not resolve: security.ubuntu.com, could not resolve : archive.canonical.com, could not resolve dl.google.com

    Then i run the command : sudo apt-get dist upgrade and it says 0 upgraded,0 newlly installed, 0 to remove and 0 not upgraded. Then i run the command : sudo apt-get install ubuntu-desktop and it says, could not resolve : in.archive.ubuntu.com, security.ubuntu.com

    And then also tried : sudo aptitude install gnome, but still no luck.

    Please reply asap.

  4. $spacer_open
    $spacer_close
  5. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Hi and Welcome !


    Which Graphics Card do you have? Post your Machine's specs here.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  6. #5
    Just Joined!
    Join Date
    Aug 2006
    Posts
    13
    Yes, welcome and hello.

    As mentioned already, the machines graphics card model would be great. But if you don't know, no sweat! Also, is this a laptop (with wireless internet) or a desktop?

    Can you also quickly run this command, and see what it tells you?

    Code:
    cat /var/log/Xorg.0.log | grep -i '(EE)'
    The 'cat' command prints onto the screen what is inside '/var/log/Xorg.0.log', which is the log file for your graphics. The bar ('|') and the 'grep' command filter through the output of that log file and will only show the part that have '(EE)' on it - in effect searching for the error.

  7. #6
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023
    Hello and Welcome!

    Going along with the above question from DC, did this problem occur after a system update/upgrade?
    Or were the commands that you listed the only ones involved before rebooting your system?
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

  8. #7
    Just Joined!
    Join Date
    Jan 2013
    Posts
    6
    after typing it says : (ww) warning, (EE) error, (NI) not implemented, (??) unknown

  9. #8
    Just Joined!
    Join Date
    Jan 2013
    Posts
    6
    yes the problem after sys update/upgrade &
    the following were the only commands before rebooting :

    sudo add-apt-repository ppamcenery/ppa
    sudo apt-get update
    sudo apt-get dist-upgrade

  10. #9
    Just Joined!
    Join Date
    Jan 2013
    Posts
    6
    when i wrote startx in root drive it said : fatal server error: server is already active for display 0. If this server is no longer running remove /tmp/.X0-lock .

  11. #10
    Just Joined!
    Join Date
    Aug 2006
    Posts
    13
    Quote Originally Posted by deepikarc View Post
    yes the problem after sys update/upgrade &
    the following were the only commands before rebooting :

    sudo add-apt-repository ppamcenery/ppa
    sudo apt-get update
    sudo apt-get dist-upgrade
    Best way I know how to revert a PPA addition is to use 'ppa-purge'.

    You will have to install it first:

    Code:
    sudo apt-get install ppa-purge
    Then you will most likely have to add the PPA to your sources again. Just do your 'apt-add-repository' command again.

    Then type
    Code:
    sudo ppa-purge pmcenery/ppa
    That would revert your packages back to the way they were before you added them.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •