Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
I suspect this is a graphics problem. This has happened through several Ubuntu revisions, so not a Unity issue. This is not my primary desktop so I've always just used ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2011
    Posts
    9

    Boot hangs on Purple screen


    I suspect this is a graphics problem. This has happened through several Ubuntu revisions, so not a Unity issue. This is not my primary desktop so I've always just used this work around. I manually select 2nd kernel option (Recovery Mode) and it goes to the Recovery Menu. I simply select the 1st option, Resume Normal Boot and it boots up just fine. But if I don't select anything in Grub or select the normal kernel it promptly hangs on a plain purple screen. My mouse light goes off and the keyboard keys don't respond (not even caps lock for example). I have to hard boot to get back to grub so I can select Reocovery Mode. I rarely use my Ubuntu desktop (most of my work is in RHEL command-line non-gui servers), so it's never been a big deal to just use the work around when booting up, but I figured I would throw it out there for help in troubleshooting so that the default kernel will boot normally.
    (also inside the Display option, clicking "Detect Displays", doesn't appear to do anything at all. Should I get a pop-up?)

    Let me know what commands I can run or what logs/config files you would like to see. I can post anything from dmesg. I can confirm once inside the GUI, the Display option thinks I'm a laptop (it is not). The GUI also says my video card is a VESA: Matrox P650/P750. Not sure if this is correct or not. The highest resolution I can display is 1024x768. I know my Planar PL1910M can go much higher than this as I run a windows box on it that does 1280x1024 quite easily. I'm sure this might be a driver issue, but don't want to troubleshoot this part quite yet. Just want the first kernel option (when the countdown timer times out), to be able to boot up properly just like Recovery Mode seems to do just fine.

    Running: Ubuntu 12.04.1 LTS Kernel 3.2.0-36-generic i686
    Update Manager says I'm fully updated.

    Let me know what to try. Very comfortable on the command-line, just don't know much about the graphics or gui side of things.

    Thanks!

  2. #2
    Just Joined!
    Join Date
    Jan 2013
    Posts
    6
    Sounds like grub can only load the default vesa driver. Verify Matrox driver is installed. Run Synaptic, search for xserver-xorg-video-mga. If it is already installed you may need a different version. Enter lspci from command line to view your card specifics, then go to matrox.com downloads to find the latest driver for your card. If you have video out you may also need package matroxset (installable from Synaptic).

  3. #3
    Just Joined!
    Join Date
    Nov 2011
    Posts
    9
    What does entering Recovery Mode kernel and then immediately resuming boot do different? Isn't there an option to step through the boot process one line at a time to see where the problem occurs?

    xserver-xorg-video-mga is installed. Synaptic reports that the installed version and latest version are the same (1:1.4.13.dfsg-4build2). That is Ubuntu's default repository so maybe the vendor may have a newer version.

    Is there a place in the boot-up/grub where I can manually define it to use 1024x768 all the way through boot-up and into the GUI rather than it trying to auto-detect supported resolutions?

    matroxset was not installed, but I've got it installed now, although when I run the command it says Cannot open /dev/fb1: No such file or directory (does nothing if I click on it in the GUI)

    The graphics lines of lspci are:
    00:02.0 Display controller: Intel Corporation 82Q963/Q965 Integrated Graphics Controller (rev 02)
    0b:00.0 VGA compatible controller: Matrox Graphics, Inc. Millennium P690 (rev 01)

    I can confirm I'm plugged into the Matrox card. The card has dual DVI ports. I've powered off and tried plugging into the second DVI port and it shows nothing on the monitor after powering back on (when I switch back, I'm in the hung state since it took the default kernel). When I switch to the internal VGA connector, nothing on my monitor either during boot-up (this probably needs to be enabled in the BIOS to work). But again, the Recovery Mode method boots just fine. Weird huh?

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jan 2013
    Posts
    6
    Please post the contents of /etc/X11/xorg.conf
    Last edited by mobuntu; 01-29-2013 at 11:51 PM.

  6. #5
    Just Joined!
    Join Date
    Jan 2013
    Posts
    6
    One additional question: do you have a PCI or PCIe graphics card, or is it integrated? The next steps will depend on that info.

  7. #6
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Post the output of /etc/X11/xorg.conf file, if any.
    Post output of lspci command too.
    Code:
    lspci | grep -i vga
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  8. #7
    Just Joined!
    Join Date
    Jan 2013
    Posts
    6
    Casper, he posted lspci previously. Looks like intel chipset, probably PCIe. Bus address (hex) is 0b:00.0 - remember to convert to decimal for xorg. He has some legwork to do before this card will work as it should, but he must start at the beginning.

    If I had a dollar for every hardware issue I have encountered with Linux, I would be a millionaire. If I had a dollar for every hardware problem I resolved, I would still be a millionaire.

    Remember folks, this is precisely why Windoze became so user-friendly, the techs did all the hardware/driver resolution before you even opened the box, and they got paid well for it. With Linux, we suffer, persevere and rejoice when we triumph!! Then, we help out every other lost soul by sharing, and we don't get a dime. Keep the faith.

  9. #8
    Just Joined!
    Join Date
    Nov 2011
    Posts
    9
    /etc/X11/xorg.conf does not exist. Seems they (try to) auto-detect these settings now.

    The card is PCIe. Remember it is Matrox, not Intel (which is the Integrated one turned off in BIOS I presume as I can't boot to it currently. See above, last paragraph).

    Here is another command I discovered:
    sudo lshw -C video
    *-display UNCLAIMED
    description: VGA Compatible controller
    product: Millennium P690
    vendor: Matrox Graphics, Inc.
    physical id: 0
    bus info: pci@0000:0b:00.0
    version: 01
    width: 64 bits
    clock: 33MHz
    capabilities: pm pciexpress msi vga_controller bus_master cap_list
    configuration: latency=0
    resources: memory:d0000000-d7ffffff memory:d8200000-d8201fff memory:d8220000-d823ffff

    My concern is the first line that says UNCLAIMED. The Intel Integrated graphics also shows UNCLAIMED. Is this normal, or does this mean no driver is loaded?

    I have gone to Matrox's website and they do have linux drivers for this card I can try.
    My question is how do I see what driver is installed now? Several google searches say to try to uninstall the driver first. How do I do that? I would first have to see what is installed/loaded as a driver (not just installed as a .deb or .rpm), before I can even attempt to remove/unload it.

    For example I read this post "In Maverick we've just disabled the autoloader for the Intel driver on these cards. That should give a baseline stable experience for users of these cards, dropping back to fbdev." Now ignoring the Intel part, how do I know for sure if my Matrox driver is loaded or not by the kernel? Or how can I see if I haven't been dropped back down to fbdev for compatibility sake (which would explain my choice of only two common display resolutions).

  10. #9
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Before trying anything else, I would suggest you to try basic xorg.conf file first. If it doesn't work, we will look for other options.

    Copy following contents and save in /etc/X11/xorg.conf file. Reboot machine.
    Code:
    Section "Device"
           Identifier "Configured Video Device"
           Driver    "vesa"  
    EndSection
    
    Section "Monitor"
             Identifier "Configured Monitor"
             HorizSync 31.5 - 70.0
             VertRefresh 50 - 160
     EndSection
    
    Section "Screen"
            Identifier "Default Screen"
            Monitor "Configured Monitor"
            Device "Configured Video Device"
            DefaultDepth 24
            Subsection "Display"
                 Depth 24
                 Modes "1280x1024" "1024x768" 
            EndSubsection
    EndSection
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  11. #10
    Just Joined!
    Join Date
    Jan 2013
    Posts
    6
    You might have to enter some or all of the following as su or root, or use sudo. These changes are temporary unless you make them permanent.

    Check that the driver is loaded
    # /sbin/lsmod | grep mtx

    If nothing found then load it
    # /sbin/modprobe mtx

    Check for agp module
    # /sbin/lsmod | grep agpgart

    If found you will see
    agpgart 33608 0

    If not found and you want to use advanced graphics
    # /sbin/modprobe agpgart

    The Matrox configuration module can be run by entering
    # matroxconfig

    If that package does not run it may need to be installed. If you are able to configure your driver this way, you will probably have to restart the X server # startx

    The mtx driver and agp modules can be made to load at startup by adding them to /etc/modprobe.preload, but first verify that your system is working properly.

    One further note, if your chipset agp is not loaded (check that by entering # /sbin/lsmod | grep agp) load it manually
    # /sbin/modprobe intel-agp

    Probably all 3 modules should be added to /etc/modprobe.preload once all is working.

    If you choose to follow Casper's advice by creating the xorg.conf file, you should add BusID "PCI:11:0:0" to the Device section, and change "vesa" to "mtx".

    If you are interested in finding out more about your settings look in /usr/share/x11.

    Good luck, and always remember that playing around with some of this stuff could damage your monitor.
    Last edited by mobuntu; 01-31-2013 at 01:52 AM.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •