Find the answer to your Linux question:
Results 1 to 1 of 1
I've been searching for an answer for a couple days and if this has been covered, please forgive me and please point me in the right direction. The other night, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2009
    Posts
    39

    vesafb/kernel issue unable to get past session selection


    I've been searching for an answer for a couple days and if this has been covered, please forgive me and please point me in the right direction.

    The other night, I was doing cleanup before imaging my partition, as I usually do with bleachbit, janitor, and removing a couple cache directories. This time, the only thing I changed was I included "localizations" in bleachbit. My system seemed to lose every graphical quality and I rebooted. Upon rebooting, I get the following error I've seen documented abundantly: "FAIL: Error inserting vesafb (/location/vesafb.ko) No such device". I had this before and gave up, ultimately restoring from a previous clone zilla image. This time, unfortunately, I can't because I have a plethora of data not backed up that I need access to.

    I've seen plenty of posts on this and all the recommendations don't work. Upon boot, it no longer boots directly into the OS, rather takes me to a login window, it attempts to login after so many seconds, I get the error and a black screen, it takes me back to the login window, and repeats.

    I have the boot menu hidden with startup manager and need to get to it or a command line to repair, recover, etc. I've tried all recommendations I've seen of depressing "shift", "esc", and even someone mentioning "alt+ctrl+f1". The latter didn't seem to do anything while trying during startup. However, when I depress "shift", I see "Grub loading." and nothing after. It attempts to go back to the login screen and it's cyclical repetition of annoyance.

    I tried booting from a live cd, mounting sda1, and tried to update grub but don't think it is updating anything but the live cd space. How can I get to a point to update grub, get to a command line from boot to run a set of commands, or edit the cfg file from a prompt to type the necessary information to edit out vesafb,

    Any help is greatly appreciated! Thank you!

    As an update, I've gotten to the live cd and updated grub. I now have a boot menu if I hold shift down but that's it - same errors, same everything... Any ideas?
    Last edited by metropoli10; 03-26-2013 at 03:46 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •