Find the answer to your Linux question:
Results 1 to 3 of 3
I performed a fresh install of Ubuntu Server 12.10 x64 on a 64GB SSD. This entire drive is for o/s use. I have a RAID-5 volume from my old Ubuntu ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2008
    Posts
    25

    Ubuntu Server 12.10 boot problem


    I performed a fresh install of Ubuntu Server 12.10 x64 on a 64GB SSD. This entire drive is for o/s use. I have a RAID-5 volume from my old Ubuntu Server 12.10 x64 server build that I want to move into this new build. It's an Ubuntu soft-RAID. From what I've read, it should be portable so long as mdadm is installed on the new system, which it is. Unfortunately, when I add the disks to the system it boots to an initramfs prompt. Take the RAID volume out and it boots up fine. I tried re-installing the o/s with the RAID drives present, and the installer recognizes the volume and installs a couple RAID packages so that I see the volume when I come to the screen to set up partitioning. Seems like GRUB loader doesn't find the boot volume during boot-up, but I have no idea how to address or fix that. Of course that's just an idea and may not be the issue at all.

    Any suggestions would be greatly appreciated. I have a good backup of the data, but I'd like to get through this without rebuilding the volume, if for anything else, to learn what the problem is and how to resolve it.

    Thanks,
    Dave

  2. #2
    Just Joined!
    Join Date
    Feb 2011
    Posts
    23
    Dave,

    I think you might be right about GRUB being the source of the problem. I've had a similar issue where having something plugged in changes which GRUB disk identifier corresponds to which actual disk. It might be that the Ubuntu installer configured with GRUB the wrong disk identifier and it's trying to boot off the the RAID rather than the SSD. I didn't have initramfs set up on the machine that I had this issue with, so I can't be sure of what role that plays in all this.

    Regardless of whether or not that is actually the problem you are having, I recommend ESC-ing out to a GRUB prompt so you can see what GRUB is trying to do. See what disk, kernel, and options it's using, and whether or not they're right. If GRUB isn't the issue and it's still not working, I would also try removing initramfs from the boot line in GRUB. It isn't needed to boot, so it'd be interesting to see what happens when initramfs isn't started first.

    Also, I would like to know: are you using a separate boot partition? Initramfs can't start unless GRUB can find it. If GRUB is booting off of the RAID then I guess you shouldn't be seeing initramfs—unless you're using a boot partition and it's actually the root that's misconfigured—and that's a kernel issue. So much for that theory . Anyway, I recommend you try messing with GRUB and initramfs to see what's going on, and post your findings so we have more to go off of.

    Good Luck,
    willnoit

  3. #3
    Just Joined!
    Join Date
    Mar 2008
    Posts
    25
    Hey, thanks for the reply. First off, I should apologize as my post didn't have the right release. The correct release was 12.04. Anyway, I was able to resolve the issue. My boot drive is so fast that I didn't notice a brief pause when initramfs was loading. I was being prompted because my array was degraded for some reason. I ignored the issue and booted successfully, then reassembled the array and added the "missing" drive back in using mdadm.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •