Find the answer to your Linux question:
Results 1 to 2 of 2
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Ubuntu - Win8 laptop - Secure Boot - GPT vs MBR...

    i have an ASUS S56C. It came pre-installed with Windows 8. I disabled Secure Boot from the BIOS and installed Ubuntu Linux 13.04 via LiveUSB flash drive. The installation succeeded, however afterwards I was unable to boot up properly. In fact, the drives just were not being seen whatsoever in the BIOS. I noticed a pattern through experimenting... If I installed Ubuntu on a drive with an MBR table, it installed and booted fine. If I installed Ubuntu on a drive with a GPT table, it installed fine but wouldn't be visible to the BIOS to boot afterwards.

    While on one hand, I could use MBR, I'd really like to figure out how to get GPT working. Some discussions with both Windows channels and Linux channels reveals one similarity - everybody believes that the operating system has nothing to do with it, and that the issue is largely between the BIOS and the hardware itself. For what it's worth, I did successfully flash the latest BIOS without issue.

    I tried several different partitioning schemes but have yet to find one that worked using GPT as my partition table. I set a 1MiB partition, unformatted, and flagged it as bios_grub, but that did nothing. I also tried to set a separate /boot partition at 500MB, but that too did nothing. Overall, GPT was an instant road block, whereas MBR worked fine. But.... why? Does anybody have any idea as to why this is or what I can do to get GPT working?

    EDIT - Sometimes things are best left if on auto pilot. I left Ubuntu do the guided partitioning. Once the installation was done, booting up was a success. I installed GParted and checked out what Ubuntu did. Ubuntu had added its own EFI Partition (FAT32, 94MiB in size) at the very beginning of the drive. I ended up redoing it but this time chose manual and selected a 94MiB FAT32 partition to be selected as EFI Boot Partition and bam, that was it. All works well now, whether I use MBR or GPT tables. I am no longer insanely frustrated with ASUS, but I can't say the same for Microsoft. At any rate, we're good.
    Last edited by JaSauders; 04-23-2013 at 07:52 PM.

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Good report on your experience with this. It will help others who have this sort of problem with new EFI/(in)Secure-boot systems.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts