Find the answer to your Linux question:
Results 1 to 3 of 3
When i try to connect a windows XP machine to the samba 4 domain i keep getting the error RPC server is unavailable. These are all the samba testís I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2012
    Posts
    15

    Samba 4 & XP rpc server


    When i try to connect a windows XP machine to the samba 4 domain i keep getting the error RPC server is unavailable.

    These are all the samba testís I have done on the Ubuntu server 12.04.2 64 bit

    File in attachment i cannot post it due to the urlís
    Attached Files Attached Files

  2. #2
    Just Joined!
    Join Date
    Oct 2012
    Posts
    15
    I have found that the samba is not creating a computer account when adding the computer to the samba domain. How can I add the computer account to samba 4 (manually and automatic)?


    this is the netsetup.log from the XP machine

    05/07 09:48:32 NetpDoDomainJoin
    05/07 09:48:32 NetpMachineValidToJoin: 'XPTEST'
    05/07 09:48:32 NetpGetLsaPrimaryDomain: status: 0x0
    05/07 09:48:32 NetpMachineValidToJoin: status: 0x0
    05/07 09:48:32 NetpJoinDomain
    05/07 09:48:32 Machine: XPTEST
    05/07 09:48:32 Domain: SVDB
    05/07 09:48:32 MachineAccountOU: (NULL)
    05/07 09:48:32 Account: SVDB\administrator
    05/07 09:48:32 Options: 0x27
    05/07 09:48:32 OS Version: 5.1
    05/07 09:48:32 Build number: 2600
    05/07 09:48:32 ServicePack: Service Pack 3
    05/07 09:48:32 NetpValidateName: checking to see if 'SVDB' is valid as type 3 name
    05/07 09:48:32 NetpCheckDomainNameIsValid [ Exists ] for 'SVDB' returned 0x0
    05/07 09:48:32 NetpValidateName: name 'SVDB' is valid for type 3
    05/07 09:48:32 NetpDsGetDcName: trying to find DC in domain 'SVDB', flags: 0x1020
    05/07 09:48:40 NetpDsGetDcName: failed to find a DC having account 'XPTEST$': 0x525
    05/07 09:48:40 NetpDsGetDcName: found DC '\\SERVER' in the specified domain
    05/07 09:48:40 NetpJoinDomain: status of connecting to dc '\\SERVER': 0x0
    05/07 09:48:40 NetpGetLsaHandle: LsaOpenPolicy on \\SERVER failed: 0xc0020017
    05/07 09:48:40 NetpGetLsaPrimaryDomain: status: 0xc0020017
    05/07 09:48:40 NetpJoinDomain: initiaing a rollback due to earlier errors
    05/07 09:48:40 NetpJoinDomain: status of disconnecting from '\\SERVER': 0x0
    05/07 09:48:40 NetpDoDomainJoin: status: 0x6ba

  3. #3
    Just Joined!
    Join Date
    Oct 2012
    Posts
    15
    well i found a solution to my problem

    in the smb.conf file i added the + in the openchange lines


    # Global parameters
    [global]
    workgroup = SVDB
    realm = schepersvandebroek.local
    netbios name = SERVER
    server role = active directory domain controller
    dns forwarder = 8.8.8.8
    ### Configuration required by OpenChange server ###
    dcerpc endpoint servers = +epmapper, +mapiproxy, +dnsserver
    dcerpc_mapiproxy:server = true
    dcerpc_mapiproxy:interfaces = exchange_emsmdb, exchange_nsp, exchange_ds_rfr
    ### Configuration required by OpenChange server ###



    [netlogon]
    path = /usr/local/samba/var/locks/sysvol/schepersvandebroek.local/scripts
    read only = No

    [sysvol]
    path = /usr/local/samba/var/locks/sysvol
    read only = No

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •