Find the answer to your Linux question:
Results 1 to 5 of 5
Hello, Yesterday, i got a new ACER predator AG3620-UR308 which came with windows 8, so i wanted to run ubuntu 12.04.2 on it as a dual booting. To be honest, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2007
    Posts
    71

    Unhappy Dual Booting Win 8/ubuntu 12.04.2: install fine no grub menu


    Hello, Yesterday, i got a new ACER predator AG3620-UR308 which came with windows 8, so i wanted to run ubuntu 12.04.2 on it as a dual booting. To be honest, i've been doing dual booting for a while now so, i did the right thing. the box came with 2TB HDD. so i made 4 partitions with a raw partition just after the windows installation partition

    I always do manual installation so even if ubuntu didn't detect windows 8, it was ok for me. So i created swap area and finished the installation etc....Grub was install on the only drive there which is sda.

    After reboot, grub doesn't even come up.So it always boot in windows 8. I did repeat the process twice and yield same result. which is weird because this method always works for me so far. Even the laptop am using to write this post is a dual booting windows 7/ mint nadia installed the same way. Is there anything new in windows 8 that i didn't make provision for? Before starting the installation, all i read about was that , windows 8 should be installed first and ubuntu after.


    Anybody for the rescue?

    thanks very much

  2. #2
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    Windows 8 uses Secure Boot which needs to be turned off in the BIOS. I've not used windows 8 except on a Virtual Machine so can't tell you any more. Look for the option in the BIOS. If that doesn't do it, boot the Ubuntu CD and run the command: sudo fdisk -l and post the output. If that doesn't help, google 'bootinfoscript', go to the site and download and run it and it will give details on your partitions and boot files. It will need to be run from the Ubuntu CD as it is a bash script.

  3. #3
    Just Joined!
    Join Date
    Jan 2007
    Posts
    71
    Quote Originally Posted by yancek View Post
    Windows 8 uses Secure Boot which needs to be turned off in the BIOS. I've not used windows 8 except on a Virtual Machine so can't tell you any more. Look for the option in the BIOS. If that doesn't do it, boot the Ubuntu CD and run the command: sudo fdisk -l and post the output. If that doesn't help, google 'bootinfoscript', go to the site and download and run it and it will give details on your partitions and boot files. It will need to be run from the Ubuntu CD as it is a bash script.
    Thanks for your comment. I am a little away from the desktop so will get back to you after I check teh BIOS

  4. #4
    Just Joined!
    Join Date
    Jan 2007
    Posts
    71
    Hi,

    I've disabled secure boot and enabled CSM based on tutorials out there but it didn't boot into ubutu. below is the output of fdisk -l
    Code:
    ubuntu@ubuntu:~$ sudo fdisk -l
    
    WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util fdisk doesn't support GPT. Use GNU Parted.
    
    
    Disk /dev/sda: 2000.4 GB, 2000398934016 bytes
    255 heads, 63 sectors/track, 243201 cylinders, total 3907029168 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 4096 bytes
    I/O size (minimum/optimal): 4096 bytes / 4096 bytes
    Disk identifier: 0x8c361cb5
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sda1               1  3907029167  1953514583+  ee  GPT
    Partition 1 does not start on physical sector boundary.
    
    Disk /dev/sdb: 8178 MB, 8178892800 bytes
    255 heads, 63 sectors/track, 994 cylinders, total 15974400 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x0006a87e
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sdb1   *        2048    15972351     7985152    b  W95 FAT32
    ubuntu@ubuntu:~$
    I am installing it again.

  5. #5
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    You have GPT and uefi, so I would suggest you read up on those. I don't use either so don't feel comfortable making suggestions. Also, in your initial post you indicate you indicate you created four partitions and only one is seen by fdisk. fdisk has limitations with GPT so you might try using gparted from the Ubuntu CD or flash driveto see what the output is.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •