Find the answer to your Linux question:
Results 1 to 1 of 1
Hello, im working on school project, I installed ISPConfig which configured nginx server and it works, now I want to enable roundcube webmail. Im running ubuntu so I used apt-get ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2012
    Posts
    5

    How to setup nginx for roundcube in ispconfig server?


    Hello, im working on school project, I installed ISPConfig which configured nginx server and it works, now I want to enable roundcube webmail. Im running ubuntu so I used apt-get

    HTML Code:
    apt-get install roundcube roundcube-plugins roundcube-plugins-extra
    The wizard configured my MySQL database for roundcube and install roundcube web files to /usr/share/roundcube and in /var/lib/roundcube I have links to /usr/share/roundcube.

    Now I need to tell nginx if someone request URL myispconfig.tld/webmail it open roundcube. But I'm not sure how to do this, maybe some alias or creating vhost ? I can configure apache but I'm new in nginx. I read roundcube documentation so next configuration I think I can handle.

    i tried add to /etc/nginx/sites-available/ispconfig.vhost

    HTML Code:
    location  /webmail/ {
      alias  /usr/share/roundcube/; #here im not sure if use /usr/share or /var/lib location ?
    }
    but after nginx reload no changes :P

    i saw in configuration is commented squirrel solution i think it could be used ?

    edit: i tried add to /etc/nginx/sites-available/apps.vhost
    Code:
            location /roundcube {
                    root /usr/share/;
                    index index.php;
    
                    location ~ ^/roundcube/(.+\.php)$ {
                           try_files $uri =404;
                           root /usr/share/;
    
                           # PHP only, required if PHP was built with --enable-force-cgi-redirect
                           fastcgi_param   REDIRECT_STATUS         200;
                           # To access phpMyAdmin, the default user (like www-data on Debian/Ubuntu) must$
                           #fastcgi_pass 127.0.0.1:9000;
                           fastcgi_pass unix:/var/run/php5-fpm.sock;
                           fastcgi_index index.php;
                           fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
                           fastcgi_buffer_size 128k;
                           fastcgi_buffers 256 4k;
                           fastcgi_busy_buffers_size 256k;
                           fastcgi_temp_file_write_size 256k;
                           fastcgi_read_timeout 240;
    
                    }
            }
    but it return empty page, what i have to do maybe some permissions ? thank you..



    Thank you

    Edit: SOLVED, same configuration for squirrelmail WORK
    Last edited by muflix; 07-05-2013 at 01:13 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •