Find the answer to your Linux question:
Results 1 to 3 of 3
Hi im in need or urgent help. Ive been trying for weeks and boss is getting annoyed :O Target platform. uname -a : Linux Moxa 2.6.9-uc0 ~130 Wed jun 19:28:49 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2013
    Posts
    6

    URGENT: Help needed to make cross platform application


    Hi im in need or urgent help. Ive been trying for weeks and boss is getting annoyed :O

    Target platform.

    uname -a : Linux Moxa 2.6.9-uc0 ~130 Wed jun 19:28:49 CST 2009 armvtl unknown

    No onboard gcc compiler or python compiler.
    --------------------------------------------------------------------------------------------------
    My platform and what ive done so far:

    uname -a : Linux christopher-VirtualBox 3.8.0-29-generic #42~precise1-Ubuntu SMP Wed Aug 14 16:19:23 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

    I have 4 python source code files (.py) written in python3.3.

    I have used cx_freeze to make a file Called MOXA which should be a standalone executable.

    Ive installed a cross compiler called arm-linux_1.3.
    ---------------------------------------------------------------------------------------------------
    situation :

    When i try to run the MOXA executable i get the error : Cannot excute binary file?

    i spoke to MOXA support ( who im struggling to understand) and he gave me a download to a precompiled python3.1 package. The instructions where extract, ftp to the MOXA device and install. I get the error no gcc compiler.

    Moxa support have told me the device does not need a gcc compiler, thats why you install a cross compiler on my desktop. But i cant seem to see where i wuould use it?

    If you need to know anything else please ask

    Thanks in advance

  2. #2
    Penguin of trust elija's Avatar
    Join Date
    Jul 2004
    Location
    Either at home or at work or down the pub
    Posts
    3,501
    I'm not sure where the no gcc compiler error comes in? What are you compiling and where; Ubuntu or moxa?

    Do you have a link to the package?
    What do we want?
    Time machines!

    When do we want 'em?
    Doesn't really matter does it!?


    The Fifth Continent

  3. #3
    Just Joined!
    Join Date
    Oct 2013
    Posts
    6
    Quote Originally Posted by elija View Post
    I'm not sure where the no gcc compiler error comes in? What are you compiling and where; Ubuntu or moxa?

    Do you have a link to the package?
    Its a package given to me from MOXA support the guys who made the EC.

    I think what he is telling me todo is :

    unpackage python3.1

    use ./configure
    then make

    this pulls all source files and and toolchains together

    i then ftp the folder over to the EC and run on there?
    does this sound right?

    Also now when i use make i get the error

    TabError: inconsistent use of tabs and spaces in indentation?

    Thank you so much.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •