Find the answer to your Linux question:
Results 1 to 10 of 10
This is my first time using linux. I have a hp dv6000 which was running windows xp. Since I acquired this computer for free(was wiped totally clean) I was told ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2013
    Posts
    3

    Xubuntu not recognizing wireless.


    This is my first time using linux. I have a hp dv6000 which was running windows xp. Since I acquired this computer for free(was wiped totally clean) I was told to use xubuntu 32 bit(newest version which I think was 13.10) Anyway I got it all loaded up and I must say its nice and simple. Still getting used to everything. I only need this computer for checking emails and taking care of my forum chapter. No gaming or constant movie watching.

    My problem is my wireless doesnt work(orange light is on no matter what position my switch is in) Will connect to the internet if its hard wired in. I know its using broadcam bcm4311. Nothing shows up in the additional drivers tab either. Like I said this is my first time using it so its totally different from what im used to. Not a computer genius but I know my way around a computer somewhat.

  2. #2
    Linux Engineer docbop's Avatar
    Join Date
    Nov 2009
    Location
    Woodshed, CA
    Posts
    949
    In the menu bar at the top of the screen there is a network config tool, it looks like a up and down arrow next to each other. Have you opened that and configured the wireless settings?

  3. #3
    Just Joined!
    Join Date
    Nov 2013
    Posts
    3
    Quote Originally Posted by docbop View Post
    In the menu bar at the top of the screen there is a network config tool, it looks like a up and down arrow next to each other. Have you opened that and configured the wireless settings?
    Yeah nothing works.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux User Steven_G's Avatar
    Join Date
    Jun 2012
    Location
    Western US
    Posts
    415
    The bcm4311 and ubuntu don't really like each other all that well. It takes a little work to get them to play nice together. If you're not really invested in this setup I'd recommend changing to xubuntu 12.04. I always recommend the LTC releases over the point releases. Generally speaking they're a lot more stable and have fewer issues. They're also supported longer.

    This is one of those things where generally speaking there is more than one way to skin a cat and depending on several different factors the following solution may or may not work for you, but it is the one that *usually* works and should be tried first:

    Remove the default driver:
    Code:
    $ sudo apt-get remove --purge bcmwl-kernel-source
    Install a the Linux Firmware nonfree drivers:
    Code:
    $ sudo apt-get install linux-firmware-nonfree
    Load the b43 module:
    Code:
    $ sudo modprobe b43
    To make it work automatically:
    Code:
    $ sudo su
    # echo "b43" >> /etc/modules
    Let me know if this fixes you up or not. If not then it will have to be chased down the rabbit hole.

  6. #5
    Just Joined!
    Join Date
    Nov 2013
    Posts
    3
    Quote Originally Posted by Steven_G View Post
    The bcm4311 and ubuntu don't really like each other all that well. It takes a little work to get them to play nice together. If you're not really invested in this setup I'd recommend changing to xubuntu 12.04. I always recommend the LTC releases over the point releases. Generally speaking they're a lot more stable and have fewer issues. They're also supported longer.

    This is one of those things where generally speaking there is more than one way to skin a cat and depending on several different factors the following solution may or may not work for you, but it is the one that *usually* works and should be tried first:

    Remove the default driver:
    Code:
    $ sudo apt-get remove --purge bcmwl-kernel-source
    Install a the Linux Firmware nonfree drivers:
    Code:
    $ sudo apt-get install linux-firmware-nonfree
    Load the b43 module:
    Code:
    $ sudo modprobe b43
    To make it work automatically:
    Code:
    $ sudo su
    # echo "b43" >> /etc/modules
    Let me know if this fixes you up or not. If not then it will have to be chased down the rabbit hole.

    Ok well edit!

    Very weird none of my connections worked(even being hardwired in) restarted my computer and check the status of my internet and I noticed in the list it said enable wireless and it was check marked. Toggled my wireless switch on and bam it worked! Not sure what made it start but just wanna say thanks for everyone's help!!!
    Last edited by RidgeReaper; 11-14-2013 at 05:25 AM.

  7. #6
    Linux User Steven_G's Avatar
    Join Date
    Jun 2012
    Location
    Western US
    Posts
    415
    You'll probably still end up with the same problem and this will probably still fix it. I haven't played with 13.10. But the broadcom cards almost always have issues with any version of *nix and usually have to be played with a bit before they work. The bcm4311 is one of the worst for this. In general you'll have fewer issues over all with an LTS release though. This solution *should* work for any vesrion of ubuntu since at least 11.04 forward, unless they made big changes in 13.10. (Except for when it doesn't. But that involes too many if / thens to chase now, always try the best solutiion first.)

    ------------
    Edit:

    We cross posted. I see you got it fixed. Like I said the bcm4311 is a pain in the neck under nix. There are several drivers that will make it work; some better than others. Now that it's working if it turns out that it's not working very well you can try the solution above to see if that will improve performance.

  8. #7
    Linux Engineer TNFrank's Avatar
    Join Date
    Jul 2013
    Location
    Crossville, TN. USA
    Posts
    968
    The only card I've ever had a problem with is the bcm43xx that was in a Dell 1521. I changed out the card for a different one and Bingo, no more problems. Make it easy on yourself, order a new wifi card, install it and then you'll not have to fight with firmware and drivers to get the wifi to work.
    Of course if you must use that card then hook up your ethernet cable and click the Install Propriatary Drivers (look around, you'll find it) and install drivers for it then it'll work.

  9. #8
    Just Joined! Cargil's Avatar
    Join Date
    Dec 2013
    Posts
    10
    So I have a similiar problem!

    Also my wlan card doesn't work.

    My distro is Xubuntu 13 and my pc is an Asus 2,4 ghz, 898 mb ram, 2x64 turion.

    My wlan card is a Broadcom 4318.

    I've just set up my Xubuntu 13 and realized that my wireless card doesn't work. Only a wired connection works.

    What can I do?

    Thanks.

  10. #9
    Just Joined! Cargil's Avatar
    Join Date
    Dec 2013
    Posts
    10
    Alright. I fixed it following this:

    help.ubuntu.com/community/WifiDocs/Driver/bcm43xx

    I'm not sure in what I've done, but it works. That's important.

  11. #10
    Just Joined! Cargil's Avatar
    Join Date
    Dec 2013
    Posts
    10
    Another final question.

    How can manage an automatic connection when I open Xubuntu? Every time I start xubuntu I have to select manually the network and connect.

    How can I get an automatic connection?

    Thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •