Find the answer to your Linux question:
Results 1 to 5 of 5
Hello I have Ubuntu 12.04 and a printer Lexmark 3200. While installing ubuntu LPT in Bios was disabled. Now I am using the system and I switched to enabled to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2014
    Location
    Europe
    Posts
    14

    Installing printer Lexmark on Ubuntu


    Hello

    I have Ubuntu 12.04 and a printer Lexmark 3200.

    While installing ubuntu LPT in Bios was disabled. Now I am using the system and I switched to enabled to use the printer.

    I guess some drivers (modules) did not install because while adding the printer via CUPS there is no LPT at all.

    What shall I do to get the printer working fine.

    I am new to linux please give me a solution step by step.

    thank you

  2. #2
    Linux User zenwalker's Avatar
    Join Date
    Feb 2010
    Location
    Inland Empire
    Posts
    293
    Open Printing has all you need, I hope. Remember it, please.

    Welcome to GNU/Linux!
    "What you think about me is none of my business"
    _______________________________________________
    mint 17 xfce | HandyLinux | Slacko

  3. #3
    Just Joined!
    Join Date
    Mar 2014
    Location
    Europe
    Posts
    14
    Open Printing[/URL][/B][/I] has all you need, I hope. Remember it, please.

    Welcome to GNU/Linux!
    This is the driver, right? Nice, but my CUPS doesn't show any LPT# while trying to install the printer via CUPS by 'adding'.

    I suppose that my LTP port does not run and I need to load module to have it run. How the hell am I supposed to do that? As I say, during ubuntu instalation LPT was disabled in BIOS, but now it is enabled.

    I think that in command line I shall put: modprobe ......................................

    No clue on what after modprobe.
    Last edited by berserk; 03-03-2014 at 04:06 PM.

  4. #4
    Linux User zenwalker's Avatar
    Join Date
    Feb 2010
    Location
    Inland Empire
    Posts
    293
    Open browser. In address line, type "http://localhost:631/admin" and choose "Add Printer.
    Here, at CUPS login, type in your normal UserName and Password

    Also, in the Lexmark 3200 page link point to, see "Generic Instructions: CUPS," link. Options are listed.

    Or, go to "directly download PPD" link under driver, lxm3200-tweaked for ubuntu.

    Note: It is sometimes necessary to uninstall printer before doing the above -- the only way i have gotten my printers to work.
    It's SOP, if somewhat confusing to newbies.
    "What you think about me is none of my business"
    _______________________________________________
    mint 17 xfce | HandyLinux | Slacko

  5. #5
    Just Joined!
    Join Date
    Mar 2014
    Location
    Europe
    Posts
    14
    nice, but in the CUPS there is nothing in 'local printers' - just blank. It looks like linux doesn't find LPT. Any help? please.

    --> looks like I have managed to solve the problem alone!!

    Just installed some 'paraller prineters' libraries and 'printconf' - a very nice piece of software: Automatically configures USB and parallel printers with CUPS. Everything from repozitories. Seems like ubuntu 12.04 and obove doesn't care about LPT printers and I had to install additional software to make my printer working.

    Those who are straggling the same problem make sure you have LPT enabled in BIOS.
    Last edited by berserk; 03-19-2014 at 08:50 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •