Find the answer to your Linux question:
Results 1 to 2 of 2
Ubuntu 13.10 Here is my situation: My work laptop uses a NIS configuration. While directly connected directly to the work network, NIS is able to bind to the server without ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2014
    Posts
    1

    NIS configuration on a laptop


    Ubuntu 13.10

    Here is my situation:

    My work laptop uses a NIS configuration. While directly connected directly to the work network, NIS is able to bind to the server without issue (unless of course the server is down...).

    However, while away from work, I cannot directly connect to NIS. My laptop takes forever to boot up (if I switch to tty2 I can stop the autofs and ypbind service). ypbind will only work when I attach my laptop to the VPN making those NIS servers accessible.

    After some googling, I tried setting YPBIND_MAXWAIT in /etc/environment but this did not appear to take effect. Is there anything else I can do (such as /etc/nsswitch.conf) to prevent NIS from waiting forever to bind?

    Note: the only things that really require nis is the netgroups and autofs... both of which I believe can wait until I have logged in to the company VPN

  2. #2
    Linux User zenwalker's Avatar
    Join Date
    Feb 2010
    Location
    Inland Empire
    Posts
    292
    This may or may not help.
    "What you think about me is none of my business"
    _______________________________________________
    antiX | SolydX | Puppy Slacko

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •