Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
Hi Iíve just setup a linux lamp server on an old laptop. I installed Ubuntu 13.0.4. From there I did an update and now I have 13.10 I then set ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2012
    Posts
    10

    now wont install updates


    Hi
    Iíve just setup a linux lamp server on an old laptop. I installed Ubuntu 13.0.4. From there I did an update and now I have 13.10 I then set up a static ip. All works fine. The problem is that now when I try to do any updates or installs such as sudo apt-get install phpmyadmin Ubuntu reads the package ok says it will install 34.8 mb. I press y to confirm and it then says it has failed to fetch the files because it failed to resolve the gb.archive.ubuntu.com directories.

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,454
    Please post exact copies of the error messages/logs. Just from what you have posted so far, I suspect that the upgrade to 13.10 has the SELinux service running and that is blocking the download of the required files. Try disabling SELinux and trying again.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Just Joined!
    Join Date
    Feb 2012
    Posts
    10
    Thanks Rubberman for your reply I checked to see if Selinux was running but have found it is not installed at the moment here is a screen capture showing what's happening when I try to update. capture1.jpg

    I have just tried pinging other devices on my network works fine from the linux machine and the other way from my pc to linux machine. If I try to ping a web address though it does not get through from the linux machine.
    Last edited by peterp53; 04-15-2014 at 07:31 AM.

  4. #4
    Linux Engineer
    Join Date
    Dec 2013
    Posts
    1,078
    Sounds like you haven't set a gateway? You can view your route table like:
    Code:
    /sbin/route -n
    If a gatway isn't set here's instructions for setting a default: Debian / Ubuntu Linux Setting a Default Gateway

  5. #5
    Just Joined!
    Join Date
    Feb 2012
    Posts
    10
    Hi Gregm,

    I had added the info in my /etc/network/interfaces file which is shown here(see attached) so this does not seem to be a problem

    route table.jpg

  6. #6
    Linux Engineer
    Join Date
    Dec 2013
    Posts
    1,078
    I take it you can get to your router?

    Do you have a nameserver configured? What do you see if you type:
    Code:
    dig security.ubuntu.com

  7. #7
    Just Joined!
    Join Date
    Feb 2012
    Posts
    10
    Yes I can get to my router and have setup port forwarding for the local ip address

    I tried the dig security.ubuntu.com and get the message:
    connection timed out; no servers can be reached

    I tried to setup nameserver in the resolv.conf file but the nameserver gets wiped from this file on a reboot
    resolv.jpg

  8. #8
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,454
    Then the problem is probably with your DNS settings. Post the contents of /etc/resolv.conf here. If it is pointing to your router, then your router may have a DNS problem. I frequently have the same issue, or at least really slow DNS address resolution, so I point my network configuration to use either my ISP or another top-level DNS server. Works great - stuff that would break or take minutes to resolve now are pretty much instantaneous.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  9. #9
    Linux Engineer
    Join Date
    Dec 2013
    Posts
    1,078
    Add a line to /etc/network/interfaces that sets it: dns-nameservers xxx.xxx.xxx.xxx

  10. #10
    Just Joined!
    Join Date
    Feb 2012
    Posts
    10
    Hey gregm and rubberman it works!!

    I added the dns-nameservers xxx.xxx.xxx.xxx as suggested. I had my server ip address and not my providers ip.

    Thanks Guys for all your help much appreciated
    Last edited by peterp53; 04-16-2014 at 11:18 PM. Reason: Update

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •