Find the answer to your Linux question:
Results 1 to 2 of 2
the ufw firewall in kubuntu 14 keeps disabling at reboot. followed instructions found on the web and still keeps disabling. first enabled ufw using sudo ufw enable assumed this would ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2014
    Posts
    2

    Help, firewall disables at reboot.


    the ufw firewall in kubuntu 14 keeps disabling at reboot.
    followed instructions found on the web and still keeps disabling.
    first enabled ufw using

    sudo ufw enable
    assumed this would be the only instruction needed to keep it turned on as most instructables mention it as one of the first steps when installing linux.
    they dont mention it turns off at reboot, and now concerned that i need to reinstall kubuntu due to not being protected.
    after hours of searching found that this code could help to get it to turn on at start up.

    sudo nano /etc/ufw/ufw.conf
    the result is as below.
    # /etc/ufw/ufw.conf
    #

    # Set to yes to start on boot. If setting this remotely, be sure to add a rule
    # to allow your remote connection before starting ufw. Eg: 'ufw allow 22/tcp'
    ENABLED=yes

    # Please use the 'ufw' command to set the loglevel. Eg: 'ufw logging medium'.
    # See 'man ufw' for details.
    LOGLEVEL=low
    now confused as it comes up as "ENABLED=yes" anyway and did not have to change the setting.

    also unsure if i needed to enter script to exit the terminal window properly,
    the commands are as below.
    ^G Get Help ^O WriteOut ^R Read File ^Y Prev Page ^K Cut Text ^C Cur Pos
    ^X Exit ^J Justify ^W Where Is ^V Next Page ^U UnCut Text ^T To Spell
    tried to exit using "^X Exit" without any luck and just closed it using the close window button.
    havent a clue what these are as they dont do anything.

    also tried Gufw which keeps turning off at reboot.

    Note: just a newby at using linux, can't understand why the firewall is turned off as default, and once turned on, turns off at reboot.
    why isn't it set to always be on as default when installed ?

  2. #2
    Penguin of trust elija's Avatar
    Join Date
    Jul 2004
    Location
    Either at home or at work or down the pub
    Posts
    3,565
    When you reboot, what does
    Code:
    sudo ufw status
    show?
    What do we want?
    Time machines!

    When do we want 'em?
    Doesn't really matter does it!?


    The Fifth Continent

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •