Find the answer to your Linux question:
Results 1 to 8 of 8
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    /mnt permission denied


    Screen Shot 2017-01-10 at 9.54.12 pm.pngHi all,
    I'm very new to Ubuntu, hence kindly pardon my foolishness.
    I have a hard disk of a FOSTEX D2424 that I needed to extract the audio files out from, which I've googled that I've to use Linux and a fdmsfs driver.

    So I've actually successfully managed to extract the files to a folder called /mnt
    However, when I tried to access the folder, it says that I do not have the permissions necessary to view contents of the folder.
    I tried using the command in terminal to change permissions but it returned saying function not implemented (as attached)
    I was wondering if there are any command lines that I have to type in before I mount it to /mnt.

    I'm operating on a MAC using parallel to run Ubuntu.
    Appreciate any help given!
    Attached Images Attached Images

  2. #2
    Linux Guru Segfault's Avatar
    Join Date
    Jun 2008
    Location
    Acadiana
    Posts
    1,573
    What is the meaning of "extract the files"? Did you actually mount the drive in /mnt/source? If yes, what command did you use?

  3. #3
    Screen Shot 2017-01-11 at 9.37.28 am.jpgScreen Shot 2017-01-11 at 9.38.06 am.jpgScreen Shot 2017-01-11 at 9.38.27 am.jpg

    I got audio files inside the hard disk which I would like to copy out. When I actually mount in /mnt/source, it says I do not have the permissions necessary to access the folder. I have attached screenshots. The command I use is sudo ./fdmsfs --bits24 fostex-image.dd /mnt/source

    Hope it helps.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru Segfault's Avatar
    Join Date
    Jun 2008
    Location
    Acadiana
    Posts
    1,573
    My guess is the FDMS filesystem does not support permissions, thus your command to change permissions/ownership is failing. Since you mounted it as root only root can access them. You could mount the drive as user, but for this it needs to be in fstab with user or users mount option. The workaround is to access these files as root and copy them to your local hard drive, then change the ownership of these files so your user can work with them.

  6. #5
    How do I mount it as user? Or how do I access as root? Am I not already accessing as root? Sorry, really new to this

  7. #6
    ^ your first screenshot shows that the files are there.
    from there, continue thusly:
    open a terminal (as normal user), enter:
    Code:
    cd
    mkdir copied_audio
    sudo cp -r /mnt/source/* ~/copied_audio/
    sudo chown -R weizheng ~/copied_audio/
    if that doesn't help please post the output of these commands.
    How to ask smart questions | Don't be a Help Vampire
    You can post a link by removing "http://www." from it!

  8. #7
    That works! I managed to see the files now. Thanks so much!!!

  9. #8
    Quote Originally Posted by weizheng View Post
    That works! I managed to see the files now. Thanks so much!!!
    cool.
    i just typed it off the top of my head - sometimes the first shot is a bulls eye.
    How to ask smart questions | Don't be a Help Vampire
    You can post a link by removing "http://www." from it!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •