Find the answer to your Linux question:
Results 1 to 8 of 8
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Please help a noob install his tplink wn722N driver

    Hi everyone

    i am new to linux and have the past 3 years downloaded 3 versions of ubuntu but always revert back to windows because i cannot get drivers installed, i am now asking for help for the first time to see if someone could perhaps assist ?

    i am trying to install a tplink-wn722n adapter however

    i bought another adapter which is the tp-link WN823N thinking it might be easier to install, but turned out from my little research that it is in fact harder to install than the WN722N adapter so i think i should stick trying to install the WN722N then ? i want to use the adapter which is easiest to install.

    I am so tired of windows and would really like to go linux, dropping the windows shackles and sending it's bloatware to oblivion now permanently if only i can get my wireless adapter installed.

    I installed ubuntu-17.04-desktop-amd64 on a clean disk

    I searched for a guide to install my adapter and found 3 different ones but none relating to the 17.04 version of ubuntu, this is the one i'm trying to follow:

    (askubuntu url i am not allowed to post the url as i have not made 15 posts yet)

    Please can anyone help with a step by step guide on instalation of my wireless adapter which is a tp-link WN722N

    The first thing i encounter is that the guide asks me to update the compiler/installer ? by typing in:

    sudo apt-get update

    However as this is the wireless device i need to use to connect to the internet, i cannot connect to the internet as it needs to be installed first. Is there another way i can get the update perhaps via a windows system connected to internet or another way of installing the device ?

    Without doing anything but trying to detect the adapter in the terminal running a command i forgot.

    Ubuntu detected the adapter and the different wireless networks shows up in the right top corner of ubuntu but it does not want to connect to the internet when i select a wireless network and type in the correct password.

    My second question, the guide at some stage asks to install certain files into a directory and change config settings to make sure ubuntu is configured to work with the adapter, so how do i go to a directory in ubuntu, in windows you just click on your drive and the directories appear.
    sorry for the noobness but i really want to kick windows out of the window and just need my adapter installed, so close yet so far !

    i am using ubuntu-17.04-desktop-amd64

  2. #2
    Linux Guru Segfault's Avatar
    Join Date
    Jun 2008
    First, is it a USB device? Presuming it is, run lsusb from command line and let us know the ID of device. It is something like 123a:b456.
    I believe it may have Atheros chipset and actually is supported by Linux kernel already. That is, no need to install driver. However, it may require firmware and it has to be installed by user.
    There will be an error in dmesg if this is the case.
    dmesg | grep -i firmware
    This will tell you what firmware is required. Then you can use a USB stick to transfer it into your laptop. There is no firmware installation needed, just copy the required binary into /lib/firmware/. Sometimes a subdirectory is required, dmesg will tell.

  3. #3
    Just Joined!
    Join Date
    Oct 2017
    It's up to the person compiling the kernel whether to compile the driver into the kernel itself, make a module out of the driver or not include the driver at all. In fact, many distros (like Ubuntu) have an optional "extra modules" kernel package with seldom used drivers just to keep the size down.

    Please keep the fake news to a minimum, thank you.

  4. $spacer_open
  5. #4
    Thanks Segfault
    I have done as you said an got the following as attached:

    How should i proceed ?

    In case the image does not show here alternative link below, just replace below with https:// (sorry board does not let me post links as i have not made 15 posts yet)

    h tee tee p s
    Attached Images Attached Images
    Last edited by james178; 11-12-2017 at 06:10 AM.

  6. #5
    Looking at the picture, am i right by saying i need to download this firmware from github:


    And from your message i need to copy it onto the /lib/firmware/

    directory ?

    Would the subdirectory be:

    ath9k_htc/htc_9271-1.4.0.fw or just



    /lib/firmware/ath9k_htc/ (copy firmware here ?)


    /lib/firmware/ (copy frimware here ?)


    and after doing that should the device work or is there other steps i need to take ?
    Last edited by james178; 11-12-2017 at 06:45 AM.

  7. #6
    ok i wanted to copy the firmware into the libre/firmware/ath9k_htc folder but it already existed and i confirmed by going into that directory and it was there..

    i still cannot connect, what happens is it shows the connecting stripes right top when connecting to a network and then disconnects after 20 seconds or so, during the time it says it is connected but i still cannot browse the internet in that 20 seconds that it says connected, the usb device has a light that constantly flashes in windows when it is on idle, it just stays on permanently at the moment in ubuntu

  8. #7
    anyone ? or will the WN823N adapter be better to try ?

  9. #8
    Linux Engineer drl's Avatar
    Join Date
    Apr 2006
    Saint Paul, MN, USA / CentOS, Debian, Slackware, {Free, Open, Net}BSD, Solaris

    This thread caught my attention because I have a TP-LINK TL-WN822N. I purchased it for a relative, but it turned it was not needed, so I never tried to install it.

    I ran across one possible solution.

    Searching for will ubuntu-17.04-desktop-amd64 support tplink wn722N produced 15 hits.

    Among those hits is the interesting which seems to say that only 2 lines need to be added to file:
    and then restart networking.

    Perhaps that will work for you.

    Good luck ... cheers, drl
    Welcome - get the most out of the forum by reading forum basics and guidelines: click here.
    90% of questions can be answered by using man pages, Quick Search, Advanced Search, Google search, Wikipedia.
    We look forward to helping you with the challenge of the other 10%.
    ( Mn, 2.6.n, AMD-64 3000+, ASUS A8V Deluxe, 1 GB, SATA + IDE, Matrox G400 AGP )

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts