Find the answer to your Linux question:
Results 1 to 6 of 6
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Angry Overall Ubuntu laggy performance: video playback, scrolling etc.


    So i have a freshly installed Linux Mint Cinnamon 18.3 on AMD X4 860K and AMD R7 250X pc with a 60Hz monitor.

    Here's my lshw output
    pastebin.com/cN2mFFE3

    and inxi -Fxz

    System: Host: kobato-chan Kernel: 4.13.0-36-generic x86_64 (64 bit gcc: 5.4.0)
    Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3) Distro: Linux Mint 18.3 Sylvia
    Machine: System: Gigabyte product: N/A
    Mobo: Gigabyte model: F2A55M-HD2 Bios: American Megatrends v: FGa date: 05/06/2015
    CPU: Quad core AMD Athlon X4 860K (-MCP-) cache: 8192 KB
    flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 29543
    clock speeds: max: 3700 MHz 1: 1700 MHz 2: 1700 MHz 3: 1700 MHz 4: 3000 MHz
    Graphics: Card: Advanced Micro Devices [AMD/ATI] Cape Verde XT [Radeon HD 7770/8760 / R7 250X] bus-ID: 01:00.0
    Display Server: X.Org 1.18.4 drivers: ati,radeon (unloaded: fbdev,vesa) Resolution: 1920x1080@60.00hz
    GLX Renderer: AMD CAPE VERDE (DRM 2.50.0 / 4.13.0-36-generic, LLVM 6.0.0)
    GLX Version: 3.1 Mesa 18.1.0-devel Direct Rendering: Yes
    Audio: Card-1 Advanced Micro Devices [AMD] FCH Azalia Controller driver: snd_hda_intel bus-ID: 00:14.2
    Card-2 Advanced Micro Devices [AMD/ATI] Cape Verde/Pitcairn HDMI Audio [Radeon HD 7700/7800 Series]
    driver: snd_hda_intel bus-ID: 01:00.1
    Sound: Advanced Linux Sound Architecture v: k4.13.0-36-generic
    Network: Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
    driver: r8169 v: 2.3LK-NAPI port: d000 bus-ID: 02:00.0
    IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter>
    Drives: HDD Total Size: 3000.6GB (20.2% used) ID-1: /dev/sda model: ST2000DM001 size: 2000.4GB
    ID-2: USB /dev/sdb model: M3_Portable size: 1000.2GB
    Partition: ID-1: / size: 96G used: 7.2G (8%) fs: ext4 dev: /dev/sda5
    ID-2: /home size: 1.3T used: 174G (15%) fs: ext4 dev: /dev/sda2
    ID-3: swap-1 size: 8.91GB used: 0.00GB (0%) fs: swap dev: /dev/sda3
    RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
    Sensors: System Temperatures: cpu: 20.6C mobo: N/A gpu: 38.0
    Fan Speeds (in rpm): cpu: N/A
    Info: Processes: 192 Uptime: 2:09 Memory: 1961.6/7933.4MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
    Client: Shell (bash 4.3.481) inxi: 2.2.35

    The problem i'm experiencing is quite global (i've tried Kubuntu 17.10,18.04 and Ubuntu 16.04,17.10). When something is moving on my screen (i.e. video, scrolling in firefox) everything seems choppy or laggy, with no tearing tho. I just get these micro-lags, framedrops or whatever, i don't know how to call them exactly. They affect only visuals, audio is stable. I have turned on "disable composition for fullscreen windows" option so in fullscreen mode everything is fine and dandy. When i press F11 in Firefox, non-fullscreen videos on youtube play smoothly, and scrolling is smooth too. Same thing happens in all media players like vlc or mpv, while theyre windowed they lag, when they're fullscreen, they don't. Most frustrating part is using a browser with this type of lags. I'm using Firefox with F11 and browser.fullscreen.autohide=false as a temporary workaround, but it's not a solution, it's like treating diarrhea with a cork. I've tried so many things, none of them seems to work. I like linux and i'd like to solve this problem, because it's a major deal-breaker. Any suggestions/ideas?
    Last edited by f7d1ed; 03-07-2018 at 12:46 PM.

  2. #2
    Linux Newbie sarlacii's Avatar
    Join Date
    May 2005
    Location
    South Africa
    Posts
    223
    Hi there

    Have you tried, as a possible first step, to run XFCE or LXDE or similar to use a different window manager? Do you still have the issue... . Also, check that 3D Compiz effects are disabled for the desktop (Ubuntu uses compizconfig settings manager I think), others like PClinuxOS include this as a menu in the desktop settings.

    Also, check that you have the proper drivers loaded for your Radeon card? Again, in Ubuntu it's under system settings, software and updates, additional drivers. There are opensource drivers, and then the closed source stuff from AMD. Can also google and check via command line, lots of stuff online.

    Go well.

  3. #3
    I tried every possible DE and WM. The only ones that work properly are marco(compton gpu compositor) and compiz, all others(xfwm4, kwin, mutter, muffin etc.) aren't working. Since old proprietary drivers(fglrx) arent't supporeted on latest ubuntu distros, i tried radeon and amdgpu, both of them work pretty much the same with the exception that amdgpu gives 10-20 more fps in cs:go on my old but faithful R7 250X.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru Segfault's Avatar
    Join Date
    Jun 2008
    Location
    Acadiana
    Posts
    2,185
    https://wiki.gentoo.org/wiki/AMDGPU

    Is the firmware loaded? Is the kernel new enough for this chipset?

  6. #5
    Quote Originally Posted by Segfault View Post
    Is the firmware loaded? Is the kernel new enough for this chipset?
    Yes and yes, i tried a bunch of kernels from 4.4 to 4.15. I don't think the problem here lies in drivers, kernels or hardware but rather in how de's and wm's interact with them, because everything works perfecly fine on some wm's like marco(compton) and compiz. I dont understand, what's wrong with kwin, cinnamon, mutter and muffin. I like cinnamon very much and i dont want to use mate or xfce instead.

  7. #6
    Linux Guru Segfault's Avatar
    Join Date
    Jun 2008
    Location
    Acadiana
    Posts
    2,185
    -->
    There are three components. Kernel driver, Xorg driver and MESA. You can see the information using glxinfo. Generally, if it tells you direct rendering is enabled things should be smooth. In any case, inspecting Xorg log may give some clues.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •