Find the answer to your Linux question:
Results 1 to 6 of 6
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    [Question] CentOS issue faced when upgrading Apache 2.2 to 2.4.29


    Understand from research that this two versions has slight changes, and they introduces something new call : Mod_Auth_Basic to the newer version.

    When I try to call the "MAKE" command, then I prompted with this error:

    Leaving directory '/usr/src/httpd-2.4.29/support'

    Does any of you faced this issue when performing the upgrade?

  2. #2
    Linux Guru
    Join Date
    Dec 2013
    Posts
    2,747
    upgrading something is not the same as compiling it. using make suggests the latter, but i think you really want the former.

    centos likely has a suitable version of apache in the repos; a simple update & upgrade (not sure what the exact commands are on centos; yum something?) should be sufficient.

    there's no reason to compile apache from source.

  3. #3
    Quote Originally Posted by nihili View Post
    upgrading something is not the same as compiling it. using make suggests the latter, but i think you really want the former.

    centos likely has a suitable version of apache in the repos; a simple update & upgrade (not sure what the exact commands are on centos; yum something?) should be sufficient.

    there's no reason to compile apache from source.
    Hi, thanks for your reply. But I am upgrading from version 2.2 to 2.4. And I guess there are some major changes or features added. Have you tried upgrading it to 2.4? Care to share your experience or which guide did you follow through. Thanks

  4. $spacer_open
    $spacer_close
  5. #4
    Hi, today i encounter this error, can anyone suggest a solution? Thanks

    #rpmbuild -tb apr-util-1.5.4.tar.bz2
    error: Failed build dependencies:
    apr-devel >= 1.4.0 is needed by apr-util-1.5.4-1.x86_64

  6. #5
    Trusted Penguin Irithori's Avatar
    Join Date
    May 2009
    Location
    Munich
    Posts
    4,031
    1) Upgrade to centos7. Centos7 has apache 2.4
    2) Learn about library and tool dependencies, then package your own rpms. Start here https://access.redhat.com/documentat...ng_guide/index
    You must always face the curtain with a bow.

  7. #6
    Linux Guru
    Join Date
    Dec 2013
    Posts
    2,747
    Quote Originally Posted by skyluke View Post
    I am upgrading from version 2.2 to 2.4.
    i get that.
    but why?

    I guess there are some major changes or features added.
    ...because you guess?
    so really you have no reason to upgrade.


    Have you tried upgrading it to 2.4?
    no, i like to stick to the version supported by my distro.


    you really need to understand how package management and dependencies work on linux. it's a feature.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •