Find the answer to your Linux question:
Results 1 to 4 of 4
I am writing this through a live Ubuntu CD as my hard-disk installation of 6 months is seriously screwed. Ubuntu boots normally until the Gnome Desktop manager login window appears. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2006
    Posts
    16

    Ubuntu Breezy WEIRD!! boot problem


    I am writing this through a live Ubuntu CD as my hard-disk installation of 6 months is seriously screwed.

    Ubuntu boots normally until the Gnome Desktop manager login window appears. Then when I try to enter my username - everytime I press a key the screen balnks and changes to a different screen resolution (I get a different sized login window) - my keypress was ignored and further keypresses just do this same behaviour.

    The only thing I can notice is that my cursor icons are different than before (weird little icons),

    Can I get access to a terminal without booting to a GUI (I know I should have made the option not to boot straight into X thru gnome!!!)

    I have data I really need to get from the hard disk quickly (University stuff and photos) - and the live CD wont access the hard disk filesystem!!! Can anyone shed some light on this pleeeeeeeze!!!!!

  2. #2
    Just Joined!
    Join Date
    Apr 2006
    Location
    Canada, Earth
    Posts
    16
    I would guess that you have a bad configuration for your keyboard. Maybe the wrong region or language setting. You could look that up. Here is what you should try to fix it.

    Step 1: Get to a command prompt. From the GUI login (GDM Gnome Display Manager) try pressing Ctrl+Alt+F2 all three keys at the same, start with the Ctrl+Alt and hold them down as you press the F2 key. In a working system this will drop you to a terminal session running on tty2. If that works and you know the root password go to the next step. If it did not work then a bit of a pickle. Normaly you would reboot and edit your GRUB boot option to put you in a different run level like 1 or 2 or 3 so that you don't have a GDM session the problem is Ubuntu will only let you enter these modes if you know the root password and the default Ubuntu install has the root password dissabled. If that is the case you need to boot with live CD, mount the / file system of your computer, chroot to that system and run passwd to set the root password. Ubuntu is broken by default in this way because you will need to know the root password to be able to fix any thing.

    Step 2: Once you are at the command prompt you can run startx to start your X desktop without going throught the login. If your keyboard is still goofy then press Ctrl+Alt+Backspace to get back to you command prompt.

    Step 3: From the command prompt su to root then you can use vi to edit your /etc/X11/XF86Config-4 file. I may have some goofy option set in the keyboard section.

    If none of that work, boot with a live CD and use scp to copy your files to another Linux system and then reinstall any OS that is not Unbuntu.

    Example to use scp to copy your files off. If your login name is joe on a Linux system at 192.168.10.5 and your Ubuntu system has your home partition on hda5
    mkdir /mnt/hda5
    mount /dev/hda5 /mnt/hda6
    cd /mnt/hda5/joe
    scp -r MyDocuments joe@192.168.10.5:~/

  3. #3
    Just Joined!
    Join Date
    Jan 2006
    Posts
    16

    Further Developments

    Hi GoP - thanks for the reply

    After my initial meltdownI found I could make Ubuntu boot into a kernel recovery mode. As I had previously set up a root account (thank god!) I edited the gdm.conf file to auto-login. This got me my gnome X Session back but the keyboard didn't work anywhere at all!! (Except the keypad with numlock on!) - only the mouse
    I noticed that synaptic was showing 66 updates available.
    I rebooted into the recovery mode and used apt-get to install them (well almost finished downloading now 45MB) the updates are all xserver ..... packages so I hope they may fix the keyboard issue.

    If not I will follow your advice about checking XF86Config-4 file and if no success well I guess a re-install is in order after backing up my data onto DVD. I suppose upgrading to dapper would be handy if I do a re-install

    God - i have to fix this before my Windoze friends hear about this - you know .... i thought Linux was bullet-proof!!!! yadayadda

  4. #4
    Just Joined!
    Join Date
    Apr 2006
    Location
    Canada, Earth
    Posts
    16
    Linux is bullet proof. Ubuntu is highly experimental and that makes you a test subject. If you want stable and reliable you need to install Debian stable. Ubuntu comes from an unstable fork of Debian. Stable Debian will not have all the fancy toys or eye candy but you can trust it. If you want toys and eye candy and are willing to be a test subject then Ubuntu is just that.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •