Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
As the title states, my Ubuntu Live CD won't start the X server. I get the following message: (EE) No devices detected Fatal server error: no screens found If I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2006
    Posts
    8

    Ubuntu Live CD can't start X server with my 7900GT. Any solutions?


    As the title states, my Ubuntu Live CD won't start the X server. I get the following message:

    (EE) No devices detected

    Fatal server error:
    no screens found

    If I look in the detailed log file, I find the section where all the video cards are listed. The list stops at the 6800 series. I assume this means that the live CD doesn't include the necessary drivers for the 7900GT? What are my options at this point for running the Live CD? When I get this error, it doesn't take me to a command line or anything--I must press Ctrl+Alt+Del to reboot.

  2. #2
    Just Joined!
    Join Date
    Apr 2006
    Location
    Europe
    Posts
    46
    It seems to me that 7900GT has been released not long ago and maybe it is not supported by the Live CD you have. How about the normal Ubuntu distro? Is it just the same, or does it at least offer options to choose another card?

  3. #3
    Just Joined!
    Join Date
    May 2006
    Posts
    8
    Hi, I was actually able to get X working by doing a "live-expert" install and manually selecting the VESA driver.

    But now I have installed Ubuntu to my hard drive and I can't get the nVidia driver working! I thought Ubuntu was supposed to be a user-friendly distro? Instead, I have had to search through dozens of forums trying to get the information I need. It involves installing the proper compiler version, doing something with the kernal headers (?), etc. I finally got to the point where the nVidia executable file would run and compile, but X still wouldn't start!!! So now I find myself back in the same situation I had with the LiveCD: getting X to start.

  4. #4
    Just Joined!
    Join Date
    Apr 2006
    Location
    Europe
    Posts
    46
    If you managed to install the driver and it is not working (I presume that you get the same message about no screens found) then try to see if the driver of another nVidia card will not work. For now, you might have to use the 7900GT card as a simple nVidia one but if Ubuntu (or any operating system) is working with it, this could be a temporary tradeoff.

    I can't say for sure but I believe that if the 7900GT is a popular card, it will soon be supported. When was your distro released? Last year? A couple of months ago? I mean, if it has been released some time ago, before 7900GT hit the market, it is impossible to have support for that particular card included in the distro.

  5. #5
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Quote Originally Posted by KillrBuckeye
    But now I have installed Ubuntu to my hard drive and I can't get the nVidia driver working! I thought Ubuntu was supposed to be a user-friendly distro? Instead, I have had to search through dozens of forums trying to get the information I need. It involves installing the proper compiler version, doing something with the kernal headers (?), etc. I finally got to the point where the nVidia executable file would run and compile, but X still wouldn't start!!! So now I find myself back in the same situation I had with the LiveCD: getting X to start.
    Installing NVIDIA drivers in Ubuntu is quite easy, no need to bother with any compiling or anything. You need:
    -your kernel "restricted modules" installed
    -the package "nvidia-glx"

    Something like that would do:
    Code:
    sudo apt-get install nvidia-glx nvidia-settings linux-restricted-modules-`uname -r`
    And then change /etc/X11/xorg.conf to take the new driver into account. Comment those:
    Code:
    #Load "dri"
    #Load “GLcore”
    and uncomment or add this one:
    Code:
    Load “glx"
    And change the driver to "nvidia"
    Code:
    Driver "nvidia"

    This would be the standard way to install it.

    As for the NVIDIA 7900GT, if I'm not mistaking, only the latest driver will work (1.0-8756):
    Adds support for GeForce 7300, GeForce 7400 Go, GeForce 7600 and GeForce 7900 GPUs.
    from
    http://www.nvidia.com/object/linux_d..._1.0-8756.html

    So if Ubuntu "nvidia-glx" package doesn't include the latest drivers, you'll need to follow techieMoe's guide:
    http://www.linuxforums.org/forum/lin...d-drivers.html
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  6. #6
    Just Joined!
    Join Date
    May 2006
    Posts
    8
    Thanks for the replies. I have discovered that I can install the nVidia driver (using the executable nVidia install file) and then start X successfully. However, once I reboot, X fails to start and I have to reinstall the driver. Here is the log file from a failed attempt to start X after I reboot:

    http://pastebin.com/710577

    Any help would be appreciated.

  7. #7
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    You're using Ubuntu Breezy?

    The nvidia-glx package in Breezy is made from NVIDIA driver version 1.0.7667.

    The problem is that your NVIDIA 7900GT only works with the latest NVIDIA driver (1.0-8756).

    You need to uninstall the nvidia-glx packages
    Code:
    sudo apt-get remove --purge nvidia-glx nvidia-settings
    Then download the latest driver from NVIDIA website:
    http://www.nvidia.com/object/unix.html

    Follow techieMoe tutorial to install it:
    http://www.linuxforums.org/forum/lin...d-drivers.html
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  8. #8
    Just Joined!
    Join Date
    May 2006
    Posts
    8
    Quote Originally Posted by antidrugue
    You're using Ubuntu Breezy?

    The nvidia-glx package in Breezy is made from NVIDIA driver version 1.0.7667.

    The problem is that your NVIDIA 7900GT only works with the latest NVIDIA driver (1.0-8756).

    You need to uninstall the nvidia-glx packages
    Code:
    sudo apt-get remove --purge nvidia-glx nvidia-settings
    Then download the latest driver from NVIDIA website:
    http://www.nvidia.com/object/unix.html

    Follow techieMoe tutorial to install it:
    http://www.linuxforums.org/forum/lin...d-drivers.html
    I am using the 8756 drivers. I'm pretty sure I tried removing the nvidia-glx packages the first time I installed, but I will do this again. Thanks.

  9. #9
    Just Joined!
    Join Date
    May 2006
    Posts
    8
    Still no luck. I have tried following multiple guides to installing the driver, and nothing solves the reboot problem. Like I said, the driver installs fine and I can restart GDM and everything appears fine. However, once I reboot, X cannot start because it "Failed to initialize the NVIDIA kernel module!". The thing is: lsmod shows that the nVidia module is running... My friends on IRC who are good with Linux have run out of ideas for me. They now suggest trying a different distro... Any other suggestions?

  10. #10
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •