Find the answer to your Linux question:
Results 1 to 5 of 5
hi all, i am doing my first ever linux install anyway i've just installed kubuntu 5.10 heres my setup 200 gb primary master with windows xp on primary 30gb NTFS ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2006
    Posts
    4

    cant seem to get winxp (ntfs) to boot from grub


    hi all,
    i am doing my first ever linux install
    anyway i've just installed kubuntu 5.10 heres my setup
    200 gb primary master with windows xp on primary 30gb NTFS partition
    rest of hdd is other ntfs drives
    40 gb primary slave for kubuntu the partitions are
    512mb /boot ext3 (primary) hd1,0
    10 gb / ext3 (primary) hd1,1
    2gb swap swap (logical) hd1,5
    5 gb /var ext3 (logical) hd1,6
    10 gb /home ext3 (logical) hd1,7
    10 gb /usr ext3 (logical) hd1,8

    i did it this way so that if i stuff my linux install i can just unplug the slave hdd and winxp will just boot from its own boot sector

    i've set the bios to boot from slave hdd and installed grub to hd1,0

    install went smoothly

    so anyway to get linux to boot i had to change grubs config file first line (for linux boot) from
    root (hd1,0) to root (hd0,0) not sure why coz my linux is on (hd1,0)
    that will let me boot my linux installation.

    my next step was to get the xp install to boot
    so being a clever little dickie i changed the xp (under "Lesser operating Systems") config to
    rootnoverify (hd1,0) i searched and someone said to use noverify (removed error about partition type)
    makeactive found through search
    chainloader +1 was already there

    now i just get garbage (hierogliphics) although i can remove the linux drive (temporarily) and windows will boot just fine

    sorry about the essay, i just wanted to make sure you had all info u need to help me please!!!
    thanks
    Greg

  2. #2
    Linux User towy71's Avatar
    Join Date
    May 2006
    Location
    West Wales
    Posts
    322
    Can you give us the contents of two files /etc/fstab and /boot/grub/menu.list the former will tell us your disk layout and the latter will tell us what you've done wrong

    I would imagine your /boot/grub/menu.list should look something like:
    Code:
    ## ## End Default Options ##
    
    title		Ubuntu, kernel 2.6.12-10-386 
    root		(hd1,0)
    kernel		/boot/vmlinuz-2.6.12-10-386 root=/dev/hda2 ro quiet splash
    initrd		/boot/initrd.img-2.6.12-10-386
    savedefault
    boot
    
    title		Ubuntu, kernel 2.6.12-10-386 (recovery mode)
    root		(hd1,0)
    kernel		/boot/vmlinuz-2.6.12-10-386 root=/dev/hda2 ro single
    initrd		/boot/initrd.img-2.6.12-10-386
    boot
    
    
    # This entry automatically added by the Debian installer for a non-linux OS
    # on /dev/hda1
    title		Windows XP
    root		(hd0,0)
    savedefault
    makeactive
    chainloader	+1
    What you have points to the wrong partition
    free/libre/open software for the people by the people
    Linux user #185360

  3. #3
    Just Joined!
    Join Date
    May 2006
    Posts
    4

    Here is my fstab

    # /etc/fstab: static file system information.
    #
    # <file system> <mount point> <type> <options> <dump> <pass>
    proc /proc proc defaults 0 0
    /dev/hdb2 / ext3 defaults,errors=remount-ro 0 1
    /dev/hdb1 /boot ext3 defaults 0 2
    /dev/hdb7 /home ext3 defaults 0 2
    /dev/hda1 /media/hda1 ntfs defaults 0 0
    /dev/hda5 /media/hda5 ntfs defaults 0 0
    /dev/hda6 /media/hda6 ntfs defaults 0 0
    /dev/hda7 /media/hda7 vfat defaults 0 0
    /dev/hda8 /media/hda8 ntfs defaults 0 0
    /dev/hdb8 /usr ext3 defaults 0 2
    /dev/hdb6 /var ext3 defaults 0 2
    /dev/hdb5 none swap sw 0 0
    /dev/hdd /media/cdrom0 udf,iso9660 user,noauto 0 0

  4. #4
    Just Joined!
    Join Date
    May 2006
    Posts
    4

    here is menu.lst

    title Ubuntu, kernel 2.6.12-9-386
    root (hd0,0)
    kernel /vmlinuz-2.6.12-9-386 root=/dev/hdb2 ro quiet splash
    initrd /initrd.img-2.6.12-9-386
    savedefault
    boot

    title Ubuntu, kernel 2.6.12-9-386 (recovery mode)
    root (hd0,0)
    kernel /vmlinuz-2.6.12-9-386 root=/dev/hdb2 ro single
    initrd /initrd.img-2.6.12-9-386
    boot

    title Ubuntu, memtest86+
    root (hd0,0)
    kernel /memtest86+.bin
    boot

    ### END DEBIAN AUTOMAGIC KERNELS LIST

    # This is a divider, added to separate the menu items below from the Debian
    # ones.
    title Lesser operating systems:
    root


    # This entry automatically added by the Debian installer for a non-linux OS
    # on /dev/hda1
    title Microsoft Windows XP Professional
    root (hd1,0)
    makeactive
    #savedefault
    chainloader +1

  5. #5
    Just Joined!
    Join Date
    May 2006
    Posts
    4

    grub must be a bit confused

    i know it seems odd but if i point grubs linux to the right partition ie (hd1,0) i get unknown filesystem and if i point it to the wrong partition ie (hd0,0) it boots just fine
    also i gotta point xp to the wrong partition ie (hd1,0) or i just get file system ext3 and i return to grub boot menu
    so I'm still getting heiroglifics when grub tries to boot winxp
    anyway i think i might have to get ntfs support for grub and linux can anyone help me
    cheers
    greg

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •