Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 16 of 16
^ok. thanks for that link, it's excellent, later i'll study it. the backup was created, no problem, but no editing, mine is kubuntu so i should use kwrite, as cited ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    May 2006
    Posts
    8

    ^ok. thanks for that link, it's excellent, later i'll study it. the backup was created, no problem, but no editing, mine is kubuntu so i should use kwrite, as cited somewhere there, but i can't:

    root@reg-desktop:/home/reg# sudo kwrite /etc/apt/sources.list
    Xlib: connection to ":0.0" refused by server
    Xlib: No protocol specified
    tried opening it from konqueror, it works but if i try to save, i receive this:

    The document could not be saved, as it was not possible to write to file:///etc/apt/sources.list.
    Check that you have write access to this file or that enough disk space is available.
    i'm logged as root as you told me, at least it shows root@ in the terminal, the owner/group of that file is root but i can't write, even with permission = -rw.
    basically my problem now is more with permissions than installing. i can edit the sources file but can't save it. (??)

  2. #12
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Quote Originally Posted by ze mane
    root@reg-desktop:/home/reg# sudo kwrite /etc/apt/sources.list
    Xlib: connection to ":0.0" refused by server
    Xlib: No protocol specified
    Then try:
    Code:
    kdesu kwrite /etc/apt/sources.list
    Or else just use a non-graphical editor:
    Code:
    sudo nano /etc/apt/sources.list
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  3. #13
    Just Joined!
    Join Date
    May 2006
    Posts
    8
    things are getting more strange...
    the kdesu code gave me the same message as before, the nano worked, but when i use konqueror to see the file it shows the old date/text (still with comments) i move to konsole and open the file as you said and it's edited (removed comments). i'll try the rest.

  4. $spacer_open
    $spacer_close
  5. #14
    Just Joined!
    Join Date
    May 2006
    Posts
    8
    ok. update proceeded until the end after "apt-get install firefox", firefox is active.
    thanks. what links/e-books on linux can you recommend me ?

  6. #15
    Linux User towy71's Avatar
    Join Date
    May 2006
    Location
    West Wales
    Posts
    322
    Online there is the excellent rute users exposition and linux.org have some tutorials too
    free/libre/open software for the people by the people
    Linux user #185360

  7. #16
    Just Joined!
    Join Date
    May 2006
    Posts
    8
    ^great, exactly what i was looking for, thanks.
    now i'll get ubuntu instead of kubu to try gnome and then a lot of studying.
    thank you all.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •