Find the answer to your Linux question:
Results 1 to 4 of 4
I am running a 64 bit version of Ubuntu on my amd-64 machine (athlon) I have gij alrady installed through syanptic. I recently downloaded 64bitversion of jdk1.5 from the sun ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2003
    Posts
    70

    Java on 64 bit Ubuntu


    I am running a 64 bit version of Ubuntu on my amd-64 machine (athlon)
    I have gij alrady installed through syanptic. I recently downloaded 64bitversion of jdk1.5 from the sun site, and installed it. I set the path and classpath variables.
    Now, when i type java on the shell, it invoked gij and not the java from jdk1.5
    Can someone help me out, I do not want to uninstall gij, since, openoffice depends on it.
    Thank you!

  2. #2
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    When you say "gij" do you really mean gcj? To the best of my knowledge, the Sun JDK does not redirect your /bin/java or /usr/bin/java links when it installs, so although it probably did install correctly, if you want a program to use the Sun JVM you'll need to do one of two things:

    1. Change the link for your /bin/java or /usr/bin/java to point to the java executable provided by Sun (not recommended).

    2. Give a command-line option to the programs that need the Sun Java VM to show them where it is. I don't know specifically how to do this in OpenOffice, but I know it works on programs I use such as Eclipse.
    Registered Linux user #270181
    TechieMoe's Tech Rants

  3. #3
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    techimoe solution works, but the Debian/Ubuntu way of doing this would be through the "alternatives" configuration.

    Make a proper symlink for
    Code:
    /etc/alternatives/java
    and the likes.

    Anyway Sun Java's should set up the alternatives automatically if you installed it the "proper" way.

    See my post here:
    http://www.linuxforums.org/forum/lin...t-working.html
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  4. #4
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    Thanks, antidrugue. That's much more elegant.
    Registered Linux user #270181
    TechieMoe's Tech Rants

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •