Find the answer to your Linux question:
Results 1 to 6 of 6
This is my first time with linux since Mandrake 7 and I'm having lots of problems and just don't know what to do. I've tried many things and have searched ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2006
    Posts
    4

    Unhappy Newb with lots of probs


    This is my first time with linux since Mandrake 7 and I'm having lots of problems and just don't know what to do. I've tried many things and have searched quite a bit and have found no easy answers. I really just can't seem to get anything to work. Here's a list. First, I can't make any changes. I have no administrative rights, I can't even change the clock. It just returns "su returned with an error" I've tried going into konsole and adding my username as a sudoer. All I get is that my authentication has failed. The password I chose is just one letter so there's no way it could be wrong. On top of that I can't install my integrated wireless. It's in an Acer aspire 3000. Tried installing ndiswrapper according to what I've seen in this forum and other places and it returns saying that it is not a gzip format file. I have no idea what to do and I'm frustrated. I really want to make this work. I'm using kubuntu 5.10. Any help would be greatly appreciated.

  2. #2
    Just Joined! cookie12243's Avatar
    Join Date
    May 2006
    Posts
    16
    I fixed the SU problem with editing under root with
    Code:
    nano /etc/sudoers
    Then adding
    Code:
    cookie ALL=(ALL) ALL
    <Cookie is my defualt user>

    So mine now looks like this

    Code:
    # /etc/sudoers
    #
    # This file MUST be edited with the 'visudo' command as root.
    #
    # See the man page for details on how to write a sudoers file.
    #
    
    # Host alias specification
    
    # User alias specification
    
    # Cmnd alias specification
    
    # Defaults
    
    Defaults        !lecture,tty_tickets,!fqdn
    
    # User privilege specification
    cookie  ALL=(ALL) ALL

  3. #3
    Just Joined!
    Join Date
    Jun 2006
    Posts
    4

    Unhappy Tried it, still don't know

    I just got your message and tried it and got not a whole lot. Here's what came up. Nano came up in the shell and said at the bottom [Error reading /etc/sudoers: Permission denied] I may be doing something wrong. I opened up Konsole it reads
    kevin@kubuntu:~$
    I typed in directly after that
    nano /etc/sudoers
    Obviously my username is kevin. I'm sorry to say it buy I feel like a child right now...Just learning how to crawl. Thanks so much for the quick response.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jun 2006
    Posts
    4

    Question Light at the end of the tunnel but still gloomy

    No matter what I did I couldn't gain access to anything so last night I ended up downloading and installing kubuntu 6.06. After that I was able to do a lot more. However, I still have some problems. I gained root access with visudo and began to install ndis wrapper per the instructions here https://wiki.ubuntu.com/WifiDocs/Dri...iswrapperHowto everything seemed to go well there. Then I went to install the drivers for my wireless. I'm using an Acer aspire 3000 laptop and the wireless adapter is a broadcom b/g. For some reason it shows up as eth1 instead of wlan0 when I look at it. All the checks on the howto seem to work just fine. When I go to the wireless assistant the wireless connection is disabled. I switch to administrator mode and attempt to enable it and it enables it for about a second and then disables it again. I have no idea what to do now. I hope someone out there can help. I've spent hours just getting to the point I am now, and I can't wait to at least get my wireless connection to work so I don't have to use two computers.

  6. #5
    Just Joined!
    Join Date
    Jun 2006
    Posts
    1
    It's possible that the default kernel module (I have a SMC2835W adapter with Prism Intersil chipset which runs only with ndiswrapper) is already loaded by the system, parallely to ndiswrapper module, so that the system prefers its own module instead of ndiswrapper.
    This happened to me. Check /etc/modules and /etc/modules.conf and look for the aliases in /etc/modutils.
    I also had to delete (better: backup to home folder for the case of the cases...) the default kernel module, cause I didn't get the system to NOT automatically load the default module with the dapper default kernel.
    Have you already installed the Windows driver (*.inf file) using "ndiswrapper -i"?

  7. #6
    Just Joined!
    Join Date
    Jun 2006
    Posts
    4

    Question Still guessing

    I'm still working on some things that I've found on forums but haven't been able to get anything to work. Now I've installed the bcm43xx-firmware package and blacklisted ndiswrapper. I've found this thread and am experimenting with trying to get it to work: http://ubuntuforums.org/showpost.php...6&postcount=24
    Still a little iffy on some things doesn't seem like there are quite enough instructions in it so it's taking a little longer. Any more help will be appreciated.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •