Find the answer to your Linux question:
Results 1 to 5 of 5
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2006
    Location
    Puerto Rico
    Posts
    7

    error when attempting sudo


    Saludos,
    After reinstalling Kubuntu 5.1, I cannot use the sudo command:
    whenever I try it, the following message appears:
    "sudo: unable to lookup lester-kubuntu via setHostbyName()"
    (lester-kubuntu is my computers name)

    Two things:
    1) I booted the Kubuntu installation as "expert", so I was able to tweak. But I do not remember eliminating any options.
    2) When I restarted the machine after the installation, it continues the software setup. Well, at this moment it started giving the following error continually while installing:
    "[####.######] Incompatible medium installed -- (asc=0x30, ascq=0x00)
    The failed "Read Cd/Dvd Capacity" packet command was:"
    Later I found out I had a DVD inside my second DVD drive. I take it out and error stops showing.

    I will try to reinstall it again to see what happens.

  2. #2
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Can you log using
    Code:
    su
    ?

    What is the content of /etc/sudoers?
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  3. #3
    Just Joined!
    Join Date
    May 2006
    Location
    Puerto Rico
    Posts
    7
    Of what I understand, the ubuntu distros do not let you use us/root by default, only "sudo", but I will try. Also, I reinstalled the kubuntu twice yesterday, first in expert mode, then in basic mode. I was able to use sudo after basic mode installation, so I guess there is a bug in the expert mode or I am not configuring something correctly.
    I will see what /etc/sudoers holds.

    Also, do you know of any good Linux books? I'm a programmer with user level experience in Unix. Any food for my mind is welcome.

    Thank you.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Quote Originally Posted by lamcro
    Of what I understand, the ubuntu distros do not let you use us/root by default, only "sudo", but I will try.
    About that you can check out my last post here :
    http://www.linuxforums.org/forum/ubu...se-help-2.html

    If sudo works, then you can enable root by choosing a root password :
    Code:
    sudo passwd
    Then you can access root with
    Code:
    su
    If only root works and not sudo, then you can enable sudo by adding yourself to the sudoers :
    http://www.linuxforums.org/forum/deb...tu-5-10-a.html
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  6. #5
    Also, if you have Gnome running, you could go into the user accounts and change things that way. Much rather use sudo myself really though.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •