Find the answer to your Linux question:
Results 1 to 2 of 2
I recently came to posess a PowerMac G4 (used). I want to dual-boot OSX (Panther) and Kunbuntu (Dapper Drake) on it. Mac OSX was already installed, so using the Live ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2006
    Posts
    9

    OSX and Kunbuntu dual-boot help needed!


    I recently came to posess a PowerMac G4 (used). I want to dual-boot OSX (Panther) and Kunbuntu (Dapper Drake) on it. Mac OSX was already installed, so using the Live CD for Kunbuntu, I attempted to shrink the largest free partition in half (40 GB in half) so that I could install Kunbuntu.

    The Live CD told me that it could not partiton the volume because it was mounted. I unmounted it, but it still claimed to be mounted. I then went back into OSX and attepmted to use the pdisk utility in the Terminal to partiton the drive. This also would not give me access to the volume (which I suspect was because it was mounted, but from what I'd read it seemed that pdisk should have worked regaurdless).

    Since that failed, I reinstalled OSX completely, ran the disk utility, partitioned the volume, and had the open volume formatted in the Unix File System format (it seemed like the best option). I then ran the Live CD, but this time, if I selected the partiton disk manually option in the installer, the installer would crash, sans error given. If I selected Reformat entire disk or Use largest free space, it worked fine.

    I decided my next best choice was to let Kunbuntu reformat the entire disk and install itself, and I could repartition it later manually, and add OSX back in. Well, I'm ready to do that, but I can't seem to make the partition shrink like I hoped. I have QTParted installed. I have tried that and also poked around in fdisk.

    I am a newbie at Linux, with only a basic command of bash. I am even MORE of a newbie at OSX. Any suggestions?

  2. #2
    Just Joined!
    Join Date
    Jan 2006
    Posts
    17
    If you look (somewhere) in qtpartition, it'll tell you what filetypes it can resize, create, split, etc.

    somehow, you can easily mount a hfsplus filesystem on linux, but resizing it is a different story :-/

    may i suggest you make 3 partitions?
    hda1 = hfsplus for OS X and it is mounted as /osx/
    hda2 = ext3 for Kubuntu, and it is mounted as /
    hda3 = fat32, and it is mounted as /home/(yourname)

    Im guessing you didn't make an ext3 filesystem for the root directory. because, idk why, but you need a ext3 for root or else the system wont install. (im pretty sure on this)

    I have the new intel macs ^_^ and i have 2 HDDs.
    hda1 = fat32 for XP
    hda2 = ext3 for Linux
    hda3 = fat32 for /home/jorge

    hdb1 = hfsplus

    by the way, idk why, but you can't (or at least i can't) mount the hfsplus partition during installation. :-/ (you gotta mount it by hand by sudo mount -t hfsplus /dev/____ /somewhere/)

    hope this helps

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •