Find the answer to your Linux question:
Results 1 to 8 of 8
I tried playing a DVD movie last night because I wanted to know if the codecs were there. Movie Player poped up and gave me an error. So I installed ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! dapperone's Avatar
    Join Date
    Jun 2006
    Location
    Calgary
    Posts
    45

    about multimedia


    I tried playing a DVD movie last night because I wanted to know if the codecs were there. Movie Player poped up and gave me an error. So I installed Mplayer because the description said it would play all video formats. But when I put a DVD in my DVD ROM Mplayer has nothing to navigate to. I don't know which file on the DVD is the movie. There are dozens of files.
    Is there a way to play DVD movies?

  2. #2
    Linux Engineer Javasnob's Avatar
    Join Date
    Jul 2005
    Location
    Wisconsin
    Posts
    942
    With MPlayer, you can play them from the command line:
    Code:
    mplayer dvd://[track number]
    Read man mplayer for more. But I'm sure you want a nice, easy to use GUI; in that case, I highly recommend Xine. It's a great Movie Player.
    Flies of a particular kind, i.e. time-flies, are fond of an arrow.

    Registered Linux User #408794

  3. #3
    Linux Guru
    Join Date
    Nov 2004
    Posts
    6,110
    Have you installed all of the multimedia codecs for Ubuntu? I used the Automatix script which replaces/updates/installs as necessary. I've just checked my Ubuntu install and DVDs play automatically in Totem (Movie Player) when a disc is inserted.
    Last edited by bigtomrodney; 07-02-2006 at 03:01 PM.

  4. #4
    Just Joined! dapperone's Avatar
    Join Date
    Jun 2006
    Location
    Calgary
    Posts
    45

    yes and no

    Totem pops up and does the same thing. I don't know what Automatix is. I use Synaptic for installations.

  5. #5
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Quote Originally Posted by dapperone
    Totem pops up and does the same thing.
    Until you install the proper codecs, no program will be able to display DVDs.

    Something like that will do the trick (once your repositories are correctly configured) :
    Code:
    sudo apt-get install libdvdread3 
    sudo /usr/share/doc/libdvdread3/examples/install-css.sh
    More info here :
    http://ubuntuguide.org/wiki/Dapper

    Configuring repositories using Synaptic :
    http://ubuntuguide.org/wiki/Dapper#H....28Synaptic.29
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  6. #6
    Just Joined! dapperone's Avatar
    Join Date
    Jun 2006
    Location
    Calgary
    Posts
    45

    almost works

    The first sudo apt-get didn't do anything. The install-css gave me the ability to play the DVD but no sound.

  7. #7
    Linux Guru
    Join Date
    Nov 2004
    Posts
    6,110
    Are all of your sound channels turned up in gnome-volume-control?

  8. #8
    Just Joined! dapperone's Avatar
    Join Date
    Jun 2006
    Location
    Calgary
    Posts
    45

    seems to be working

    [Update] I got it figured out. I reconfigured my packages, did some updates, and now DVD movies play very well. I also did a 'dpkg-reconfigure xserver-xorg' and set display to 24-bit. The movies play slightly jittery but that's to be expected considering my video card and CPU speed.

    I checked all volume controls, everything is ok. This time I let the movie play while checking Preferences etc, and after about 40 seconds playing time the sound kicked in. The movie plays kind of jerky so I assume I'm choking the system between video and sound. My settings are at 32-bit video so maybe that's choking everything.
    I can't remember how to change from 32-bit to 24-bit, but I think it's in the xorg. I'll check my notes.
    Thanks for the help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •