Find the answer to your Linux question:
Results 1 to 3 of 3
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Dual Monitor but OpenGL Stretches game

    Ok, so I have my dual monitor setup running GREAT but the problem is whenever I start up World of Warcraft using Cedega, it tries to stretch the window to span the 2nd monitor but my setup blacks out the 2nd monitor. What I need it to do is just get it the size of my 1st monitor and just run the game on that. Get what I'm saying? Here is my xorg file:

    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig:  version 1.0  (buildmeister@builder3)  Mon May 15 13:23:42 PDT 2006
    # /etc/X11/xorg.conf (xorg X Window System server configuration file)
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    # Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
    # (Type "man /etc/X11/xorg.conf" at the shell prompt.)
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    Section "ServerLayout"
        Identifier     "Default Layout"
        Screen         "Default Screen" 0 0
        InputDevice    "Generic Keyboard"
        InputDevice    "Configured Mouse"
    Section "Files"
            # paths to defoma fonts
        FontPath        "/usr/share/X11/fonts/misc"
        FontPath        "/usr/share/X11/fonts/cyrillic"
        FontPath        "/usr/share/X11/fonts/100dpi/:unscaled"
        FontPath        "/usr/share/X11/fonts/75dpi/:unscaled"
        FontPath        "/usr/share/X11/fonts/Type1"
        FontPath        "/usr/share/X11/fonts/CID"
        FontPath        "/usr/share/X11/fonts/100dpi"
        FontPath        "/usr/share/X11/fonts/75dpi"
        FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
        FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
    Section "Module"
        Load           "i2c"
        Load           "bitmap"
        Load           "ddc"
        Load           "extmod"
        Load           "freetype"
        Load           "glx"
        Load           "int10"
        Load           "type1"
        Load           "vbe"
    Section "InputDevice"
        Identifier     "Generic Keyboard"
        Driver         "kbd"
        Option         "CoreKeyboard"
        Option         "XkbRules" "xorg"
        Option         "XkbModel" "pc104"
        Option         "XkbLayout" "us"
    Section "InputDevice"
        Identifier     "Configured Mouse"
        Driver         "mouse"
        Option         "CorePointer"
        Option         "Device" "/dev/input/mice"
        Option         "Protocol" "ImPS/2"
        Option         "Emulate3Buttons" "true"
        Option         "ZAxisMapping" "4 5"
    Section "Monitor"
        Identifier     "Generic Monitor"
        HorizSync       28.0 - 64.0
        VertRefresh     43.0 - 60.0
        Option         "DPMS"
    Section "Device"
        Identifier     "NVIDIA Corporation NV34 [GeForce FX 5500]"
        Driver         "nvidia"
    Option "TwinView" "on"
    #Option "MetaModes" "1024x768,1024x768"
     Option "MetaModes" "1280x1024,1280x1024"
    # Option "MetaModes" "1152x870,1024x768"
    # Option "MetaModes" "1152x870,1152x870"
    Option "TwinViewOrientation" "RightOf"
    Option "SecondMonitorHorizSync" "31.4-68.6"
    Option "SecondMonitorVertRefresh" "59-85"
    # The following options are for XGL
    # If you want to remove it, sudo rm /etc/gdm/gdm.conf-custom
    Option "RenderAccel" "true"
    Option "AllowGLXWithComposite" "true"
    # New additions
    Option "ConnectedMonitor" "CRT,CRT"
    Section "Screen"
        Identifier     "Default Screen"
        Device         "NVIDIA Corporation NV34 [GeForce FX 5500]"
        Monitor        "Generic Monitor"
        DefaultDepth    24
        SubSection     "Display"
            Depth       1
            Modes      "1280x1024" "1024x768" "800x600" "640x480"
        SubSection     "Display"
            Depth       4
            Modes      "1280x1024" "1024x768" "800x600" "640x480"
        SubSection     "Display"
            Depth       8
            Modes      "1280x1024" "1024x768" "800x600" "640x480"
        SubSection     "Display"
            Depth       15
            Modes      "1280x1024" "1024x768" "800x600" "640x480"
        SubSection     "Display"
            Depth       16
            Modes      "1280x1024" "1024x768" "800x600" "640x480"
        SubSection     "Display"
            Depth       24
            Modes      "1280x1024" "1024x768" "800x600" "640x480"

  2. #2
    Lol Guess nobody figured it out... But I got it fixed now! So no worries! :P

  3. #3
    This is fairly old to be bumping, so sorry, but I'm having the same problem myself. Can anyone post a solution?

  4. $spacer_open

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts