Find the answer to your Linux question:
Results 1 to 6 of 6
Hi I am very new at Linux and I've just installed ubuntu (dapper drake). In windows I can easily connect to the net by using my phones 3G modem via ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2006
    Posts
    2

    KPPP noauth requires root privledges


    Hi
    I am very new at Linux and I've just installed ubuntu (dapper drake). In windows I can easily connect to the net by using my phones 3G modem via bluetooth. I have managed to get connected to the phone via bluetooth and get the modem set up as well as rfcomm0. I am using KPPP- the problem is that the ISP does not use a username/password, so I have to specify the "noauth" option. When I try to connect though it give exit code 2- the noauth option requires root priviledges?
    Any ideas on how to get this working- I feel so close to getting this up and running, but I can't figure out how to run KPPP (in gnome) as root...
    Please could someone point me in the right direction.
    Thanks

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    hi johnpienaar !!

    i am surfing through bluetooth only... with noautho ISP.... if you are logged in as root then it should not give any error... even non-root user can use KPPP...
    well !! on activation it ask for root password... thats all... right now i am using KPPP as non-root user
    post ur modem string details.....

    <=== { casper } ===>
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Jul 2006
    Posts
    2
    Hi devils_casper!
    Thanks for the reply- becuase I'm new to ubuntu, I'm not sure which file to check for my modem string details. is it the etc\ppp\options file?
    How do you log in as root?
    Thanks for the help

  4. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    hi johnpienaar !!!

    you are welcome !!

    for logging in as root... type this command....
    $ su
    it will ask for password... when you type password... it wont display anything... not even ******
    type root password and press enter... you are root now...
    well !! right now you dont need to be root....

    for modem details...

    click on KPPP--> modem---> select your modem and click edit..
    there are three buttons... click one which shows details window... like timeout, connection string etc etc...
    post these details....

    <=== { casper } ===>
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  5. #5
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729

    Smile

    hi johnpienaar !!!

    check this link .....

    http://www.linuxforums.org/forum/sus...tml#post348351

    please do reply back !!!

    <=== { casper } ===>
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  6. #6
    Just Joined!
    Join Date
    Aug 2006
    Posts
    5

    kppp-noauth-requires-root

    Hi,

    had exactly the same problem

    open terminal

    "cd" to your /etc/ppp/peers/kppp (or some similar) path
    there should be a kppp config file there (kppp-config ?)

    while in terminal, type
    sudo gedit kppp-config (provided this is indeed kppp-config)
    unhash (that is delete # at the beginning of the line) the line reading
    # noauth

    In my case it worked by I then encountered problems with appending another ISPs numbers in kppp and switched over to gnome-ppp

    If it does not work, just switch over to gnome-ppp which producs no problems at all, it is what also what I finally did

    rafal

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •