Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
how do i enable 3d support? I have a nvidia graphics card...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2006
    Posts
    38

    3d support?


    how do i enable 3d support? I have a nvidia graphics card

  2. #2
    Just Joined!
    Join Date
    May 2006
    Posts
    38
    someone? anyone going to help?

  3. #3
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    Registered Linux user #270181
    TechieMoe's Tech Rants

  4. #4
    Just Joined!
    Join Date
    May 2006
    Posts
    38
    that worked....sort of. Now my sceen res is way to big i tried to edit it with system>preferences>screen res but only one options appears then i tried
    xrandr -s 1024x760
    but that didnt work. xrandr by itself returns this:
    SZ: Pixels Physical Refresh
    *0 640 x 480 ( 217mm x 163mm ) *60
    Current rotation - normal
    Current reflection - none
    Rotations possible - normal
    Reflections possible - none

  5. #5
    Just Joined!
    Join Date
    May 2006
    Posts
    38
    please help. When i use the vesa driver my screen resolution is fien, but when i dont its stuck at 640x480. I have to use the nvidia not he vesa driver to play 3d games, but i dont want bad screen resoution. If people dont hel soon i m gong bakc to fedora or suse

  6. #6
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    Your resolution problem is probably due to a misconfigured xorg.conf file. You can't edit this from the Ubuntu preferences menus; it must be done with a text editor with root (administrator) privileges. Ubuntu turns off the root account by default, so you'll need to use the sudo command, like this:

    To open the file:
    Code:
    sudo nano /etc/X11/xorg.conf
    Password: <enter your regular user password>
    Scroll down to the bottom of the file and look for a section that looks similar to this:
    Code:
    Subsection "Display"
            Depth       16
            Modes       "640x480"
            ViewPort    0 0
    EndSubsection
    Yours more than likely only has "640x480" in the Modes line. To add more resolutions, add them to the Modes line in quotation marks separated by a space. For a more complete set of available resolutions, make your mode line look like this:
    Code:
    Modes "1024x768" "800x600" "640x480"
    Your preferred default resolution should be first, followed by the lower resolutions. You'll probably have to do this for every depth listed (8, 16, 24, etc.) When you're done, hit CTRL+X and answer yes when it asks if you'd like to save. Now hit CTRL+ALT+BACKSPACE to restart the X Windows GUI and see if your default resolution is what you want.
    Registered Linux user #270181
    TechieMoe's Tech Rants

  7. #7
    Just Joined!
    Join Date
    May 2006
    Posts
    38
    thats not the problem here is my xconfig file:

    # /etc/X11/xorg.conf (xorg X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
    # (Type "man /etc/X11/xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    # sudo dpkg-reconfigure -phigh xserver-xorg

    Section "Files"
    FontPath "/usr/share/X11/fonts/misc"
    FontPath "/usr/share/X11/fonts/cyrillic"
    FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
    FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
    FontPath "/usr/share/X11/fonts/Type1"
    FontPath "/usr/share/X11/fonts/100dpi"
    FontPath "/usr/share/X11/fonts/75dpi"
    # path to defoma fonts
    FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    EndSection

    Section "Module"
    Load "i2c"
    Load "bitmap"
    Load "ddc"
    Load "dri"
    Load "extmod"
    Load "freetype"
    Load "glx"
    Load "int10"
    Load "type1"
    Load "vbe"
    EndSection

    Section "InputDevice"
    Identifier "Generic Keyboard"
    Driver "kbd"
    Option "CoreKeyboard"
    Option "XkbRules" "xorg"
    Option "XkbModel" "pc104"
    Option "XkbLayout" "us"
    EndSection

    Section "InputDevice"
    Identifier "Configured Mouse"
    Driver "mouse"
    Option "CorePointer"
    Option "Device" "/dev/input/mice"
    Option "Protocol" "ExplorerPS/2"
    Option "ZAxisMapping" "4 5"
    Option "Emulate3Buttons" "true"
    EndSection

    Section "InputDevice"
    Driver "wacom"
    Identifier "stylus"
    Option "Device" "/dev/wacom" # Change to
    # /dev/input/event
    # for USB
    Option "Type" "stylus"
    Option "ForceDevice" "ISDV4" # Tablet PC ONLY
    EndSection

    Section "InputDevice"
    Driver "wacom"
    Identifier "eraser"
    Option "Device" "/dev/wacom" # Change to
    # /dev/input/event
    # for USB
    Option "Type" "eraser"
    Option "ForceDevice" "ISDV4" # Tablet PC ONLY
    EndSection

    Section "InputDevice"
    Driver "wacom"
    Identifier "cursor"
    Option "Device" "/dev/wacom" # Change to
    # /dev/input/event
    # for USB
    Option "Type" "cursor"
    Option "ForceDevice" "ISDV4" # Tablet PC ONLY
    EndSection

    Section "Device"
    Identifier "NVIDIA Corporation NV18 [GeForce4 MX - nForce GPU]"
    Driver "nvidia"
    BusID "PCI:1:0:0"
    EndSection

    Section "Monitor"
    Identifier "ULTRASCANP99"
    Option "DPMS"
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    Device "NVIDIA Corporation NV18 [GeForce4 MX - nForce GPU]"
    Monitor "ULTRASCANP99"
    DefaultDepth 24
    SubSection "Display"
    Depth 1
    Modes "1280x1024" "1024x768" "800x600" "720x400" "720x350" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 4
    Modes "1280x1024" "1024x768" "800x600" "720x400" "720x350" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "1280x1024" "1024x768" "800x600" "720x400" "720x350" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 15
    Modes "1280x1024" "1024x768" "800x600" "720x400" "720x350" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "1280x1024" "1024x768" "800x600" "720x400" "720x350" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1280x1024" "1024x768" "800x600" "720x400" "720x350" "640x480"
    EndSubSection
    EndSection

    Section "ServerLayout"
    Identifier "Default Layout"
    Screen "Default Screen"
    InputDevice "Generic Keyboard"
    InputDevice "Configured Mouse"
    InputDevice "stylus" "SendCoreEvents"
    InputDevice "cursor" "SendCoreEvents"
    InputDevice "eraser" "SendCoreEvents"
    EndSection

    Section "DRI"
    Mode 0666
    EndSection

  8. #8
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    Remove this line from the load statements at the top for starters and see if you're still having trouble.

    Code:
    Load  "dri"
    Registered Linux user #270181
    TechieMoe's Tech Rants

  9. #9
    Just Joined!
    Join Date
    May 2006
    Posts
    38
    that didnt work

  10. #10
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    Are you sure the Nvidia driver installed correctly? What do you see when you do a lsmod | grep nvidia from the command line?
    Registered Linux user #270181
    TechieMoe's Tech Rants

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •