Find the answer to your Linux question:
Results 1 to 4 of 4
just like the title says. i dont want to get the one that is seen on the internet, just the one my router gives to my computer. i tried ifconfig, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2006
    Posts
    20

    how do i get my internal network ip?


    just like the title says. i dont want to get the one that is seen on the internet, just the one my router gives to my computer. i tried ifconfig, but that only gave me a 127 ip and not a 129 ip, which is what i need so i can port forward. thanks.

  2. #2
    Linux Enthusiast
    Join Date
    Aug 2005
    Location
    Hell
    Posts
    514
    Quote Originally Posted by speedy11309
    i tried ifconfig, but that only gave me a 127 ip and not a 129 ip, which is what i need so i can port forward. thanks.
    What does this mean? Can you post the output of ifconfig? What is a "129 ip"? You will always have a loopback interface (lo) which has the localhost IP (127.0.0.1); this is not what you are looking for. And hopefully you will have other real network interfaces (eth0, etc.) which will have IP addresses.

  3. #3
    Just Joined!
    Join Date
    Jul 2006
    Posts
    20
    yeah i rebooted the thing 3 times then it finally changed the ip from 127.0.0.1 to 129.168.whatever. it was wierd. i dont really know how to explain it.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Sep 2005
    Posts
    15

    network connection

    i got my pc setup this morning to connect online. i have ubuntu 6.06. anyway, i went into System, then Administration, then Network. click on Ethernet connection (which has a picture of a NIC next to it) that says The interface eth1 is active (or yours might show not configured). click on properties and it should say Connection Interface name: eth1 (or eth0). make sure "Enable this connection" box is checked.
    under Connection settings, in the Configuration section, mine is set as Static IP address. in the IP address i set mine to 192.168.1.100 because this pc is my basestation in my network. Subnet mask is 255.255.255.0 and Gateway address is 192.168.1.1.
    try these settings. see if they work.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •