Find the answer to your Linux question:
Results 1 to 5 of 5
I'm using kubuntu Dapper Drake, and (because I need "kde includes" to install certain software), I would like to install at least one of: kdelibs4-dev kde-devel kdebase-dev packages (these are ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2006
    Location
    Australia
    Posts
    5

    Adept threatens "BREAK (install)"


    I'm using kubuntu Dapper Drake, and (because I need "kde includes" to install certain software), I would like to install at least one of:
    kdelibs4-dev
    kde-devel
    kdebase-dev
    packages (these are the packages more advanced users have recommended). Adept Package Manager can find them, but if I request install, the requested action becomes "BREAK (install)". What is it going to break? How can I find out (please note, there is currently no documentation for adept)? Or, what else can I do to get the "kde includes" (whatever they really are)?

  2. #2
    Linux User Kojak's Avatar
    Join Date
    Apr 2006
    Posts
    421
    I wonder what should break your installation if you install development packages. You can try to install them with apt-get from a command line. Apt-get should have an option to check an installation prior to performing it. That would be more secure than using adept.

    sudo apt-get kdebase-dev kde-devel kdelibs4-dev
    Windows free since 2002 | computing since 1984

  3. #3
    Just Joined!
    Join Date
    Jul 2006
    Location
    Australia
    Posts
    5
    Thanks for trying, Kojak... see below for results ( "-s" is supposed to simulate the command only (no action)). My interpretation is that an install of (in this instance) kdelibs4-dev would indeed break something, but I am no closer to being enlightened as to what...

    Any other ideas?

    Code:
    user@daniel-jackson:~/rosegarden-1.2.4$ sudo apt-get -s install kdelibs4-dev
    Reading package lists... Done
    Building dependency tree... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    
    Since you only requested a single operation it is extremely likely that
    the package is simply not installable and a bug report against
    that package should be filed.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
      kdelibs4-dev: Depends: kdelibs4c2a (= 4:3.5.2-0ubuntu18) but 4:3.5.3-0ubuntu0.1 is to be installed
                    Depends: kdelibs-bin (= 4:3.5.2-0ubuntu18) but 4:3.5.3-0ubuntu0.1 is to be installed
                    Depends: libarts1-dev (>= 1.5-rc1) but it is not going to be installed
    E: Broken packages
    user@daniel-jackson:~/rosegarden-1.2.4$ sudo apt-get -s install libarts1-dev
    Reading package lists... Done
    Building dependency tree... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    
    Since you only requested a single operation it is extremely likely that
    the package is simply not installable and a bug report against
    that package should be filed.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
      libarts1-dev: Depends: libarts1c2a (= 1.5.2-0ubuntu1) but 1.5.3-0ubuntu0.1 is to be installed
                    Depends: libartsc0-dev (= 1.5.2-0ubuntu1) but it is not going to be installed
    E: Broken packages
    user@daniel-jackson:~/rosegarden-1.2.4$ sudo apt-get -s install libartsc0-dev
    Reading package lists... Done
    Building dependency tree... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    
    Since you only requested a single operation it is extremely likely that
    the package is simply not installable and a bug report against
    that package should be filed.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
      libartsc0-dev: Depends: libartsc0 (= 1.5.2-0ubuntu1) but 1.5.3-0ubuntu0.1 is to be installed
    E: Broken packages
    Please note that "is to be installed" seems to mean "is already installed".

  4. #4
    Linux User Kojak's Avatar
    Join Date
    Apr 2006
    Posts
    421
    I would check their bugtracker now. It looks as if there is really something broken in Kubuntu.
    Windows free since 2002 | computing since 1984

  5. #5
    Just Joined!
    Join Date
    Jul 2006
    Location
    Australia
    Posts
    5
    Thanks Kojak -- it turned out my repo list was missing
    deb http://kubuntu.org/packages/kde-latest/ dapper main
    so maybe something wrong with the install, or something automatix did to the repo list (which now has
    Code:
    ## Automatix sources.list
    ## This is automatically generated by Automatix
    at the start.

    http://kubuntuforums.net/forums/index.php?topic=7159.0

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •