Find the answer to your Linux question:
Results 1 to 3 of 3
Hello all, I am a linux newbie who has a Belkin F5D7000 PCI wireless card, which i installed using the bcm43xx-fwcutter and wl_apsta.o driver. I get internet access using WEP, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2006
    Posts
    21

    WPA problems


    Hello all, I am a linux newbie who has a Belkin F5D7000 PCI wireless card, which i installed using the bcm43xx-fwcutter and wl_apsta.o driver. I get internet access using WEP, but I can't configure the wpa_supplicant that comes with Ubuntu Dapper Drake. Whenever I use the command
    Code:
    sudo wpa_supplicant -Dwext -iwlan0 -c/home/"username"/wpa_supplicant.conf
    I end up with
    Code:
    ioctl[SIOCSIWPMKSA]: No such device
    ioctl[SIOCSIWMODE]: No such device
    Could not configure driver to use managed mode
    ioctl[SIOCGIFFLAGS]: No such device
    Could not set interface 'wlan0' UP
    ioctl[SIOCGIWRANGE]: No such device
    ioctl[SIOCGIFINDEX]: No such device
    ioctl[SIOCSIWENCODEEXT]: No such device
    ioctl[SIOCSIWENCODE]: No such device
    ioctl[SIOCSIWENCODEEXT]: No such device
    ioctl[SIOCSIWENCODE]: No such device
    ioctl[SIOCSIWENCODEEXT]: No such device
    ioctl[SIOCSIWENCODE]: No such device
    ioctl[SIOCSIWENCODEEXT]: No such device
    ioctl[SIOCSIWENCODE]: No such device
    ioctl[SIOCSIWAUTH]: No such device
    WEXT auth param 7 value 0x0 - Failed to disable WPA in the driver.
    ioctl[SIOCSIWAUTH]: No such device
    WEXT auth param 5 value 0x0 - ioctl[SIOCSIWAUTH]: No such device
    WEXT auth param 4 value 0x0 - ioctl[SIOCSIWAP]: No such device
    ioctl[SIOCGIFFLAGS]: No such device
    I appreciate any help in getting WPA-PSK to work on my box.

  2. #2
    Linux Newbie objuan's Avatar
    Join Date
    Jul 2006
    Location
    california
    Posts
    234
    Hello
    You must check out wireless card before purchasing most card are for windows and use a boardcom chip set and I suspect that the card you are using is boardcom. linux will not work with this chip set. most all other chip sets will work.

  3. #3
    Just Joined!
    Join Date
    Jun 2006
    Posts
    21
    Thanks for the reply. Somehow it started working without me using wpa supplicant at all, I installed NetworkManager, and at first it detected no wireless card, but either after a restart or something else happening, it detected my card and immediately set up the network!

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •