Find the answer to your Linux question:
Results 1 to 5 of 5
I followed this tutorial from a previous post on how to remove the graphical startup and automatically log in http://doc.gwos.org/index.php/Automa...Authentication After doing so it loaded the default .Xsession in my ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! EvanPMeth's Avatar
    Join Date
    Oct 2006
    Posts
    20

    Ubuntu non-gdm change in resolution


    I followed this tutorial from a previous post on how to remove the graphical startup and automatically log in http://doc.gwos.org/index.php/Automa...Authentication

    After doing so it loaded the default .Xsession in my user folder instead of the blackbox.desktop file in /usr/share/xsessions which referenced .bbstartup.sh in my user folder.

    So I changed the .Xsession file to look exactly like my .bbstartup.sh file and it started up all the same programs as before.

    Everything was the same except the resolution seemed to change because all teh windows and text were a great deal larger. Why would that change?

    I am still using the same xorg.conf file because both of my screens still work, It doesnt make sense to me why the resolution would change. There is still an nvidia logo on start up.

    My only thought is that maybe ubuntu loads some sort of graphical manager/config file or something when gdm starts up.

    It has to be with the resolution of differnt windows, firefox looks the same but everything else doesnt. I reinstalled gdm and logged in and everything was back to normal.

    Does anyone know of way to auto-login with out loosing settings?

    I need some help bad. I cant stand looking at large text.

    If you have any questions ill be happy to answer.

    thanks

  2. #2
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Perhaps you can try
    Code:
    startx -- -dpi 100
    in your .bash_profile instead of simply "startx" as specifyed in the tutorial you pointed out.
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  3. #3
    Just Joined! EvanPMeth's Avatar
    Join Date
    Oct 2006
    Posts
    20

    hmm

    that didnt seem to change anything, Ive read other posts on the same problem but there was no logical reason or solution. thanks for the help, srry for the delay.
    -evan

  4. #4
    Just Joined! EvanPMeth's Avatar
    Join Date
    Oct 2006
    Posts
    20
    i think i figured a little something out when ubuntu desktop doesnt startup a font library isnt started.

    its not actually my resolution its fonts that were present before are gone now so it falls back to default

    what font libraries are loaded when ubuntu starts?

  5. #5
    Just Joined! EvanPMeth's Avatar
    Join Date
    Oct 2006
    Posts
    20

    Resolution

    [QUOTE=antidrugue]Perhaps you can try
    Code:
    startx -- -dpi 100
    The actual solution is stteing the DPI lower for smaller font. X set my dpi to 100 for the monitor i have. To set a defualt dpi with an nvidia card
    Code:
    Option   "DPI"   "75 x 75"
    This solved the problem of large looking font.

    Sorry for the delay on response.
    I am still learning.

    -EvanPMeth

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •